kernel: bump 5.4 to 5.4.126
authorJohn Audia <graysky@archlinux.us>
Wed, 23 Jun 2021 07:00:02 +0000 (03:00 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 26 Jun 2021 10:49:15 +0000 (12:49 +0200)
Manually rebased:
  bcm27xx/patches-5.4/950-0089-cgroup-Disable-cgroup-memory-by-default.patch

All other patches automatically rebased.

Signed-off-by: John Audia <graysky@archlinux.us>
13 files changed:
include/kernel-version.mk
target/linux/bcm27xx/patches-5.4/950-0089-cgroup-Disable-cgroup-memory-by-default.patch
target/linux/bcm27xx/patches-5.4/950-0134-spi-spi-bcm2835-Disable-forced-software-CS.patch
target/linux/bcm27xx/patches-5.4/950-0212-spi-bcm2835-enable-shared-interrupt-support.patch
target/linux/bcm27xx/patches-5.4/950-0409-SQUASH-Fix-spi-driver-compiler-warnings.patch
target/linux/bcm27xx/patches-5.4/950-0646-spi-Force-CS_HIGH-if-GPIO-descriptors-are-used.patch
target/linux/bcm27xx/patches-5.4/950-0665-spi-use_gpio_descriptor-fixup-moved-to-spi_setup.patch
target/linux/bcm27xx/patches-5.4/950-0690-SQUASH-spi-Demote-SPI_CS_HIGH-warning-to-KERN_DEBUG.patch
target/linux/bcm27xx/patches-5.4/950-0788-Revert-SQUASH-Fix-spi-driver-compiler-warnings.patch
target/linux/bcm27xx/patches-5.4/950-0789-Revert-spi-spi-bcm2835-Disable-forced-software-CS.patch
target/linux/generic/config-5.4
target/linux/generic/hack-5.4/221-module_exports.patch
target/linux/mediatek/patches-5.4/0001-v5.7-spi-make-spi-max-frequency-optional.patch

index 4bd243663c20389d01d0c9ff6287a47ccc926c9c..d3d08a6d3399f1f137495c0625c694d77d826b8f 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .125
+LINUX_VERSION-5.4 = .126
 LINUX_VERSION-5.10 = .46
 
-LINUX_KERNEL_HASH-5.4.125 = 17ee750a4aeb1c883d721e730d1f7e2855124585e2f47766864a1359a7ebe33c
+LINUX_KERNEL_HASH-5.4.126 = c7fd7998ab36b574326bbd67bcc2b74e4c58e81581a5f8a7a71af5185f635277
 LINUX_KERNEL_HASH-5.10.46 = 569122a39c6b325befb9ac1c07da0c53e6363b3baacd82081d131b06c1dc1415
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 86f60e7052f4a3c0c3dd0982f8450f7b647d2b07..d4818b22399660c4d96a20e6a1415d4efb538c37 100644 (file)
@@ -1,4 +1,4 @@
-From 0f95a2f2688ff44dc7080beaa2076741a0bdf510 Mon Sep 17 00:00:00 2001
+From 2b13c54592135b6fab269517ed687fa9f80bf8e5 Mon Sep 17 00:00:00 2001
 From: Phil Elwell <phil@raspberrypi.org>
 Date: Mon, 27 Nov 2017 17:14:54 +0000
 Subject: [PATCH] cgroup: Disable cgroup "memory" by default
@@ -12,34 +12,46 @@ See: https://github.com/raspberrypi/linux/issues/1950
 
 Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 ---
- kernel/cgroup/cgroup.c | 3++++++++++++++++++++++++++++++
- 1 file changed, 30 insertions(+)
+ kernel/cgroup/cgroup.c | 38 ++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 38 insertions(+)
 
 --- a/kernel/cgroup/cgroup.c
 +++ b/kernel/cgroup/cgroup.c
-@@ -5722,6 +5722,8 @@ int __init cgroup_init_early(void)
+@@ -5721,6 +5721,9 @@ int __init cgroup_init_early(void)
+       return 0;
  }
  
- static u16 cgroup_disable_mask __initdata;
 +static u16 cgroup_enable_mask __initdata;
 +static int __init cgroup_disable(char *str);
++
  /**
   * cgroup_init - cgroup initialization
-@@ -5761,6 +5763,12 @@ int __init cgroup_init(void)
+  *
+@@ -5759,6 +5762,12 @@ int __init cgroup_init(void)
  
        mutex_unlock(&cgroup_mutex);
  
-+      /* Apply an implicit disable... */
++      /*
++       * Apply an implicit disable, knowing that an explicit enable will
++       * prevent if from doing anything.
++       */
 +      cgroup_disable("memory");
-+
-+      /* ...knowing that an explicit enable will override it. */
-+      cgroup_disable_mask &= ~cgroup_enable_mask;
 +
        for_each_subsys(ss, ssid) {
                if (ss->early_init) {
                        struct cgroup_subsys_state *css =
-@@ -6180,6 +6188,28 @@ static int __init cgroup_disable(char *s
+@@ -6168,6 +6177,10 @@ static int __init cgroup_disable(char *s
+                           strcmp(token, ss->legacy_name))
+                               continue;
++                      /* An explicit cgroup_enable overrides a disable */
++                      if (cgroup_enable_mask & (1 << i))
++                              continue;
++
+                       static_branch_disable(cgroup_subsys_enabled_key[i]);
+                       pr_info("Disabling %s control group subsystem\n",
+                               ss->name);
+@@ -6177,6 +6190,31 @@ static int __init cgroup_disable(char *s
  }
  __setup("cgroup_disable=", cgroup_disable);
  
@@ -59,6 +71,9 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 +                              continue;
 +
 +                      cgroup_enable_mask |= 1 << i;
++                      static_branch_enable(cgroup_subsys_enabled_key[i]);
++                      pr_info("Enabling %s control group subsystem\n",
++                              ss->name);
 +              }
 +      }
 +      return 1;
index 0abe5059c0df04eaafe65db5aea7490ba10600cf..cfb46d87913a640206640a2d08682a31cd1b2f15 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/spi/spi-bcm2835.c
 +++ b/drivers/spi/spi-bcm2835.c
-@@ -1230,31 +1230,6 @@ static int bcm2835_spi_setup(struct spi_
+@@ -1236,31 +1236,6 @@ static int bcm2835_spi_setup(struct spi_
                return -EINVAL;
        }
  
index f82ae7d9f690a12ab18dbe47a89c81b2eebebd78..5326934b7122a3b232f0d8afeaca8f5fdf26a791 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Martin Sperl <kernel@martin.sperl.org>
        /* Read as many bytes as possible from FIFO */
        bcm2835_rd_fifo(bs);
        /* Write as many bytes as possible to FIFO */
-@@ -1281,7 +1285,8 @@ static int bcm2835_spi_probe(struct plat
+@@ -1287,7 +1291,8 @@ static int bcm2835_spi_probe(struct plat
        bcm2835_wr(bs, BCM2835_SPI_CS,
                   BCM2835_SPI_CS_CLEAR_RX | BCM2835_SPI_CS_CLEAR_TX);
  
index 44134391011334baaad42fd19560a37202f25881..742dbad7120797b9102c4d41b205e92af5cece3f 100644 (file)
@@ -19,4 +19,4 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 -      struct gpio_chip *chip;
        u32 cs;
  
-       /*
+       if (spi->chip_select >= BCM2835_SPI_NUM_CS) {
index 6ee6a275c305257b75693808be19f4f12f0aedca..05fa9f8f2ec2e2fb24c351ff2169f6c918376fca 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 
 --- a/drivers/spi/spi.c
 +++ b/drivers/spi/spi.c
-@@ -3110,6 +3110,7 @@ static int __spi_validate_bits_per_word(
+@@ -3116,6 +3116,7 @@ static int __spi_validate_bits_per_word(
   */
  int spi_setup(struct spi_device *spi)
  {
@@ -31,7 +31,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
        unsigned        bad_bits, ugly_bits;
        int             status;
  
-@@ -3127,6 +3128,14 @@ int spi_setup(struct spi_device *spi)
+@@ -3133,6 +3134,14 @@ int spi_setup(struct spi_device *spi)
                (SPI_TX_DUAL | SPI_TX_QUAD | SPI_TX_OCTAL |
                 SPI_RX_DUAL | SPI_RX_QUAD | SPI_RX_OCTAL)))
                return -EINVAL;
index 8792faa0c9bee5e40863ebc332068939052327be..402635d838b27fa36d1da43cccacb849bb65b405 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 
 --- a/drivers/spi/spi.c
 +++ b/drivers/spi/spi.c
-@@ -1793,15 +1793,6 @@ static int of_spi_parse_dt(struct spi_co
+@@ -1799,15 +1799,6 @@ static int of_spi_parse_dt(struct spi_co
        }
        spi->chip_select = value;
  
index fee107876a178fd1ba8147d24abf6cfcacf990b6..b821afb08b44be79355734941e31ed5b0aec4894 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 
 --- a/drivers/spi/spi.c
 +++ b/drivers/spi/spi.c
-@@ -3122,8 +3122,8 @@ int spi_setup(struct spi_device *spi)
+@@ -3128,8 +3128,8 @@ int spi_setup(struct spi_device *spi)
  
        if (ctlr->use_gpio_descriptors && ctlr->cs_gpiods &&
            ctlr->cs_gpiods[spi->chip_select] && !(spi->mode & SPI_CS_HIGH)) {
index 437e5aba5954cc06f9c4220572648c49eaca9c88..fad57b4863977bbe18a5b2773b26a8261845c97d 100644 (file)
@@ -20,4 +20,4 @@ See: https://github.com/raspberrypi/linux/pull/3687
 +      enum gpio_lookup_flags lflags;
        u32 cs;
  
-       /*
+       if (spi->chip_select >= BCM2835_SPI_NUM_CS) {
index 14793352172d9cc9c3c156db55b88d07cc72fb1c..ac0684be8629b6333070447d82bbdfb20c51e407 100644 (file)
@@ -13,7 +13,7 @@ See: https://github.com/raspberrypi/linux/pull/3687
 
 --- a/drivers/spi/spi-bcm2835.c
 +++ b/drivers/spi/spi-bcm2835.c
-@@ -1235,6 +1235,43 @@ static int bcm2835_spi_setup(struct spi_
+@@ -1241,6 +1241,43 @@ static int bcm2835_spi_setup(struct spi_
                return -EINVAL;
        }
  
index f5e976a6910191a9c97875da85d9518b0a5ff236..fe5204abb55ad7e0b96745921f30e4eabcf43257 100644 (file)
@@ -3833,6 +3833,7 @@ CONFIG_NMI_LOG_BUF_SHIFT=13
 # CONFIG_NVMEM_SYSFS is not set
 # CONFIG_NVME_FC is not set
 # CONFIG_NVME_TARGET is not set
+# CONFIG_NVME_TCP is not set
 # CONFIG_NVRAM is not set
 # CONFIG_NV_TCO is not set
 # CONFIG_NXP_STB220 is not set
index 09855b04d1f626924a818050ed5f94a09cae7dca..ef6e980892babd3735b78248ebee9033c9a78523 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }                                                               \
                                                                        \
        /* __*init sections */                                          \
-@@ -903,6 +913,8 @@
+@@ -904,6 +914,8 @@
        EXIT_TEXT                                                       \
        EXIT_DATA                                                       \
        EXIT_CALL                                                       \
index 8487c3dda0b80539c53ebb035d24366f5ece3ca8..79ce15c37b61b2854a3f4c7a63c7ef3838953b84 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/spi/spi.c
 +++ b/drivers/spi/spi.c
-@@ -1803,13 +1803,8 @@ static int of_spi_parse_dt(struct spi_co
+@@ -1809,13 +1809,8 @@ static int of_spi_parse_dt(struct spi_co
                spi->mode |= SPI_CS_HIGH;
  
        /* Device speed */