brcm2708: bcm2711: remove unneeded boot file
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Fri, 9 Aug 2019 05:37:51 +0000 (07:37 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Fri, 9 Aug 2019 08:21:17 +0000 (10:21 +0200)
bootcode.bin isn't needed for RPi 4B since it's stored on a SPI-attached EEPROM.
More info: https://www.raspberrypi.org/documentation/hardware/raspberrypi/booteeprom.md

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/brcm2708/image/Makefile

index a9afa4e915d1d20994e30616966a5fb6b3648606..f1a4bb8dc49cfdf7d4020ecbcffdf9a7367d70e1 100644 (file)
@@ -25,7 +25,6 @@ define Build/boot-common
        rm -f $@.boot
        mkfs.fat -C $@.boot $(FAT32_BLOCKS)
        mcopy -i $@.boot $(KDIR)/COPYING.linux ::
-       mcopy -i $@.boot $(KDIR)/bootcode.bin ::
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
        mcopy -i $@.boot cmdline.txt ::
        mcopy -i $@.boot $(BOOT_CONFIG) ::config.txt
@@ -37,6 +36,7 @@ define Build/boot-common
 endef
 
 define Build/boot-2708
+       mcopy -i $@.boot $(KDIR)/bootcode.bin ::
        mcopy -i $@.boot $(KDIR)/start.elf ::
        mcopy -i $@.boot $(KDIR)/start_cd.elf ::
        mcopy -i $@.boot $(KDIR)/start_x.elf ::
@@ -131,7 +131,6 @@ endif
 define Device/rpi-4
   DEVICE_MODEL := 4B
   KERNEL_IMG := kernel8.img
-  DEVICE_TITLE := Raspberry Pi 4B
   DEVICE_DTS := broadcom/bcm2711-rpi-4-b
   SUPPORTED_DEVICES := \
        raspberrypi,4-model-b