ramips: refresh patches
authorGabor Juhos <juhosg@openwrt.org>
Sat, 11 Feb 2012 15:11:40 +0000 (15:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 11 Feb 2012 15:11:40 +0000 (15:11 +0000)
SVN-Revision: 30435

target/linux/ramips/patches-2.6.39/105-ramips-spi-driver.patch
target/linux/ramips/patches-2.6.39/105-usb_dwc_otg.patch

index 1ca174da48d214d2df7c31e9d3dbe77a7ff35011..777a5258a65d67680db7fb895f56a21ea5ffb6a3 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -283,6 +283,12 @@ config SPI_PXA2XX
-         The driver can be configured to use any SSP port and additional
-         documentation can be found a Documentation/spi/pxa2xx.
+@@ -310,6 +310,12 @@ config SPI_PXA2XX
+ config SPI_PXA2XX_PCI
+       def_bool SPI_PXA2XX && X86_32 && PCI
  
 +config SPI_RAMIPS
 +      tristate "Ralink RT288x/RT305x SPI Controller"
@@ -15,7 +15,7 @@
        depends on ARCH_S3C2410 && EXPERIMENTAL
 --- a/drivers/spi/Makefile
 +++ b/drivers/spi/Makefile
-@@ -37,6 +37,7 @@ obj-$(CONFIG_SPI_FSL_LIB)            += spi_fsl_li
+@@ -42,6 +42,7 @@ obj-$(CONFIG_SPI_FSL_LIB)            += spi_fsl_li
  obj-$(CONFIG_SPI_FSL_ESPI)            += spi_fsl_espi.o
  obj-$(CONFIG_SPI_FSL_SPI)             += spi_fsl_spi.o
  obj-$(CONFIG_SPI_PPC4xx)              += spi_ppc4xx.o
index 583202c528d2674cba60ceefff07a64bda02b7d8..1840c9d75a70ffd2538f535b7e6de07dbd59554c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/Kconfig
 +++ b/drivers/usb/Kconfig
-@@ -163,4 +163,6 @@
+@@ -164,4 +164,6 @@ source "drivers/usb/gadget/Kconfig"
  
  source "drivers/usb/otg/Kconfig"
  
@@ -9,7 +9,7 @@
  endif # USB_SUPPORT
 --- a/drivers/usb/Makefile
 +++ b/drivers/usb/Makefile
-@@ -45,3 +45,4 @@
+@@ -45,3 +45,4 @@ obj-$(CONFIG_EARLY_PRINTK_DBGP)      += early
  
  obj-$(CONFIG_USB_ATM)         += atm/
  obj-$(CONFIG_USB_SPEEDTOUCH)  += atm/