tools/meson: static host and both libraries
authorRosen Penev <rosenp@gmail.com>
Wed, 21 Feb 2024 21:16:35 +0000 (13:16 -0800)
committerPaul Spooren <mail@aparcar.org>
Fri, 29 Mar 2024 22:42:22 +0000 (23:42 +0100)
Host packages typically are statically linked to avoid rpath issues and
to avoid libraries not being found as a result. With target packages,
both libraries make the most sense as InstallDev typically installs
both, giving packages flexibility. Default this behavior.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/meson.mk

index 65716746fe1eec4aaf3ac03c8069c960eb4c3476..2a20c2bd6bd04ef7164d2564591ced8e3fcd7bc0 100644 (file)
@@ -100,6 +100,7 @@ define Host/Configure/Meson
        $(call Meson, \
                setup \
                --native-file $(HOST_BUILD_DIR)/openwrt-native.txt \
+               -Ddefault_library=static \
                $(MESON_HOST_ARGS) \
                $(MESON_HOST_BUILD_DIR) \
                $(MESON_HOST_BUILD_DIR)/.., \
@@ -126,6 +127,7 @@ define Build/Configure/Meson
                --buildtype plain \
                --native-file $(PKG_BUILD_DIR)/openwrt-native.txt \
                --cross-file $(PKG_BUILD_DIR)/openwrt-cross.txt \
+               -Ddefault_library=both \
                $(MESON_ARGS) \
                $(MESON_BUILD_DIR) \
                $(MESON_BUILD_DIR)/.., \