ar71xx: add profile and build initramfs image for the WNDR4300
authorGabor Juhos <juhosg@openwrt.org>
Wed, 12 Dec 2012 16:49:52 +0000 (16:49 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 12 Dec 2012 16:49:52 +0000 (16:49 +0000)
It is not yet possible to use the default squasfsh/jffs2 images
on NAND flashes, so only initramfs image is supported for now.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34650

target/linux/ar71xx/generic/profiles/netgear.mk
target/linux/ar71xx/image/Makefile

index fe136234f6f8abfd33cf928a38df8d65c4b44c7d..ff25f695a029f35662f9d68406773273173e747c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,3 +15,16 @@ define Profile/WNDR3700/Description
 endef
 
 $(eval $(call Profile,WNDR3700))
+
+
+define Profile/WNDR4300
+       NAME:=NETGEAR WNDR4300
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNDR4300/Description
+       Package set optimized for the NETGEAR WNDR4300
+endef
+
+$(eval $(call Profile,WNDR4300))
+
index b51e8c79f0a28b796aeef8838b44644b54a496ca..53b4f90a0a53a37f59d6fa62f860cae209cbdee3 100644 (file)
@@ -183,6 +183,7 @@ ubdev_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6
 whrhpg300n_mtdlayout=mtdparts=spi0.0:248k(u-boot)ro,8k(u-boot-env)ro,960k(kernel),2816k(rootfs),64k(art)ro,3712k@0x40000(firmware)
 wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
 wndr3700v2_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),14848k(rootfs),64k(art)ro,15872k@0x70000(firmware)
+wndr4300_mtdlayout=mtdparts=ar934x-nfc:256k(u-boot)ro,256k(u-boot-env)ro,256k(caldata),512k(pot),2048k(language),512k(config),3072k(traffic_meter),1152k(kernel),24448k(rootfs),25600k@0x6c0000(firmware),256k(caldata_backup),-(reserved)
 zcn1523h_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6208k(rootfs),1472k(kernel),64k(configure)ro,64k(mfg)ro,64k(art)ro,7680k@0x50000(firmware)
 
 define Image/BuildKernel
@@ -662,6 +663,10 @@ define Image/Build/Netgear/initramfs
                $(5)
 endef
 
+define Image/Build/NetgearNAND/initramfs
+       $(call Image/Build/Netgear/initramfs,$(1),$(2),$(3),$(4),$(5))
+endef
+
 ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
   define Image/Build/ZyXEL
        $(call MkuImageLzma,$(2),$(3))
@@ -832,6 +837,8 @@ $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3800,wndr3800,WNDR3700,ttyS0,1
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDRMAC,wndrmac,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDRMAC,"",-H 29763654+16+64))
 $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDRMACV2,wndrmacv2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDRMACv2,"",-H 29763654+16+128))
 
+$(eval $(call SingleProfile,NetgearNAND,$(fs_64k),WNDR4300,wndr4300,WNDR4300,ttyS0,115200,$$(wndr4300_mtdlayout),3703,WNDR4300,"",-H 29763948+0+128+128+2x2+3x3))
+
 $(eval $(call SingleProfile,OpenMesh,$(fs_squash),OM2P,om2p,,,,OM2P))
 $(eval $(call SingleProfile,OpenMesh,$(fs_squash),MR600,mr600,,,,MR600))