wireguard-tools: drop the dependency on ip-{tiny,full}
authorRui Salvaterra <rsalvaterra@gmail.com>
Thu, 5 Nov 2020 11:37:16 +0000 (11:37 +0000)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 14 Nov 2020 16:46:35 +0000 (17:46 +0100)
BusyBox ip already provides the required functionality and is enabled by default
in OpenWrt. This patch drops the ip dependency and makes the BusyBox ip required
dependencies explicit, allowing for a significant image size reduction.

openwrt-ath79-generic-ubnt_nanostation-loco-m-squashfs-sysupgrade.bin size:
4588354 bytes (with ip-tiny)
4457282 bytes (with BusyBox ip)

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/network/utils/wireguard-tools/Makefile

index a5264a50b4aa03405ca7066e321eb1456dd1aa1c..07258fde986c8156a6b3ef3bed9c23d13f40ff3b 100644 (file)
@@ -32,7 +32,7 @@ MAKE_VARS += PLATFORM=linux
 define Package/wireguard-tools
   $(call Package/wireguard/Default)
   TITLE:=WireGuard userspace control program (wg)
-  DEPENDS:=+ip
+  DEPENDS:=+@BUSYBOX_CONFIG_IP +@BUSYBOX_CONFIG_FEATURE_IP_LINK
 endef
 
 define Package/wireguard-tools/description