oxnas: change file extension of u-boot+initramfs image
authorFelix Fietkau <nbd@openwrt.org>
Sun, 14 Jun 2015 17:42:00 +0000 (17:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 14 Jun 2015 17:42:00 +0000 (17:42 +0000)
The *u-boot-initramfs* images are not ITB/FIT images but are rather
supposed to be loaded to RAM and jumped-into.
To avoid confusion, change the file extension from itb to bin.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 45963

target/linux/oxnas/image/Makefile

index 2660a9b1255399281c0d743aba2d4a4e7a2b1685..de6c4db3ab90fbb0b249dec205566576efc25aad 100644 (file)
@@ -38,7 +38,7 @@ define Image/BuildKernel/Template
        $(CP) $(KDIR)/fit-$(1)-initramfs.itb $(BIN_DIR)/$(IMG_PREFIX)-$(1)-fit-uImage-initramfs.itb
        if [ -e "$(KDIR)/u-boot.bin" ]; then \
        ( dd if=$(KDIR)/u-boot.bin bs=128k conv=sync ; dd if=$(KDIR)/fit-$(1)-initramfs.itb bs=128k conv=sync ) \
-               > $(BIN_DIR)/$(IMG_PREFIX)-$(1)-u-boot-initramfs.itb; \
+               > $(BIN_DIR)/$(IMG_PREFIX)-$(1)-u-boot-initramfs.bin; \
        fi
  endif