ixp4xx: Add a ixp4xx hardware crypto kernel module
authorLinus Walleij <linus.walleij@linaro.org>
Mon, 23 Oct 2023 06:43:08 +0000 (08:43 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 25 Oct 2023 09:29:05 +0000 (11:29 +0200)
The IXP4xx crypto module must be loaded after the rootfs is
up as it depends on loading some NPE microcode from the file
system.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
package/kernel/linux/modules/crypto.mk
target/linux/ixp4xx/Makefile

index c0ccdaa3dfe6852a39f37a2174f019319439a240..dd17d868fa1522a85c09cd7397c6498d0dd1808b 100644 (file)
@@ -399,6 +399,19 @@ endef
 
 $(eval $(call KernelPackage,crypto-hw-hifn-795x))
 
+define KernelPackage/crypto-hw-ixp4xx
+  TITLE:=Intel IXP4xx crypto accelerator
+  DEPENDS:=@TARGET_ixp4xx +kmod-random-core +kmod-crypto-manager +kmod-crypto-authenc +kmod-crypto-des
+  KCONFIG:= \
+       CONFIG_CRYPTO_HW=y \
+       CONFIG_CRYPTO_DEV_IXP4XX
+  FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
+  AUTOLOAD:=$(call AutoProbe,ixp4xx_crypto)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ixp4xx))
+
 
 define KernelPackage/crypto-hw-padlock
   TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
index 89a1b2407bfe2911f7f3c1a216a089518c7bc9e1..6cd30877eeeecd884527268cbc6e87f9b475c9cd 100644 (file)
@@ -21,6 +21,7 @@ KERNELNAME:=zImage dtbs
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += fconfig \
+       kmod-crypto-hw-ixp4xx \
        kmod-usb-ledtrig-usbport \
        kmod-leds-gpio