kernel: x86: Add glue_helper.ko only on kernel < 5.12
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 22 Oct 2022 00:26:05 +0000 (02:26 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 22 Oct 2022 00:31:57 +0000 (02:31 +0200)
This module was removed with kernel 5.12.
This fixes the build of the x86 target.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/crypto.mk

index f8af5f0a3bb2fb45079e4666a5554372bb4af23e..83048e50d3fcea163f7a20237ee7ee0e0f301ccf 100644 (file)
@@ -727,10 +727,10 @@ ifndef CONFIG_TARGET_x86_64
     FILES+= \
        $(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko \
        $(LINUX_DIR)/arch/x86/crypto/serpent-sse2-i586.ko \
-       $(LINUX_DIR)/arch/x86/crypto/glue_helper.ko \
+       $(LINUX_DIR)/arch/x86/crypto/glue_helper.ko@lt5.12 \
        $(LINUX_DIR)/crypto/cryptd.ko \
        $(LINUX_DIR)/crypto/crypto_simd.ko
-    AUTOLOAD+= $(call AutoLoad,10,cryptd glue_helper \
+    AUTOLOAD+= $(call AutoLoad,10,cryptd glue_helper@lt5.12 \
        serpent-sse2-i586 twofish-i586 blowfish_generic)
   endef
 endif