arm-trusted-firmware-mvebu: add Methode eDPU support
authorRobert Marko <robert.marko@sartura.hr>
Wed, 21 Sep 2022 16:40:59 +0000 (18:40 +0200)
committerRobert Marko <robert.marko@sartura.hr>
Mon, 17 Oct 2022 13:42:50 +0000 (15:42 +0200)
Provide ATF support for Methode eDPU as well, this makes it easy for
OpenWrt users to update the included U-boot+ATF combo.

Signed-off-by: Robert Marko <robert.marko@sartura.hr>
package/boot/arm-trusted-firmware-mvebu/Makefile

index 3b7fd7a7cc5ad625803fbecc8b5b947cb60ee7df..569d952cb832f4835859891b989f6dc8fce4a416 100644 (file)
@@ -97,6 +97,16 @@ define Trusted-Firmware-A/udpu
   PLAT:=a3700
 endef
 
+define Trusted-Firmware-A/edpu
+  NAME:=Methode eDPU
+  DEPENDS:=+u-boot-eDPU
+  BUILD_DEVICES:=methode_edpu
+  UBOOT:=eDPU
+  DDR_TOPOLOGY:=0
+  CLOCKSPRESET:=CPU_1000_DDR_800
+  PLAT:=a3700
+endef
+
 
 TFA_TARGETS:= \
        espressobin-512mb \
@@ -105,7 +115,8 @@ TFA_TARGETS:= \
        espressobin-v3-v5-2gb \
        espressobin-v7-1gb \
        espressobin-v7-2gb \
-       udpu
+       udpu \
+       edpu
 
 TFA_MAKE_FLAGS += \
                CROSS_CM3=$(BUILD_DIR)/$(CM3_GCC_NAME)-$(CM3_GCC_RELEASE)-$(CM3_GCC_VERSION)/bin/arm-none-eabi- \