imagebuilder: fix partition signature
authorMatthew Gyurgyik <matthew@gyurgyik.io>
Fri, 13 Nov 2020 19:21:29 +0000 (11:21 -0800)
committerPaul Spooren <mail@aparcar.org>
Wed, 25 Nov 2020 00:46:05 +0000 (14:46 -1000)
When building images with the imagebuilder, the partition signature
never changes. The signature is generated by hashing SOURCE_DATE_EPOCH
and LINUX_VERMAGIC which are undefined. Prepopulate these variables, as
done by the SDK.

Signed-off-by: Matthew Gyurgyik <matthew@gyurgyik.io>
target/imagebuilder/Makefile

index a96f8618e839681774ea3a394bb3437084e5870f..e7954e96a4774802b6fe6c5b30970675ea8d8cb4 100644 (file)
@@ -89,6 +89,8 @@ endif
                $(CP) -L $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/dts/* $(IB_DTSDIR); \
        fi
        $(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(PKG_BUILD_DIR)/include/version.mk
+       $(SED) 's,^# SOURCE_DATE_EPOCH:=.*,SOURCE_DATE_EPOCH:=$(SOURCE_DATE_EPOCH),g' $(PKG_BUILD_DIR)/include/version.mk
+       $(SED) '/LINUX_VERMAGIC:=/ { s,unknown,$(LINUX_VERMAGIC),g }' $(PKG_BUILD_DIR)/include/kernel.mk
        find $(PKG_BUILD_DIR) -name CVS -o -name .git -o -name .svn \
          | $(XARGS) rm -rf
        $(INSTALL_DIR) $(IB_IDIR)