realtek: remove KERNEL_PATCHVER overrides
authorSander Vanheule <sander@svanheule.net>
Sun, 29 Jan 2023 09:57:48 +0000 (10:57 +0100)
committerSander Vanheule <sander@svanheule.net>
Sun, 29 Jan 2023 15:29:42 +0000 (16:29 +0100)
On the realtek target, the subtarget makefiles include a KERNEL_PATCHVER
setting, shadowing KERNEL_PATCHVER from target/linux/realtek/Makefile.
This makes the realtek target an exception in this regard, and makes
switching kernel version a bit bothersome. Remove the overrides so all
subtargets use the same kernel version.

Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/realtek/rtl838x/target.mk
target/linux/realtek/rtl839x/target.mk
target/linux/realtek/rtl930x/target.mk
target/linux/realtek/rtl931x/target.mk

index d78b44b717ff24eb9c4a24d7473ead85a7813982..e776676f663d42164d5414ca4a67995bfeac582f 100644 (file)
@@ -5,8 +5,6 @@ CPU_TYPE:=4kec
 BOARD:=realtek
 BOARDNAME:=Realtek MIPS RTL838X
 
-KERNEL_PATCHVER:=5.10
-
 define Target/Description
        Build firmware images for Realtek RTL838x based boards.
 endef
index 88993fad147dc835bcb2b8bdf294ef57f1ec0c21..b2f4e9c0dd260d864a134801e6ecd62d02bde6ad 100644 (file)
@@ -5,8 +5,6 @@ CPU_TYPE:=24kc
 BOARD:=realtek
 BOARDNAME:=Realtek MIPS RTL839X
 
-KERNEL_PATCHVER:=5.10
-
 define Target/Description
        Build firmware images for Realtek RTL839x based boards.
 endef
index 31b06219cab84fa642f74339d9e8e223d27ed477..a2b95f4db9bebafbcdf9b0aa5ec4b66ce3935e49 100644 (file)
@@ -5,8 +5,6 @@ CPU_TYPE:=24kc
 BOARD:=realtek
 BOARDNAME:=Realtek MIPS RTL930X
 
-KERNEL_PATCHVER:=5.10
-
 define Target/Description
        Build firmware images for Realtek RTL930x based boards.
 endef
index 39892e548428d79243591116679fa4c6cb4c3488..eaa6b61214ca1a540568bd961d4f68aef592179e 100644 (file)
@@ -5,8 +5,6 @@ CPU_TYPE:=24kc
 BOARD:=realtek
 BOARDNAME:=Realtek MIPS RTL931X
 
-KERNEL_PATCHVER:=5.10
-
 define Target/Description
        Build firmware images for Realtek RTL931x based boards.
 endef