kirkwood: import patch to fix build and refresh patches
authorDaniel Golle <daniel@makrotopia.org>
Thu, 5 Aug 2021 22:40:21 +0000 (23:40 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 5 Aug 2021 22:53:07 +0000 (23:53 +0100)
kirkwood build broke due to missing include needed for ETH_ALEN.
Add patch (sent upstream as well) to address that.
Refresh patches for 5.4 and 5.10.

Fixes: 91a52f22a1 ("treewide: backport support for nvmem on non platform devices")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
16 files changed:
target/linux/generic/backport-5.10/782-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
target/linux/generic/hack-5.10/773-bgmac-add-srab-switch.patch
target/linux/generic/hack-5.4/773-bgmac-add-srab-switch.patch
target/linux/generic/pending-5.10/681-NET-add-mtd-mac-address-support-to-of_get_mac_addres.patch
target/linux/generic/pending-5.10/682-of_net-add-mac-address-increment-support.patch
target/linux/generic/pending-5.10/683-of_net-add-mac-address-to-of-tree.patch
target/linux/generic/pending-5.10/780-ARM-kirkwood-add-missing-linux-if_ether.h-for-ETH_AL.patch [new file with mode: 0644]
target/linux/generic/pending-5.4/681-NET-add-mtd-mac-address-support-to-of_get_mac_addres.patch
target/linux/generic/pending-5.4/682-of_net-add-mac-address-increment-support.patch
target/linux/generic/pending-5.4/683-of_net-add-mac-address-to-of-tree.patch
target/linux/generic/pending-5.4/770-06-net-ethernet-mtk_eth_soc-implement-dynamic-interrupt.patch
target/linux/generic/pending-5.4/770-15-net-ethernet-mediatek-mtk_eth_soc-add-support-for-in.patch
target/linux/generic/pending-5.4/770-16-net-ethernet-mediatek-mtk_eth_soc-add-flow-offloadin.patch
target/linux/generic/pending-5.4/780-ARM-kirkwood-add-missing-linux-if_ether.h-for-ETH_AL.patch [new file with mode: 0644]
target/linux/mediatek/patches-5.10/510-net-mediatek-add-flow-offload-for-mt7623.patch
target/linux/mediatek/patches-5.10/700-net-ethernet-mtk_eth_soc-add-support-for-coherent-DM.patch

index b97cb13fc5c6e13d5f462e33dab4ac21fc7b0efb..6489c037348cdbd82c50c55f97d6bc0f5e536d58 100644 (file)
@@ -423,7 +423,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (bgmac->irq < 0)
 --- a/drivers/net/ethernet/cadence/macb_main.c
 +++ b/drivers/net/ethernet/cadence/macb_main.c
-@@ -4453,7 +4453,6 @@ static int macb_probe(struct platform_de
+@@ -4456,7 +4456,6 @@ static int macb_probe(struct platform_de
        struct net_device *dev;
        struct resource *regs;
        void __iomem *mem;
@@ -431,7 +431,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        struct macb *bp;
        int err, val;
  
-@@ -4566,15 +4565,11 @@ static int macb_probe(struct platform_de
+@@ -4569,15 +4568,11 @@ static int macb_probe(struct platform_de
        if (bp->caps & MACB_CAPS_NEEDS_RSTONUBR)
                bp->rx_intr_mask |= MACB_BIT(RXUBR);
  
@@ -561,7 +561,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        /* Get IRQ number */
 --- a/drivers/net/ethernet/freescale/fec_main.c
 +++ b/drivers/net/ethernet/freescale/fec_main.c
-@@ -1664,6 +1664,7 @@ static void fec_get_mac(struct net_devic
+@@ -1666,6 +1666,7 @@ static void fec_get_mac(struct net_devic
        struct fec_enet_private *fep = netdev_priv(ndev);
        struct fec_platform_data *pdata = dev_get_platdata(&fep->pdev->dev);
        unsigned char *iap, tmpaddr[ETH_ALEN];
@@ -569,7 +569,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        /*
         * try to get mac address in following order:
-@@ -1679,9 +1680,9 @@ static void fec_get_mac(struct net_devic
+@@ -1681,9 +1682,9 @@ static void fec_get_mac(struct net_devic
        if (!is_valid_ether_addr(iap)) {
                struct device_node *np = fep->pdev->dev.of_node;
                if (np) {
@@ -752,7 +752,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                            ndev->dev_addr);
 --- a/drivers/net/ethernet/lantiq_xrx200.c
 +++ b/drivers/net/ethernet/lantiq_xrx200.c
-@@ -435,7 +435,6 @@ static int xrx200_probe(struct platform_
+@@ -440,7 +440,6 @@ static int xrx200_probe(struct platform_
        struct resource *res;
        struct xrx200_priv *priv;
        struct net_device *net_dev;
@@ -760,7 +760,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        int err;
  
        /* alloc the network device */
-@@ -479,10 +478,8 @@ static int xrx200_probe(struct platform_
+@@ -484,10 +483,8 @@ static int xrx200_probe(struct platform_
                return PTR_ERR(priv->clk);
        }
  
@@ -895,7 +895,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
 --- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
 +++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
-@@ -2559,14 +2559,11 @@ static int __init mtk_init(struct net_de
+@@ -2580,14 +2580,11 @@ static int __init mtk_init(struct net_de
  {
        struct mtk_mac *mac = netdev_priv(dev);
        struct mtk_eth *eth = mac->hw;
@@ -1360,7 +1360,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        int irq;
 --- a/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c
 +++ b/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c
-@@ -4911,7 +4911,7 @@ int stmmac_dvr_probe(struct device *devi
+@@ -4904,7 +4904,7 @@ int stmmac_dvr_probe(struct device *devi
        priv->wol_irq = res->wol_irq;
        priv->lpi_irq = res->lpi_irq;
  
@@ -1380,7 +1380,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  {
        struct device_node *np = pdev->dev.of_node;
        struct plat_stmmacenet_data *plat;
-@@ -405,12 +405,12 @@ stmmac_probe_config_dt(struct platform_d
+@@ -406,12 +406,12 @@ stmmac_probe_config_dt(struct platform_d
        if (!plat)
                return ERR_PTR(-ENOMEM);
  
@@ -1397,8 +1397,8 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 +              eth_zero_addr(mac);
        }
  
-       plat->phy_interface = device_get_phy_mode(&pdev->dev);
-@@ -631,7 +631,7 @@ void stmmac_remove_config_dt(struct plat
+       phy_mode = device_get_phy_mode(&pdev->dev);
+@@ -635,7 +635,7 @@ void stmmac_remove_config_dt(struct plat
  }
  #else
  struct plat_stmmacenet_data *
@@ -1586,7 +1586,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (!is_valid_ether_addr(ndev->dev_addr))
                eth_hw_addr_random(ndev);
        temac_do_set_mac_address(ndev);
-@@ -1351,7 +1351,7 @@ static int temac_probe(struct platform_d
+@@ -1372,7 +1372,7 @@ static int temac_probe(struct platform_d
        struct device_node *temac_np = dev_of_node(&pdev->dev), *dma_np;
        struct temac_local *lp;
        struct net_device *ndev;
@@ -1595,7 +1595,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        __be32 *p;
        bool little_endian;
        int rc = 0;
-@@ -1542,8 +1542,8 @@ static int temac_probe(struct platform_d
+@@ -1563,8 +1563,8 @@ static int temac_probe(struct platform_d
  
        if (temac_np) {
                /* Retrieve the MAC address */
@@ -1902,7 +1902,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                        break;
 --- a/net/dsa/slave.c
 +++ b/net/dsa/slave.c
-@@ -1852,7 +1852,7 @@ int dsa_slave_create(struct dsa_port *po
+@@ -1857,7 +1857,7 @@ int dsa_slave_create(struct dsa_port *po
        slave_dev->hw_features |= NETIF_F_HW_TC;
        slave_dev->features |= NETIF_F_LLTX;
        slave_dev->ethtool_ops = &dsa_slave_ethtool_ops;
index d0de01fe5b847cc7559acdea0999bf6849b0a53d..5a7e38516cce6fcb4d462aeafa758cf8236b7181 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/drivers/net/ethernet/broadcom/bgmac-bcma.c
 +++ b/drivers/net/ethernet/broadcom/bgmac-bcma.c
-@@ -268,6 +268,7 @@ static int bgmac_probe(struct bcma_devic
+@@ -266,6 +266,7 @@ static int bgmac_probe(struct bcma_devic
                bgmac->feature_flags |= BGMAC_FEAT_CLKCTLST;
                bgmac->feature_flags |= BGMAC_FEAT_NO_RESET;
                bgmac->feature_flags |= BGMAC_FEAT_FORCE_SPEED_2500;
index 89e0df460671a18f4a3bae3484120be9a4299933..88109ac8b07d3281d5c0729749a357cdb6eaf8f5 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/drivers/net/ethernet/broadcom/bgmac-bcma.c
 +++ b/drivers/net/ethernet/broadcom/bgmac-bcma.c
-@@ -268,6 +268,7 @@ static int bgmac_probe(struct bcma_devic
+@@ -266,6 +266,7 @@ static int bgmac_probe(struct bcma_devic
                bgmac->feature_flags |= BGMAC_FEAT_CLKCTLST;
                bgmac->feature_flags |= BGMAC_FEAT_NO_RESET;
                bgmac->feature_flags |= BGMAC_FEAT_FORCE_SPEED_2500;
index 463fc270c6bd153ecb581ea10a07dcc0bcf6a4a1..30e292a25d2af91b5cc684e7d7c9f970a4745350 100644 (file)
@@ -78,7 +78,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
  /**
   * Search the device tree for the best MAC address to use.  'mac-address' is
   * checked first, because that is supposed to contain to "most recent" MAC
-@@ -115,6 +161,10 @@ static int of_get_mac_addr_nvmem(struct
+@@ -115,6 +162,10 @@ static int of_get_mac_addr_nvmem(struct
   * this case, the real MAC is in 'local-mac-address', and 'mac-address' exists
   * but is all zeros.
   *
@@ -89,7 +89,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
   * Return: 0 on success and errno in case of error.
  */
  int of_get_mac_address(struct device_node *np, u8 *addr)
-@@ -136,6 +186,10 @@ int of_get_mac_address(struct device_nod
+@@ -136,6 +187,10 @@ int of_get_mac_address(struct device_nod
        if (!ret)
                return 0;
  
index ce5211a21b83957bef67fbcd002ea35df3f77146..e48e6311c6f57622bf05eaec94ee470da330d8d6 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
 
 --- a/drivers/of/of_net.c
 +++ b/drivers/of/of_net.c
-@@ -165,31 +165,56 @@ static int of_get_mac_address_mtd(struct
+@@ -166,31 +166,56 @@ static int of_get_mac_address_mtd(struct
   * If a mtd-mac-address property exists, try to fetch the MAC address from the
   * specified mtd device.
   *
index 377f16e7c922167a5034a87715e65b53bc0f0840..509d721403f9cb46354a1219f68483656e13a0a0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/of/of_net.c
 +++ b/drivers/of/of_net.c
-@@ -132,6 +132,30 @@ static void *of_get_mac_address_mtd(stru
+@@ -141,6 +141,30 @@ static int of_get_mac_address_mtd(struct
        return -EINVAL;
  }
  
@@ -31,7 +31,7 @@
  
  /**
   * Search the device tree for the best MAC address to use.  'mac-address' is
-@@ -205,6 +232,7 @@ found:
+@@ -216,6 +240,7 @@ found:
        if (!of_property_read_u32(np, "mac-address-increment", &mac_inc))
                addr[inc_idx] += mac_inc;
  
diff --git a/target/linux/generic/pending-5.10/780-ARM-kirkwood-add-missing-linux-if_ether.h-for-ETH_AL.patch b/target/linux/generic/pending-5.10/780-ARM-kirkwood-add-missing-linux-if_ether.h-for-ETH_AL.patch
new file mode 100644 (file)
index 0000000..fcf7892
--- /dev/null
@@ -0,0 +1,61 @@
+From patchwork Thu Aug  5 22:23:30 2021
+Content-Type: text/plain; charset="utf-8"
+MIME-Version: 1.0
+Content-Transfer-Encoding: 7bit
+X-Patchwork-Submitter: Daniel Golle <daniel@makrotopia.org>
+X-Patchwork-Id: 12422209
+Date: Thu, 5 Aug 2021 23:23:30 +0100
+From: Daniel Golle <daniel@makrotopia.org>
+To: linux-arm-kernel@lists.infradead.org, netdev@vger.kernel.org,
+ linux-kernel@vger.kernel.org
+Cc: "David S. Miller" <davem@davemloft.net>, Andrew Lunn <andrew@lunn.ch>,
+ Michael Walle <michael@walle.cc>
+Subject: [PATCH] ARM: kirkwood: add missing <linux/if_ether.h> for ETH_ALEN
+Message-ID: <YQxk4jrbm31NM1US@makrotopia.org>
+MIME-Version: 1.0
+Content-Disposition: inline
+X-BeenThere: linux-arm-kernel@lists.infradead.org
+X-Mailman-Version: 2.1.34
+Precedence: list
+List-Id: <linux-arm-kernel.lists.infradead.org>
+List-Archive: <http://lists.infradead.org/pipermail/linux-arm-kernel/>
+Sender: "linux-arm-kernel" <linux-arm-kernel-bounces@lists.infradead.org>
+
+After commit 83216e3988cd1 ("of: net: pass the dst buffer to
+of_get_mac_address()") build fails for kirkwood as ETH_ALEN is not
+defined.
+
+arch/arm/mach-mvebu/kirkwood.c: In function 'kirkwood_dt_eth_fixup':
+arch/arm/mach-mvebu/kirkwood.c:87:13: error: 'ETH_ALEN' undeclared (first use in this function); did you mean 'ESTALE'?
+   u8 tmpmac[ETH_ALEN];
+             ^~~~~~~~
+             ESTALE
+arch/arm/mach-mvebu/kirkwood.c:87:13: note: each undeclared identifier is reported only once for each function it appears in
+arch/arm/mach-mvebu/kirkwood.c:87:6: warning: unused variable 'tmpmac' [-Wunused-variable]
+   u8 tmpmac[ETH_ALEN];
+      ^~~~~~
+make[5]: *** [scripts/Makefile.build:262: arch/arm/mach-mvebu/kirkwood.o] Error 1
+make[5]: *** Waiting for unfinished jobs....
+
+Add missing #include <linux/if_ether.h> to fix this.
+
+Cc: David S. Miller <davem@davemloft.net>
+Cc: Andrew Lunn <andrew@lunn.ch>
+Cc: Michael Walle <michael@walle.cc>
+Reported-by: https://buildbot.openwrt.org/master/images/#/builders/56/builds/220/steps/44/logs/stdio
+Fixes: 83216e3988cd1 ("of: net: pass the dst buffer to of_get_mac_address()")
+Signed-off-by: Daniel Golle <daniel@makrotopia.org>
+---
+ arch/arm/mach-mvebu/kirkwood.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/arch/arm/mach-mvebu/kirkwood.c
++++ b/arch/arm/mach-mvebu/kirkwood.c
+@@ -14,6 +14,7 @@
+ #include <linux/kernel.h>
+ #include <linux/init.h>
+ #include <linux/mbus.h>
++#include <linux/if_ether.h>
+ #include <linux/of.h>
+ #include <linux/of_address.h>
+ #include <linux/of_net.h>
index 463fc270c6bd153ecb581ea10a07dcc0bcf6a4a1..a9e06cdfe19553edd18aa54264a2113d4ebd8d9e 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
  
  /**
   * of_get_phy_mode - Get phy mode for given device_node
-@@ -95,6 +96,52 @@ static int of_get_mac_addr_nvmem(struct
+@@ -89,6 +90,52 @@ static int of_get_mac_addr_nvmem(struct
        return 0;
  }
  
@@ -78,7 +78,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
  /**
   * Search the device tree for the best MAC address to use.  'mac-address' is
   * checked first, because that is supposed to contain to "most recent" MAC
-@@ -115,6 +161,10 @@ static int of_get_mac_addr_nvmem(struct
+@@ -109,6 +156,10 @@ static int of_get_mac_addr_nvmem(struct
   * this case, the real MAC is in 'local-mac-address', and 'mac-address' exists
   * but is all zeros.
   *
@@ -89,7 +89,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
   * Return: 0 on success and errno in case of error.
  */
  int of_get_mac_address(struct device_node *np, u8 *addr)
-@@ -136,6 +186,10 @@ int of_get_mac_address(struct device_nod
+@@ -130,6 +181,10 @@ int of_get_mac_address(struct device_nod
        if (!ret)
                return 0;
  
index ce5211a21b83957bef67fbcd002ea35df3f77146..35c717ca51eb1b810ddd7353b63a4b473c8add46 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
 
 --- a/drivers/of/of_net.c
 +++ b/drivers/of/of_net.c
-@@ -165,31 +165,56 @@ static int of_get_mac_address_mtd(struct
+@@ -160,31 +160,56 @@ static int of_get_mac_address_mtd(struct
   * If a mtd-mac-address property exists, try to fetch the MAC address from the
   * specified mtd device.
   *
index 377f16e7c922167a5034a87715e65b53bc0f0840..622d19d4ff25fb9ddb2e6cbb06c99202a3b70506 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/of/of_net.c
 +++ b/drivers/of/of_net.c
-@@ -132,6 +132,30 @@ static void *of_get_mac_address_mtd(stru
+@@ -135,6 +135,30 @@ static int of_get_mac_address_mtd(struct
        return -EINVAL;
  }
  
@@ -31,7 +31,7 @@
  
  /**
   * Search the device tree for the best MAC address to use.  'mac-address' is
-@@ -205,6 +232,7 @@ found:
+@@ -210,6 +234,7 @@ found:
        if (!of_property_read_u32(np, "mac-address-increment", &mac_inc))
                addr[inc_idx] += mac_inc;
  
index 9302f0b1f72a10ba692b0b605542bea00f536dca..58128445b27145eb95a2a5ff2f18664b27bc33a6 100644 (file)
@@ -194,7 +194,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        mtk_tx_irq_disable(eth, ~0);
        mtk_rx_irq_disable(eth, ~0);
  
-@@ -2951,6 +3025,13 @@ static int mtk_probe(struct platform_dev
+@@ -2948,6 +3022,13 @@ static int mtk_probe(struct platform_dev
        spin_lock_init(&eth->page_lock);
        spin_lock_init(&eth->tx_irq_lock);
        spin_lock_init(&eth->rx_irq_lock);
index f609f11d2ce1f23c2946c4592113a966f3f7099a..8847870fb7cd09299382c2c859f221f5e0f7469a 100644 (file)
@@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        return 0;
  }
  
-@@ -3165,6 +3173,13 @@ static int mtk_probe(struct platform_dev
+@@ -3162,6 +3170,13 @@ static int mtk_probe(struct platform_dev
                        goto err_free_dev;
        }
  
@@ -68,7 +68,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        for (i = 0; i < MTK_MAX_DEVS; i++) {
                if (!eth->netdev[i])
                        continue;
-@@ -3239,6 +3254,7 @@ static const struct mtk_soc_data mt7621_
+@@ -3236,6 +3251,7 @@ static const struct mtk_soc_data mt7621_
        .hw_features = MTK_HW_FEATURES,
        .required_clks = MT7621_CLKS_BITMAP,
        .required_pctl = false,
@@ -76,7 +76,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  };
  
  static const struct mtk_soc_data mt7622_data = {
-@@ -3247,6 +3263,7 @@ static const struct mtk_soc_data mt7622_
+@@ -3244,6 +3260,7 @@ static const struct mtk_soc_data mt7622_
        .hw_features = MTK_HW_FEATURES,
        .required_clks = MT7622_CLKS_BITMAP,
        .required_pctl = false,
index b0f06f603b36af86a921938ac807801de3b974c8..de337026d30b14fc4c603d586c6b2f9a3f537df1 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  skip_rx:
                ring->data[idx] = new_data;
-@@ -2882,6 +2888,25 @@ static int mtk_set_rxnfc(struct net_devi
+@@ -2879,6 +2885,25 @@ static int mtk_set_rxnfc(struct net_devi
        return ret;
  }
  
@@ -70,7 +70,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static const struct ethtool_ops mtk_ethtool_ops = {
        .get_link_ksettings     = mtk_get_link_ksettings,
        .set_link_ksettings     = mtk_set_link_ksettings,
-@@ -2913,6 +2938,7 @@ static const struct net_device_ops mtk_n
+@@ -2910,6 +2935,7 @@ static const struct net_device_ops mtk_n
  #ifdef CONFIG_NET_POLL_CONTROLLER
        .ndo_poll_controller    = mtk_poll_controller,
  #endif
@@ -78,7 +78,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  };
  
  static int mtk_add_mac(struct mtk_eth *eth, struct device_node *np)
-@@ -3178,6 +3204,10 @@ static int mtk_probe(struct platform_dev
+@@ -3175,6 +3201,10 @@ static int mtk_probe(struct platform_dev
                                   eth->base + MTK_ETH_PPE_BASE, 2);
                if (err)
                        goto err_free_dev;
diff --git a/target/linux/generic/pending-5.4/780-ARM-kirkwood-add-missing-linux-if_ether.h-for-ETH_AL.patch b/target/linux/generic/pending-5.4/780-ARM-kirkwood-add-missing-linux-if_ether.h-for-ETH_AL.patch
new file mode 100644 (file)
index 0000000..fcf7892
--- /dev/null
@@ -0,0 +1,61 @@
+From patchwork Thu Aug  5 22:23:30 2021
+Content-Type: text/plain; charset="utf-8"
+MIME-Version: 1.0
+Content-Transfer-Encoding: 7bit
+X-Patchwork-Submitter: Daniel Golle <daniel@makrotopia.org>
+X-Patchwork-Id: 12422209
+Date: Thu, 5 Aug 2021 23:23:30 +0100
+From: Daniel Golle <daniel@makrotopia.org>
+To: linux-arm-kernel@lists.infradead.org, netdev@vger.kernel.org,
+ linux-kernel@vger.kernel.org
+Cc: "David S. Miller" <davem@davemloft.net>, Andrew Lunn <andrew@lunn.ch>,
+ Michael Walle <michael@walle.cc>
+Subject: [PATCH] ARM: kirkwood: add missing <linux/if_ether.h> for ETH_ALEN
+Message-ID: <YQxk4jrbm31NM1US@makrotopia.org>
+MIME-Version: 1.0
+Content-Disposition: inline
+X-BeenThere: linux-arm-kernel@lists.infradead.org
+X-Mailman-Version: 2.1.34
+Precedence: list
+List-Id: <linux-arm-kernel.lists.infradead.org>
+List-Archive: <http://lists.infradead.org/pipermail/linux-arm-kernel/>
+Sender: "linux-arm-kernel" <linux-arm-kernel-bounces@lists.infradead.org>
+
+After commit 83216e3988cd1 ("of: net: pass the dst buffer to
+of_get_mac_address()") build fails for kirkwood as ETH_ALEN is not
+defined.
+
+arch/arm/mach-mvebu/kirkwood.c: In function 'kirkwood_dt_eth_fixup':
+arch/arm/mach-mvebu/kirkwood.c:87:13: error: 'ETH_ALEN' undeclared (first use in this function); did you mean 'ESTALE'?
+   u8 tmpmac[ETH_ALEN];
+             ^~~~~~~~
+             ESTALE
+arch/arm/mach-mvebu/kirkwood.c:87:13: note: each undeclared identifier is reported only once for each function it appears in
+arch/arm/mach-mvebu/kirkwood.c:87:6: warning: unused variable 'tmpmac' [-Wunused-variable]
+   u8 tmpmac[ETH_ALEN];
+      ^~~~~~
+make[5]: *** [scripts/Makefile.build:262: arch/arm/mach-mvebu/kirkwood.o] Error 1
+make[5]: *** Waiting for unfinished jobs....
+
+Add missing #include <linux/if_ether.h> to fix this.
+
+Cc: David S. Miller <davem@davemloft.net>
+Cc: Andrew Lunn <andrew@lunn.ch>
+Cc: Michael Walle <michael@walle.cc>
+Reported-by: https://buildbot.openwrt.org/master/images/#/builders/56/builds/220/steps/44/logs/stdio
+Fixes: 83216e3988cd1 ("of: net: pass the dst buffer to of_get_mac_address()")
+Signed-off-by: Daniel Golle <daniel@makrotopia.org>
+---
+ arch/arm/mach-mvebu/kirkwood.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/arch/arm/mach-mvebu/kirkwood.c
++++ b/arch/arm/mach-mvebu/kirkwood.c
+@@ -14,6 +14,7 @@
+ #include <linux/kernel.h>
+ #include <linux/init.h>
+ #include <linux/mbus.h>
++#include <linux/if_ether.h>
+ #include <linux/of.h>
+ #include <linux/of_address.h>
+ #include <linux/of_net.h>
index 7585d6cf188be1bfbbc36f896600345e40625d8b..36f88a51fcb58c5f35cb557a2fa3f5c31f19e794 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Frank Wunderlich <frank-w@public-files.de>
 
 --- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
 +++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
-@@ -3274,6 +3274,7 @@ static const struct mtk_soc_data mt7623_
+@@ -3269,6 +3269,7 @@ static const struct mtk_soc_data mt7623_
        .hw_features = MTK_HW_FEATURES,
        .required_clks = MT7623_CLKS_BITMAP,
        .required_pctl = true,
index 529a252d3b15694a2ddc3f69a3eb5c8f1dd4619b..1e38b58f3ec373f11b0058956763908be29714e5 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (MTK_HAS_CAPS(eth->soc->caps, MTK_SOC_MT7628)) {
                ret = device_reset(eth->dev);
                if (ret) {
-@@ -3076,6 +3084,16 @@ static int mtk_probe(struct platform_dev
+@@ -3071,6 +3079,16 @@ static int mtk_probe(struct platform_dev
                }
        }