ipq806x: Enlarge D7800 flash - use netgear partition
authorMike Lothian <mike@fireburn.co.uk>
Mon, 17 May 2021 09:15:20 +0000 (10:15 +0100)
committerPetr Štetiar <ynezz@true.cz>
Tue, 8 Feb 2022 11:52:14 +0000 (12:52 +0100)
Increase the available flash memory size in Netgear R7800
by repurposing the unused "netgear" partition that is
located after the firmware partition.

Available flash space for kernel+rootfs+overlay increases
by 68 MB from 32 MB to 100 MB.

In a typical build, overlay space increases from 15 to 85,
increasing the package installation possibilities greatly.

Reverting to the OEM firmware is still possible, as the OEM
firmware contains logic to initialise the "netgear" partition
if its contents do not match expectations. In OEM firmware,
"netgear" contains 6 UBI sub-partitions that are defined in
/etc/netgear.cfg and initialisation is done by /etc/preinit

This is based on https://github.com/openwrt/openwrt/commit/fb8a578aa70572b3e56b64d296e22c2931e77b69

Signed-off-by: Mike Lothian <mike@fireburn.co.uk>
target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8064-d7800.dts
target/linux/ipq806x/image/generic.mk

index b8314a6bd0c9a73c9785ac6ea942a9d2c0607481..2f259150fa4db47c67267efc5c171687971d40b8 100644 (file)
 
                        ubi@1880000 {
                                label = "ubi";
-                               reg = <0x1880000 0x1C00000>;
-                       };
-
-                       netgear@3480000 {
-                               label = "netgear";
-                               reg = <0x3480000 0x4480000>;
-                               read-only;
+                               reg = <0x1880000 0x6080000>;
                        };
 
                        reserve@7900000 {
index 4fdf656b4be218ebcbaa87fa1776adbf84871621..21b309376f3be3b470eb812af48c5ee65f77a4c2 100644 (file)
@@ -242,6 +242,9 @@ define Device/netgear_d7800
        BOARD_NAME := d7800
        SUPPORTED_DEVICES += d7800
        DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
+       DEVICE_COMPAT_VERSION := 2.0
+       DEVICE_COMPAT_MESSAGE := Sysupgrade does not work due to rootfs ubi partition size change. \
+               Use factory image with the TFTP recovery flash routine.
 endef
 TARGET_DEVICES += netgear_d7800