ramips: move zyimage define to common Makefile
authorMaxim Anisimov <maxim.anisimov.ua@gmail.com>
Thu, 28 Jun 2018 05:26:39 +0000 (08:26 +0300)
committerMathias Kresin <dev@kresin.me>
Tue, 3 Jul 2018 23:20:02 +0000 (01:20 +0200)
Signed-off-by: Maxim Anisimov <maxim.anisimov.ua@gmail.com>
target/linux/ramips/image/Makefile
target/linux/ramips/image/mt7620.mk

index cd77ffe411913c7aeac651290f8d87ae8e152558..753e287d737593b9dce820e054680d8db6615cdc 100644 (file)
@@ -147,6 +147,10 @@ define Build/mkdlinkfw-factory
        mv $@.new $@
 endef
 
+define Build/zyimage
+       $(STAGING_DIR_HOST)/bin/zyimage $(1) $@
+endef
+
 #
 # The real magic happens inside these templates
 #
index 325e3104a7e43335316cd4c075bc8830c31e3a8e..736741a4ba220ce5169ee1d1396bcca9619e0fc4 100644 (file)
@@ -16,10 +16,6 @@ define Build/elecom-header
                -f $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
 endef
 
-define Build/zyimage
-       $(STAGING_DIR_HOST)/bin/zyimage $(1) $@
-endef
-
 define Device/ai-br100
   DTS := AI-BR100
   IMAGE_SIZE := 7936k