ipq40xx: refactor ZTE MF287 series
authorAndreas Böhler <dev@aboehler.at>
Sat, 16 Sep 2023 19:55:01 +0000 (21:55 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 19 Sep 2023 09:43:36 +0000 (11:43 +0200)
The ZTE MF287 requires a different board calibration file for ath10k than
the ZTE MF287+. The two devices receive their own DTS, thus the device tree
is slightly refactored.

Signed-off-by: Andreas Böhler <dev@aboehler.at>
package/firmware/ipq-wifi/Makefile
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/lib/upgrade/platform.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287.dts [new file with mode: 0644]
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287.dtsi [deleted file]
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287_common.dtsi [new file with mode: 0644]
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287plus.dts
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287pro.dts
target/linux/ipq40xx/image/generic.mk

index e65afbdd14276b366b137e2123bac6a01c224e3b..2fb40bea3ba095ed742f1a6ec6f0db566799fc47 100644 (file)
@@ -43,6 +43,7 @@ ALLWIFIBOARDS:= \
        xiaomi_ax9000 \
        yyets_le1 \
        zte_mf289f \
+       zte_mf287 \
        zte_mf287plus \
        zyxel_nbg7815
 
@@ -133,6 +134,7 @@ $(eval $(call generate-ipq-wifi-package,xiaomi_ax3600,Xiaomi AX3600))
 $(eval $(call generate-ipq-wifi-package,xiaomi_ax9000,Xiaomi AX9000))
 $(eval $(call generate-ipq-wifi-package,yyets_le1,YYeTs LE1))
 $(eval $(call generate-ipq-wifi-package,zte_mf289f,ZTE MF289F))
+$(eval $(call generate-ipq-wifi-package,zte_mf287,ZTE MF287))
 $(eval $(call generate-ipq-wifi-package,zte_mf287plus,ZTE MF287Plus))
 $(eval $(call generate-ipq-wifi-package,zyxel_nbg7815,Zyxel NBG7815))
 
index 5353cd398dc6e6eaf9b7810a3728305d0fe046d6..1e9782551f62e23260627d389ee81fcfc6bd962c 100644 (file)
@@ -114,6 +114,7 @@ ipq40xx_setup_interfaces()
        zte,mf286d)
                ucidef_set_interfaces_lan_wan "lan2 lan3 lan4" "wan"
                ;;
+       zte,mf287|\
        zte,mf287plus|\
        zte,mf287pro)
                ucidef_set_interface_lan "lan1 lan2 lan3 lan4"
index d55bb71c8b48732174b0fafa97773e782622dd07..8989cf49f6349c961d5b19efe5ebc9989b74865d 100644 (file)
@@ -27,6 +27,7 @@ EOF
                ;;
        zte,mf18a |\
        zte,mf286d |\
+       zte,mf287|\
        zte,mf287plus |\
        zte,mf287pro |\
        zte,mf289f)
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287.dts
new file mode 100644 (file)
index 0000000..722f250
--- /dev/null
@@ -0,0 +1,226 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+// Copyright (c) 2022, Pawel Dembicki <paweldembicki@gmail.com>.
+// Copyright (c) 2022, Giammarco Marzano <stich86@gmail.com>.
+// Copyright (c) 2023, Andreas Böhler <dev@aboehler.at>
+
+#include "qcom-ipq4018-mf287_common.dtsi"
+
+/ {
+       model = "ZTE MF287";
+       compatible = "zte,mf287";
+
+       /*
+        * This node is used to restart modem module to avoid anomalous
+        * behaviours on initial communication.
+        */
+       gpio-restart {
+               compatible = "gpio-restart";
+               gpios = <&tlmm 5 GPIO_ACTIVE_HIGH>;
+       };
+};
+
+&key_reset {
+       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
+};
+
+&key_wps {
+       gpios = <&tlmm 2 GPIO_ACTIVE_LOW>;
+};
+
+&led_status {
+       gpios = <&tlmm 0 GPIO_ACTIVE_LOW>;
+};
+
+&blsp1_spi1 {
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>,
+                  <&tlmm 59 GPIO_ACTIVE_HIGH>,
+                  <&tlmm 1 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               #address-cells = <1>;
+               #size-cells = <1>;
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "0:SBL1";
+                               reg = <0x0 0x40000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "0:MIBIB";
+                               reg = <0x40000 0x20000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "0:QSEE";
+                               reg = <0x60000 0x60000>;
+                               read-only;
+                       };
+
+                       partition@c0000 {
+                               label = "0:CDT";
+                               reg = <0xc0000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@d0000 {
+                               label = "0:DDRPARAMS";
+                               reg = <0xd0000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@e0000 {
+                               label = "0:APPSBLENV";
+                               reg = <0xe0000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@f0000 {
+                               label = "0:APPSBL";
+                               reg = <0xf0000 0xc0000>;
+                               read-only;
+                       };
+
+                       partition@1b0000 {
+                               label = "0:reserved1";
+                               reg = <0x1b0000 0x50000>;
+                               read-only;
+                       };
+               };
+       };
+
+       spi-nand@1 { /* flash@1 ? */
+               compatible = "spi-nand";
+               reg = <1>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "fota-flag";
+                               reg = <0x0 0x140000>;
+                               read-only;
+                       };
+
+                       partition@140000 {
+                               label = "ART";
+                               reg = <0x140000 0x140000>;
+                               read-only;
+                               compatible = "nvmem-cells";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               precal_art_1000: precal@1000 {
+                                       reg = <0x1000 0x2f20>;
+                               };
+
+                               precal_art_5000: precal@5000 {
+                                       reg = <0x5000 0x2f20>;
+                               };
+                       };
+
+                       partition@280000 {
+                               label = "mac";
+                               reg = <0x280000 0x140000>;
+                               read-only;
+                               compatible = "nvmem-cells";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               macaddr_mac_0: macaddr@0 {
+                                       reg = <0x0 0x6>;
+                               };
+                       };
+
+                       partition@3c0000 {
+                               label = "cfg-param";
+                               reg = <0x3c0000 0x600000>;
+                               read-only;
+                       };
+
+                       partition@9c0000 {
+                               label = "oops";
+                               reg = <0x9c0000 0x140000>;
+                       };
+
+                       partition@b00000 {
+                               label = "web";
+                               reg = <0xb00000 0x800000>;
+                       };
+
+                       partition@1300000 {
+                               label = "rootfs";
+                               reg = <0x1300000 0x2200000>;
+                       };
+
+                       partition@3500000 {
+                               label = "data";
+                               reg = <0x3500000 0x1900000>;
+                       };
+
+                       partition@4e00000 {
+                               label = "fota";
+                               reg = <0x4e00000 0x3200000>;
+                       };
+               };
+       };
+
+       zigbee@2 {
+               #address-cells = <1>;
+               #size-cells = <0>;
+
+               compatible = "silabs,em3581";
+               reg = <2>;
+               spi-max-frequency = <12000000>;
+       };
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               pinmux {
+                       function = "blsp_spi0";
+                       pins = "gpio55", "gpio56", "gpio57";
+                       drive-strength = <12>;
+                       bias-disable;
+               };
+
+               pinmux_cs {
+                       function = "gpio";
+                       pins = "gpio54", "gpio59", "gpio1";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+};
+
+&wifi0 {
+       qcom,ath10k-calibration-variant = "zte,mf287";
+};
+
+&wifi1{
+       qcom,ath10k-calibration-variant = "zte,mf287";
+};
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287.dtsi b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287.dtsi
deleted file mode 100644 (file)
index 3cbe2ea..0000000
+++ /dev/null
@@ -1,183 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-// Copyright (c) 2022, Pawel Dembicki <paweldembicki@gmail.com>.
-// Copyright (c) 2022, Giammarco Marzano <stich86@gmail.com>.
-// Copyright (c) 2023, Andreas Böhler <dev@aboehler.at>
-
-#include "qcom-ipq4019.dtsi"
-#include <dt-bindings/soc/qcom,tcsr.h>
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/leds/common.h>
-
-/ {
-       aliases {
-               led-boot = &led_status;
-               led-failsafe = &led_status;
-               led-running = &led_status;
-               led-upgrade = &led_status;
-       };
-
-       chosen {
-               /*
-                * bootargs forced by u-boot bootipq command:
-                * 'ubi.mtd=rootfs root=mtd:ubi_rootfs rootfstype=squashfs rootwait'
-                */
-               bootargs-append = " root=/dev/ubiblock0_1";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_status: led-0 {
-                       label = "blue:power";
-                       function = LED_FUNCTION_POWER;
-                       color = <LED_COLOR_ID_BLUE>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               key_reset: key-reset {
-                       label = "reset";
-                       linux,code = <KEY_RESTART>;
-               };
-
-               key_wps: key-wps {
-                       label = "wps";
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
-       };
-
-       soc {
-               rng@22000 {
-                       status = "okay";
-               };
-
-               tcsr@1949000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1949000 0x100>;
-                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
-               };
-
-               tcsr@194b000 {
-                       /* select hostmode */
-                       compatible = "qcom,tcsr";
-                       reg = <0x194b000 0x100>;
-                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
-                       status = "okay";
-               };
-
-               ess_tcsr@1953000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1953000 0x1000>;
-                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
-               };
-
-               tcsr@1957000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1957000 0x100>;
-                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
-               };
-       };
-};
-
-&mdio {
-       status = "okay";
-};
-
-&watchdog {
-       status = "okay";
-};
-
-&blsp_dma {
-       status = "okay";
-};
-
-&usb2 {
-       status = "okay";
-};
-
-&usb3 {
-       status = "okay";
-};
-
-&blsp1_uart1 {
-       pinctrl-0 = <&serial_pins>;
-       pinctrl-names = "default";
-       status = "okay";
-};
-
-&crypto {
-       status = "okay";
-};
-
-&cryptobam {
-       status = "okay";
-};
-
-&gmac {
-       status = "okay";
-       nvmem-cell-names = "mac-address";
-       nvmem-cells = <&macaddr_mac_0>;
-       mac-address-increment = <2>;
-};
-
-&switch {
-       status = "okay";
-};
-
-&swport2 {
-       status = "okay";
-
-       label = "lan1";
-};
-
-&swport3 {
-       status = "okay";
-
-       label = "lan2";
-};
-
-&swport4 {
-       status = "okay";
-
-       label = "lan3";
-};
-
-&swport5 {
-       status = "okay";
-
-       label = "lan4";
-};
-
-&qpic_bam {
-       status = "okay";
-};
-
-&usb2_hs_phy {
-       status = "okay";
-};
-
-&usb3_ss_phy {
-       status = "okay";
-};
-
-&usb3_hs_phy {
-       status = "okay";
-};
-
-&wifi0 {
-       status = "okay";
-       nvmem-cell-names = "pre-calibration", "mac-address";
-       nvmem-cells = <&precal_art_1000>, <&macaddr_mac_0>;
-       qcom,ath10k-calibration-variant = "zte,mf287plus";
-};
-
-&wifi1 {
-       status = "okay";
-       nvmem-cell-names = "pre-calibration", "mac-address";
-       nvmem-cells = <&precal_art_5000>, <&macaddr_mac_0>;
-       mac-address-increment = <1>;
-       qcom,ath10k-calibration-variant = "zte,mf287plus";
-};
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287_common.dtsi b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287_common.dtsi
new file mode 100644 (file)
index 0000000..dcb4915
--- /dev/null
@@ -0,0 +1,181 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+// Copyright (c) 2022, Pawel Dembicki <paweldembicki@gmail.com>.
+// Copyright (c) 2022, Giammarco Marzano <stich86@gmail.com>.
+// Copyright (c) 2023, Andreas Böhler <dev@aboehler.at>
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/soc/qcom,tcsr.h>
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+
+/ {
+       aliases {
+               led-boot = &led_status;
+               led-failsafe = &led_status;
+               led-running = &led_status;
+               led-upgrade = &led_status;
+       };
+
+       chosen {
+               /*
+                * bootargs forced by u-boot bootipq command:
+                * 'ubi.mtd=rootfs root=mtd:ubi_rootfs rootfstype=squashfs rootwait'
+                */
+               bootargs-append = " root=/dev/ubiblock0_1";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status: led-0 {
+                       label = "blue:power";
+                       function = LED_FUNCTION_POWER;
+                       color = <LED_COLOR_ID_BLUE>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               key_reset: key-reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+               };
+
+               key_wps: key-wps {
+                       label = "wps";
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+
+       soc {
+               rng@22000 {
+                       status = "okay";
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@194b000 {
+                       /* select hostmode */
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+                       status = "okay";
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+       };
+};
+
+&mdio {
+       status = "okay";
+};
+
+&watchdog {
+       status = "okay";
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&usb2 {
+       status = "okay";
+};
+
+&usb3 {
+       status = "okay";
+};
+
+&blsp1_uart1 {
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+};
+
+&crypto {
+       status = "okay";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&gmac {
+       status = "okay";
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_mac_0>;
+       mac-address-increment = <2>;
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport2 {
+       status = "okay";
+
+       label = "lan1";
+};
+
+&swport3 {
+       status = "okay";
+
+       label = "lan2";
+};
+
+&swport4 {
+       status = "okay";
+
+       label = "lan3";
+};
+
+&swport5 {
+       status = "okay";
+
+       label = "lan4";
+};
+
+&qpic_bam {
+       status = "okay";
+};
+
+&usb2_hs_phy {
+       status = "okay";
+};
+
+&usb3_ss_phy {
+       status = "okay";
+};
+
+&usb3_hs_phy {
+       status = "okay";
+};
+
+&wifi0 {
+       status = "okay";
+       nvmem-cell-names = "pre-calibration", "mac-address";
+       nvmem-cells = <&precal_art_1000>, <&macaddr_mac_0>;
+};
+
+&wifi1 {
+       status = "okay";
+       nvmem-cell-names = "pre-calibration", "mac-address";
+       nvmem-cells = <&precal_art_5000>, <&macaddr_mac_0>;
+       mac-address-increment = <1>;
+};
index db8c8c9ad02a9f20668ccc610204f6fef3d29476..b5f386fa4bbd9c3e0282048ed1afb099f5fb1427 100644 (file)
@@ -3,7 +3,7 @@
 // Copyright (c) 2022, Giammarco Marzano <stich86@gmail.com>.
 // Copyright (c) 2023, Andreas Böhler <dev@aboehler.at>
 
-#include "qcom-ipq4018-mf287.dtsi"
+#include "qcom-ipq4018-mf287_common.dtsi"
 
 / {
        model = "ZTE MF287Plus";
                };
        };
 };
+
+&wifi0 {
+       qcom,ath10k-calibration-variant = "zte,mf287plus";
+};
+
+&wifi1{
+       qcom,ath10k-calibration-variant = "zte,mf287plus";
+};
index dda0f74449b7c67b9a0cf78faefe49103d1a325e..0af7b0426b371b5e7d064a93e433adfd59c82fab 100644 (file)
@@ -3,7 +3,7 @@
 // Copyright (c) 2022, Giammarco Marzano <stich86@gmail.com>.
 // Copyright (c) 2023, Andreas Böhler <dev@aboehler.at>
 
-#include "qcom-ipq4018-mf287.dtsi"
+#include "qcom-ipq4018-mf287_common.dtsi"
 
 / {
        model = "ZTE MF287Pro";
                };
        };
 };
+
+/* The MF287Plus and MF287Pro share the same board data file */
+&wifi0 {
+       qcom,ath10k-calibration-variant = "zte,mf287plus";
+};
+
+/* The MF287Plus and MF287Pro share the same board data file */
+&wifi1{
+       qcom,ath10k-calibration-variant = "zte,mf287plus";
+};
index 6dd4549f8df8575151b1f0d633cee1b2d6bba58e..a723e99e64b59f1a9a9ca6c68683fbafd28145e2 100644 (file)
@@ -1168,7 +1168,6 @@ TARGET_DEVICES += zte_mf286d
 
 define Device/zte_mf287_common
        $(call Device/zte_mf28x_common)
-       DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
        SOC := qcom-ipq4018
 #      The recovery image is used to return back to stock (an initramfs-based image
 #      that can be flashed to the device via sysupgrade
@@ -1181,15 +1180,23 @@ endef
 
 define Device/zte_mf287plus
        $(call Device/zte_mf287_common)
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
        DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
        DEVICE_MODEL := MF287Plus
-       DEVICE_ALT0_VENDOR := ZTE
-       DEVICE_ALT0_MODEL := MF287
 endef
 TARGET_DEVICES += zte_mf287plus
 
+define Device/zte_mf287
+       $(call Device/zte_mf287_common)
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+       DEVICE_MODEL := MF287
+endef
+TARGET_DEVICES += zte_mf287
+
 define Device/zte_mf287pro
        $(call Device/zte_mf287_common)
+       DEVICE_PACKAGES += ipq-wifi-zte_mf287plus
        DEVICE_DTS_CONFIG := config@ap.dk04.1-c1
        DEVICE_MODEL := MF287Pro
 endef