opkg: drop argument from check_signature in opkg.conf
authorJonas Gorski <jonas.gorski@gmail.com>
Mon, 10 Sep 2018 09:42:53 +0000 (11:42 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 22 Jan 2019 12:22:49 +0000 (13:22 +0100)
check_signature is a bool option and doesn't take any arguments. The
presence of the 1 falsely suggests setting it to 0 disables the check,
while the option actually needs to be removed or commented out to be
disabled. So remove the argument to make it more clear.

Fixes: beca028bd6bb ("build: add integration for managing opkg package feed keys")
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
(backported from commit d3bf5ff9bc7b55b2a3dab93853b33a0cd2c4ca47)

package/system/opkg/Makefile

index 876a72d0161c473e12d972b46ca225f6a570545f..5e57c2f0ed3f714809d80b8e295880ca42667882 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=opkg
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
 PKG_FLAGS:=essential
 
 PKG_SOURCE_PROTO:=git
@@ -91,7 +91,7 @@ define Package/opkg/install
        $(INSTALL_BIN) ./files/20_migrate-feeds $(1)/etc/uci-defaults/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
   ifneq ($(CONFIG_SIGNED_PACKAGES),)
-       echo "option check_signature 1" >> $(1)/etc/opkg.conf
+       echo "option check_signature" >> $(1)/etc/opkg.conf
   endif
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/