kernel: bump 4.14 to 4.14.245
authorDavid Bauer <mail@david-bauer.net>
Sun, 29 Aug 2021 22:46:33 +0000 (00:46 +0200)
committerDavid Bauer <mail@david-bauer.net>
Thu, 2 Sep 2021 20:30:34 +0000 (22:30 +0200)
Compile-tested: ath79-generic
Run-tested: ath79-generic

Signed-off-by: David Bauer <mail@david-bauer.net>
24 files changed:
include/kernel-version.mk
target/linux/brcm2708/patches-4.14/950-0170-lan78xx-Avoid-spurious-kevent-4-error.patch
target/linux/brcm2708/patches-4.14/950-0251-lan78xx-Read-initial-EEE-status-from-DT.patch
target/linux/brcm2708/patches-4.14/950-0252-lan78xx-Change-LEDs-to-include-10Mb-activity.patch
target/linux/brcm2708/patches-4.14/950-0257-lan78xx-Read-LED-states-from-Device-Tree.patch
target/linux/brcm2708/patches-4.14/950-0265-net-lan78xx-Allow-for-VLAN-headers-in-timeout.patch
target/linux/brcm2708/patches-4.14/950-0268-lan78xx-Move-enabling-of-EEE-into-PHY-init-code.patch
target/linux/brcm2708/patches-4.14/950-0269-net-lan78xx-Request-s-w-csum-check-on-VLAN-tagged-pa.patch
target/linux/brcm2708/patches-4.14/950-0270-net-lan78xx-Add-support-for-VLAN-filtering.patch
target/linux/brcm2708/patches-4.14/950-0271-net-lan78xx-Add-support-for-VLAN-tag-stripping.patch
target/linux/brcm2708/patches-4.14/950-0272-net-lan78xx-Reduce-s-w-csum-check-on-VLANs.patch
target/linux/brcm2708/patches-4.14/950-0314-net-lan78xx-Disable-TCP-Segmentation-Offload-TSO.patch
target/linux/brcm2708/patches-4.14/950-0359-net-lan78xx-fix-rx-handling-before-first-packet-is-s.patch
target/linux/brcm2708/patches-4.14/950-0360-lan78xx-Fix-link-status-notifications.patch
target/linux/brcm2708/patches-4.14/950-0443-net-lan78xx-Support-auto-downshift-to-100Mb-s.patch
target/linux/brcm2708/patches-4.14/950-0454-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
target/linux/brcm2708/patches-4.14/961-lan78xx-enable-LED.patch
target/linux/generic/hack-4.14/220-gc_sections.patch
target/linux/generic/hack-4.14/221-module_exports.patch
target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
target/linux/mediatek/patches-4.14/0032-net-dsa-mediatek-add-support-for-GMAC2-wired-to-ext-.patch
target/linux/mediatek/patches-4.14/0033-dsa-multi-cpu.patch
target/linux/mediatek/patches-4.14/0044-net-next-dsa-mediatek-tell-GDMA-when-we-are-turning-.patch
target/linux/mediatek/patches-4.14/0045-net-dsa-mediatek-turn-into-platform-driver.patch

index a3527c142d98fcc1dd970ede0545469ab5d5eef9..5636a112162e2f7cc83b229138499bb635931c13 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .244
+LINUX_VERSION-4.14 = .245
 
-LINUX_KERNEL_HASH-4.14.244 = b6e0bfa171959aef36817e28f9010f5a949488db122a6ea7a4e8b8325923a574
+LINUX_KERNEL_HASH-4.14.245 = 0d7461890bca7eb836ff9f61b129cead97c80725577f7077a5fd67b18ea6b220
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 273dc54cd2b9cea4a6e83933cb5fc8c8f4e6b0a4..e9b4d3855d55260cdc9f5c446d1954bf8a1a8a56 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2496,7 +2496,7 @@ static void lan78xx_init_stats(struct la
+@@ -2504,7 +2504,7 @@ static void lan78xx_init_stats(struct la
        dev->stats.rollover_max.eee_tx_lpi_transitions = 0xFFFFFFFF;
        dev->stats.rollover_max.eee_tx_lpi_time = 0xFFFFFFFF;
  
index 41f7d8d2d393bec5da25bdb7810ef12118ee2de8..7b7c04f11c461f994bc875eed1564b9e36780d01 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2512,6 +2512,22 @@ static int lan78xx_open(struct net_devic
+@@ -2520,6 +2520,22 @@ static int lan78xx_open(struct net_devic
  
        netif_dbg(dev, ifup, dev->net, "phy initialised successfully");
  
index 768c92100b732cb971d00b773949f2ba2ad0627d..47c20a7f132e59e56f6d53e9aedf98f711ce47f4 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -1996,6 +1996,7 @@ static int lan78xx_phy_init(struct lan78
+@@ -2004,6 +2004,7 @@ static int lan78xx_phy_init(struct lan78
  {
        int ret;
        u32 mii_adv;
@@ -22,7 +22,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        struct phy_device *phydev = dev->net->phydev;
  
        phydev = phy_find_first(dev->mdiobus);
-@@ -2068,6 +2069,19 @@ static int lan78xx_phy_init(struct lan78
+@@ -2076,6 +2077,19 @@ static int lan78xx_phy_init(struct lan78
        mii_adv = (u32)mii_advertise_flowctrl(dev->fc_request_control);
        phydev->advertising |= mii_adv_to_ethtool_adv_t(mii_adv);
  
index b32ff390d6be0202ce22fe515cf5e2b4d6c37c5a..d9de18f40122de5ab0eb1df2ad6565e840b65404 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -1996,7 +1996,9 @@ static int lan78xx_phy_init(struct lan78
+@@ -2004,7 +2004,9 @@ static int lan78xx_phy_init(struct lan78
  {
        int ret;
        u32 mii_adv;
@@ -30,7 +30,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        struct phy_device *phydev = dev->net->phydev;
  
        phydev = phy_find_first(dev->mdiobus);
-@@ -2069,18 +2071,27 @@ static int lan78xx_phy_init(struct lan78
+@@ -2077,18 +2079,27 @@ static int lan78xx_phy_init(struct lan78
        mii_adv = (u32)mii_advertise_flowctrl(dev->fc_request_control);
        phydev->advertising |= mii_adv_to_ethtool_adv_t(mii_adv);
  
index fc495f19119a4096f0740412bcfc80c3467344e6..fa4dbcd35e6bb8d3806089357a778112dcd7e190 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2192,7 +2192,7 @@ static int lan78xx_change_mtu(struct net
+@@ -2200,7 +2200,7 @@ static int lan78xx_change_mtu(struct net
        if ((ll_mtu % dev->maxpacket) == 0)
                return -EDOM;
  
@@ -26,7 +26,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  
        netdev->mtu = new_mtu;
  
-@@ -2485,7 +2485,8 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2493,7 +2493,8 @@ static int lan78xx_reset(struct lan78xx_
        buf |= FCT_TX_CTL_EN_;
        ret = lan78xx_write_reg(dev, FCT_TX_CTL, buf);
  
index 7608325ed710cd7a74ce7530831a1a62a978b890..1d334d009142e8b79a4a25e12805ea6337c65cd3 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2071,6 +2071,22 @@ static int lan78xx_phy_init(struct lan78
+@@ -2079,6 +2079,22 @@ static int lan78xx_phy_init(struct lan78
        mii_adv = (u32)mii_advertise_flowctrl(dev->fc_request_control);
        phydev->advertising |= mii_adv_to_ethtool_adv_t(mii_adv);
  
@@ -39,7 +39,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        /* Set LED modes:
         * led: 0=link/activity          1=link1000/activity
         *      2=link100/activity       3=link10/activity
-@@ -2538,22 +2554,6 @@ static int lan78xx_open(struct net_devic
+@@ -2546,22 +2562,6 @@ static int lan78xx_open(struct net_devic
  
        netif_dbg(dev, ifup, dev->net, "phy initialised successfully");
  
index 23d29ca98302a472fed89e3bf7ee6a8f526cdad7..206bd2588d4a200b57157ae42e872b372f93569f 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2890,8 +2890,12 @@ static void lan78xx_rx_csum_offload(stru
+@@ -2898,8 +2898,12 @@ static void lan78xx_rx_csum_offload(stru
                                    struct sk_buff *skb,
                                    u32 rx_cmd_a, u32 rx_cmd_b)
  {
index 732d96c8241477c798d1cf941f93945e2f2d3c10..c66a6cde5e715a3d1d3d5331767516cf2a82c2aa 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2277,7 +2277,7 @@ static int lan78xx_set_features(struct n
+@@ -2285,7 +2285,7 @@ static int lan78xx_set_features(struct n
                pdata->rfe_ctl &= ~(RFE_CTL_ICMP_COE_ | RFE_CTL_IGMP_COE_);
        }
  
@@ -24,7 +24,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
                pdata->rfe_ctl |= RFE_CTL_VLAN_FILTER_;
        else
                pdata->rfe_ctl &= ~RFE_CTL_VLAN_FILTER_;
-@@ -2826,6 +2826,9 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2834,6 +2834,9 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_TSO_CSUM_ENABLE)
                dev->net->features |= NETIF_F_TSO | NETIF_F_TSO6 | NETIF_F_SG;
  
index 1b4a8db53706f26fb0184cccc8bc59d9804614ec..ece8542c01ead99f5bae26d4db2fe4e1f7cd8b2c 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  #define TX_OVERHEAD                   (8)
  #define RXW_PADDING                   2
  
-@@ -2277,6 +2278,11 @@ static int lan78xx_set_features(struct n
+@@ -2285,6 +2286,11 @@ static int lan78xx_set_features(struct n
                pdata->rfe_ctl &= ~(RFE_CTL_ICMP_COE_ | RFE_CTL_IGMP_COE_);
        }
  
@@ -36,7 +36,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
        if (features & NETIF_F_HW_VLAN_CTAG_FILTER)
                pdata->rfe_ctl |= RFE_CTL_VLAN_FILTER_;
        else
-@@ -2826,6 +2832,9 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2834,6 +2840,9 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_TSO_CSUM_ENABLE)
                dev->net->features |= NETIF_F_TSO | NETIF_F_TSO6 | NETIF_F_SG;
  
@@ -46,7 +46,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
        if (DEFAULT_VLAN_FILTER_ENABLE)
                dev->net->features |= NETIF_F_HW_VLAN_CTAG_FILTER;
  
-@@ -2906,6 +2915,16 @@ static void lan78xx_rx_csum_offload(stru
+@@ -2914,6 +2923,16 @@ static void lan78xx_rx_csum_offload(stru
        }
  }
  
@@ -63,7 +63,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static void lan78xx_skb_return(struct lan78xx_net *dev, struct sk_buff *skb)
  {
        int             status;
-@@ -2970,6 +2989,8 @@ static int lan78xx_rx(struct lan78xx_net
+@@ -2978,6 +2997,8 @@ static int lan78xx_rx(struct lan78xx_net
                        if (skb->len == size) {
                                lan78xx_rx_csum_offload(dev, skb,
                                                        rx_cmd_a, rx_cmd_b);
@@ -72,7 +72,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  
                                skb_trim(skb, skb->len - 4); /* remove fcs */
                                skb->truesize = size + sizeof(struct sk_buff);
-@@ -2988,6 +3009,7 @@ static int lan78xx_rx(struct lan78xx_net
+@@ -2996,6 +3017,7 @@ static int lan78xx_rx(struct lan78xx_net
                        skb_set_tail_pointer(skb2, size);
  
                        lan78xx_rx_csum_offload(dev, skb2, rx_cmd_a, rx_cmd_b);
index 0621b3493953e9fad97f453456fd13bc422ee750..7aa49a9b0389ddd52862d06795c4b6751133cd8e 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2902,12 +2902,13 @@ static void lan78xx_rx_csum_offload(stru
+@@ -2910,12 +2910,13 @@ static void lan78xx_rx_csum_offload(stru
                                    struct sk_buff *skb,
                                    u32 rx_cmd_a, u32 rx_cmd_b)
  {
index d26737bcaddf41be38e6ddb9e7e0983ca3c47175..c860f5bacb037c619a421e828df46d5722d8f1c6 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -2829,8 +2838,14 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2837,8 +2846,14 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_RX_CSUM_ENABLE)
                dev->net->features |= NETIF_F_RXCSUM;
  
index bb35c544d3b5bbe9588b79d60f5f6f42565ac41a..d308f082148f37ae5fc392278da12fb3de8ebc96 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2587,6 +2587,8 @@ static int lan78xx_open(struct net_devic
+@@ -2595,6 +2595,8 @@ static int lan78xx_open(struct net_devic
  
        dev->link_on = false;
  
index 8a44e8c100878628576156780b82af00e61332fd..5a279cdebdd27516bbb97e3bc32b166b748c529c 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2587,8 +2587,6 @@ static int lan78xx_open(struct net_devic
+@@ -2595,8 +2595,6 @@ static int lan78xx_open(struct net_devic
  
        dev->link_on = false;
  
index 8ca3290d1ba2f146ddad00ea22f715503fd24dfe..3bb25695738bd2f89c3187eba0421f15738768f7 100644 (file)
@@ -85,7 +85,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  #include <linux/of_net.h>
  #include "lan78xx.h"
  
-@@ -1760,6 +1761,7 @@ done:
+@@ -1768,6 +1769,7 @@ done:
  
  static int lan78xx_mdio_init(struct lan78xx_net *dev)
  {
@@ -93,7 +93,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        int ret;
  
        dev->mdiobus = mdiobus_alloc();
-@@ -1789,7 +1791,9 @@ static int lan78xx_mdio_init(struct lan7
+@@ -1797,7 +1799,9 @@ static int lan78xx_mdio_init(struct lan7
                break;
        }
  
index ba3927794fba189b02ecd5c038deffb857d6f718..c323ced943cbf64f51607f7bb34c9da8f9137ebd 100644 (file)
@@ -28,7 +28,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3679,7 +3684,12 @@ static int lan78xx_probe(struct usb_inte
+@@ -3687,7 +3692,12 @@ static int lan78xx_probe(struct usb_inte
        netdev->max_mtu = MAX_SINGLE_PACKET_SIZE;
        netif_set_gso_max_size(netdev, MAX_SINGLE_PACKET_SIZE - MAX_HEADER);
  
index 79243675f7ab6aca1b50a13fc3b197b9c46b02f8..2b9f91137bc71667eb410662e2b70eb295b35b36 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2460,6 +2460,15 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2468,6 +2468,15 @@ static int lan78xx_reset(struct lan78xx_
  
        ret = lan78xx_read_reg(dev, HW_CFG, &buf);
        buf |= HW_CFG_MEF_;
index c91c25dab1870d1b72ac6582ee78ec036ce562fa..db6564ed7a740081f4ad2875e98ad933fa87b137 100644 (file)
@@ -238,7 +238,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
  /*
   * Data section helpers
-@@ -500,7 +501,7 @@
+@@ -501,7 +502,7 @@
  #define ENTRY_TEXT                                                    \
                ALIGN_FUNCTION();                                       \
                VMLINUX_SYMBOL(__entry_text_start) = .;                 \
@@ -247,7 +247,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
                VMLINUX_SYMBOL(__entry_text_end) = .;
  
  #define IRQENTRY_TEXT                                                 \
-@@ -607,7 +608,7 @@
+@@ -608,7 +609,7 @@
        . = ALIGN(sbss_align);                                          \
        .sbss : AT(ADDR(.sbss) - LOAD_OFFSET) {                         \
                *(.dynsbss)                                             \
index 8faa3e752a6ede75e27344fcf36e5848c19d278f..bf08819cb6bc31d23263ae204741e0512afac7d3 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }                                                               \
                                                                        \
        /* __*init sections */                                          \
-@@ -804,6 +814,8 @@
+@@ -805,6 +815,8 @@
        EXIT_TEXT                                                       \
        EXIT_DATA                                                       \
        EXIT_CALL                                                       \
index 083a518bba7718a8a09bf3e5d31b5616f378b703..f9cb810b5c8f3102389530754f213e116aa8e4ed 100644 (file)
@@ -509,7 +509,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
   * @dma_pfn_offset: offset of DMA memory range relatively of RAM
   * @dma_parms:        A low level driver may set these to teach IOMMU code about
   *            segment limitations.
-@@ -930,6 +938,7 @@ struct device {
+@@ -931,6 +939,7 @@ struct device {
                                             not all hardware supports
                                             64 bit addresses for consistent
                                             allocations such descriptors. */
@@ -517,7 +517,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        unsigned long   dma_pfn_offset;
  
        struct device_dma_parameters *dma_parms;
-@@ -1268,6 +1277,7 @@ extern const char *dev_driver_string(con
+@@ -1269,6 +1278,7 @@ extern const char *dev_driver_string(con
  struct device_link *device_link_add(struct device *consumer,
                                    struct device *supplier, u32 flags);
  void device_link_del(struct device_link *link);
index c01703d07b8b60bd84ebba68f095fccf1efc8024..44d6cdfe4f40ce14bcfcd85a2f032b917c33dd3b 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -991,6 +991,11 @@ mt7530_setup(struct dsa_switch *ds)
+@@ -992,6 +992,11 @@ mt7530_setup(struct dsa_switch *ds)
        val = mt7530_read(priv, MT7530_MHWTRAP);
        val &= ~MHWTRAP_P6_DIS & ~MHWTRAP_PHY_ACCESS;
        val |= MHWTRAP_MANUAL;
index 0442506977260c60bc145967ac69cdc07dde4ec6..a317b52e1305a4902df658ffc66646fb040a6c84 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -670,6 +670,9 @@ static int
+@@ -671,6 +671,9 @@ static int
  mt7530_cpu_port_enable(struct mt7530_priv *priv,
                       int port)
  {
@@ -10,7 +10,7 @@
        /* Enable Mediatek header mode on the cpu port */
        mt7530_write(priv, MT7530_PVC_P(port),
                     PORT_SPEC_TAG);
-@@ -686,8 +689,12 @@ mt7530_cpu_port_enable(struct mt7530_pri
+@@ -687,8 +690,12 @@ mt7530_cpu_port_enable(struct mt7530_pri
        /* CPU port gets connected to all user ports of
         * the switch
         */
@@ -24,7 +24,7 @@
  
        return 0;
  }
-@@ -697,6 +704,7 @@ mt7530_port_enable(struct dsa_switch *ds
+@@ -698,6 +705,7 @@ mt7530_port_enable(struct dsa_switch *ds
                   struct phy_device *phy)
  {
        struct mt7530_priv *priv = ds->priv;
@@ -32,7 +32,7 @@
  
        mutex_lock(&priv->reg_mutex);
  
-@@ -707,7 +715,7 @@ mt7530_port_enable(struct dsa_switch *ds
+@@ -708,7 +716,7 @@ mt7530_port_enable(struct dsa_switch *ds
         * restore the port matrix if the port is the member of a certain
         * bridge.
         */
@@ -41,7 +41,7 @@
        priv->ports[port].enable = true;
        mt7530_rmw(priv, MT7530_PCR_P(port), PCR_MATRIX_MASK,
                   priv->ports[port].pm);
-@@ -770,7 +778,8 @@ mt7530_port_bridge_join(struct dsa_switc
+@@ -771,7 +779,8 @@ mt7530_port_bridge_join(struct dsa_switc
                        struct net_device *bridge)
  {
        struct mt7530_priv *priv = ds->priv;
@@ -51,7 +51,7 @@
        int i;
  
        mutex_lock(&priv->reg_mutex);
-@@ -808,6 +817,7 @@ mt7530_port_bridge_leave(struct dsa_swit
+@@ -809,6 +818,7 @@ mt7530_port_bridge_leave(struct dsa_swit
                         struct net_device *bridge)
  {
        struct mt7530_priv *priv = ds->priv;
@@ -59,7 +59,7 @@
        int i;
  
        mutex_lock(&priv->reg_mutex);
-@@ -832,8 +842,8 @@ mt7530_port_bridge_leave(struct dsa_swit
+@@ -833,8 +843,8 @@ mt7530_port_bridge_leave(struct dsa_swit
         */
        if (priv->ports[port].enable)
                mt7530_rmw(priv, MT7530_PCR_P(port), PCR_MATRIX_MASK,
@@ -70,7 +70,7 @@
  
        mutex_unlock(&priv->reg_mutex);
  }
-@@ -908,15 +918,7 @@ err:
+@@ -909,15 +919,7 @@ err:
  static enum dsa_tag_protocol
  mtk_get_tag_protocol(struct dsa_switch *ds)
  {
@@ -87,7 +87,7 @@
  }
  
  static int
-@@ -989,7 +991,7 @@ mt7530_setup(struct dsa_switch *ds)
+@@ -990,7 +992,7 @@ mt7530_setup(struct dsa_switch *ds)
  
        /* Enable Port 6 only; P5 as GMAC5 which currently is not supported */
        val = mt7530_read(priv, MT7530_MHWTRAP);
index 4a69e7aadf48795fb1a1de1cea4ba49db72f71a6..9bb7ce152ecf41e88292818cb2511083622e24df 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -677,6 +677,11 @@ mt7530_cpu_port_enable(struct mt7530_pri
+@@ -678,6 +678,11 @@ mt7530_cpu_port_enable(struct mt7530_pri
        mt7530_write(priv, MT7530_PVC_P(port),
                     PORT_SPEC_TAG);
  
index 55f10157704f5700b27cb2bb404fc2c52ccb3085..01c62b03ac3eddd1b1fdce01ef6d9d94f496b6fb 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -1049,10 +1049,10 @@ static const struct dsa_switch_ops mt753
+@@ -1050,10 +1050,10 @@ static const struct dsa_switch_ops mt753
  };
  
  static int
@@ -23,7 +23,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  
        dn = mdiodev->dev.of_node;
  
-@@ -1100,7 +1100,12 @@ mt7530_probe(struct mdio_device *mdiodev
+@@ -1101,7 +1101,12 @@ mt7530_probe(struct mdio_device *mdiodev
                }
        }
  
@@ -37,7 +37,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        priv->dev = &mdiodev->dev;
        priv->ds->priv = priv;
        priv->ds->ops = &mt7530_switch_ops;
-@@ -1110,8 +1115,8 @@ mt7530_probe(struct mdio_device *mdiodev
+@@ -1111,8 +1116,8 @@ mt7530_probe(struct mdio_device *mdiodev
        return dsa_register_switch(priv->ds);
  }
  
@@ -48,7 +48,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  {
        struct mt7530_priv *priv = dev_get_drvdata(&mdiodev->dev);
        int ret = 0;
-@@ -1128,6 +1133,8 @@ mt7530_remove(struct mdio_device *mdiode
+@@ -1129,6 +1134,8 @@ mt7530_remove(struct mdio_device *mdiode
  
        dsa_unregister_switch(priv->ds);
        mutex_destroy(&priv->reg_mutex);
@@ -57,7 +57,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  }
  
  static const struct of_device_id mt7530_of_match[] = {
-@@ -1136,16 +1143,16 @@ static const struct of_device_id mt7530_
+@@ -1137,16 +1144,16 @@ static const struct of_device_id mt7530_
  };
  MODULE_DEVICE_TABLE(of, mt7530_of_match);