base-files-network: configure vlan interface name type immediately before the vconfig...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 13 Mar 2012 12:25:28 +0000 (12:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 13 Mar 2012 12:25:28 +0000 (12:25 +0000)
SVN-Revision: 30919

package/base-files-network/Makefile
package/base-files-network/files/lib/network/config.sh

index 65ed020ac9171bd745fcfd547c3be7132c7db035..80e78154f514f2d17d8a114d474db17cb258faac 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files-network
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_BUILD_DEPENDS:=opkg/host
 
index feeaa2f9ce3099c22ed503255df83e677c343fa4..a58ab1edcf5e5def4569c736f38511da6d1f2c96 100755 (executable)
@@ -83,6 +83,7 @@ add_vlan() {
 
        [ "$1" = "$vif" ] || ifconfig "$1" >/dev/null 2>/dev/null || {
                ifconfig "$vif" up 2>/dev/null >/dev/null || add_vlan "$vif"
+               $DEBUG vconfig set_name_type DEV_PLUS_VID_NO_PAD
                $DEBUG vconfig add "$vif" "${1##*\.}"
                return 0
        }
@@ -218,7 +219,8 @@ prepare_interface() {
                                        $DEBUG brctl addif "br-$config" "$iface"
                                        $DEBUG brctl stp "br-$config" $stp
                                        [ -z "$macaddr" ] && macaddr="$(cat /sys/class/net/$iface/address)"
-                                       echo $igmp_snooping > /sys/devices/virtual/net/br-$config/bridge/multicast_snooping 2>/dev/null
+                                       [ -e /sys/devices/virtual/net/br-$config/bridge/multicast_snooping ] && \
+                                               echo $igmp_snooping > /sys/devices/virtual/net/br-$config/bridge/multicast_snooping
                                        $DEBUG ifconfig "br-$config" hw ether $macaddr up
                                        # Creating the bridge here will have triggered a hotplug event, which will
                                        # result in another setup_interface() call, so we simply stop processing