ar71xx: add profile and build image for the TL-WR1041N v2 board
authorGabor Juhos <juhosg@openwrt.org>
Sat, 5 May 2012 17:02:41 +0000 (17:02 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 5 May 2012 17:02:41 +0000 (17:02 +0000)
Patch-by: Vince Huang <axishero@foxmail.com>
SVN-Revision: 31610

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index 96ff12ae74cd432c42c39376009580b4c36a2cd5..5c18c44717252f3bfd38bac90da36bc2d0c7d1e4 100644 (file)
@@ -149,6 +149,17 @@ endef
 $(eval $(call Profile,TLWR941))
 
 
+define Profile/TLWR1041
+       NAME:=TP-LINK TL-WR1041N
+       PACKAGES:=
+endef
+
+define Profile/TLWR1041/Description
+       Package set optimized for the TP-LINK TL-WR1041N/ND.
+endef
+$(eval $(call Profile,TLWR1041))
+
+
 define Profile/TLWR1043
        NAME:=TP-LINK TL-WR1043N/ND
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
index 3df96251b4db8e714ac7f496f01d2914caa02d6f..f99c01ab150a3843085c80923aada0e53d5e71b5 100644 (file)
@@ -948,6 +948,11 @@ define Image/Build/Profile/TLWR941
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr941nd-v4,$(tlwr941v4_cmdline),0x09410004,1,4M)
 endef
 
+tlwr1041_cmdline=board=TL-WR1041N-v2 console=ttyS0,115200
+define Image/Build/Profile/TLWR1041
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wr1041n-v2,$(tlwr1041_cmdline),0x10410002,1,8Mlzma)
+endef
+
 tlwr1043_cmdline=board=TL-WR1043ND console=ttyS0,115200
 define Image/Build/Profile/TLWR1043
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr1043nd-v1,$(tlwr1043_cmdline),0x10430001,1,8M)
@@ -1087,6 +1092,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR841,$(1))
        $(call Image/Build/Profile/TLWR842,$(1))
        $(call Image/Build/Profile/TLWR941,$(1))
+       $(call Image/Build/Profile/TLWR1041,$(1))
        $(call Image/Build/Profile/TLWR1043,$(1))
        $(call Image/Build/Profile/TLWR2543,$(1))
        $(call Image/Build/Profile/UBNT,$(1))