ramips: Make serial console for DIR-300-B1 work again
authorGabor Juhos <juhosg@openwrt.org>
Wed, 2 May 2012 19:17:58 +0000 (19:17 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 2 May 2012 19:17:58 +0000 (19:17 +0000)
Make serial console for DIR-300-B1 work again.

With some recent change, "console=ttyS1,57600" was removed from the
default kernel command line, this adds the necessary mkcmdline
incantation to image/Makefile to add it there for this target.
This is quite likely broken for other targets as well.

Without this the console switches to ttyS0 instead of ttyS1 and
kernel output is missing, and the userspace comes up with 9600 baud
instead of 57600.

Signed-off-by: Tobias Diedrich <ranma+openwrt@tdiedrich.de>
SVN-Revision: 31556

target/linux/ramips/image/Makefile

index 3d4d64933b469f15952963721fe8d6619549ba54..88b20fa3d8ecb6399722a5b836692e62b427627e 100644 (file)
@@ -158,14 +158,14 @@ mtdlayout_dir300b1=192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,896k(kernel),288
 mtd_dir300b1_kernel_part_size=917504
 mtd_dir300b1_rootfs_part_size=2949120
 define BuildFirmware/DIR300B1
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
+       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),ttyS1,57600) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
        mkwrgimg -s $(4) -d /dev/mtdblock/2 \
                -i $(call sysupname,$(1),$(2)) \
                -o $(call imgname,$(1),$(2))-factory.bin
 endef
 
 define BuildFirmware/DIR300B1/initramfs
-       $(call BuildFirmware/Generic/initramfs,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
+       $(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),ttyS1,57600) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
 endef
 
 define BuildFirmware/Edimax