layerscape: remove Traverse LS1043 boards
authorMathew McBride <matt@traverse.com.au>
Tue, 27 Jun 2023 04:20:50 +0000 (04:20 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 1 Jul 2023 13:47:08 +0000 (15:47 +0200)
The Traverse LS1043 boards were not publicly released,
all the production has been going to OEM customers who
do not use the image format defined in the OpenWrt tree.

Only a few samples were circulated outside Traverse
and our OEM customers. The public release (then called
Five64) of this series was cancelled in favour of our
LS1088A based design (Ten64).

It is best to remove these boards to avoid wasting
OpenWrt project and contributor resources.

Signed-off-by: Mathew McBride <matt@traverse.com.au>
package/boot/uboot-envtools/files/layerscape
target/linux/layerscape/base-files/etc/board.d/01_led
target/linux/layerscape/base-files/etc/board.d/02_network
target/linux/layerscape/base-files/etc/board.d/03_gpio_switches
target/linux/layerscape/base-files/lib/preinit/05_layerscape_reorder_eth [deleted file]
target/linux/layerscape/base-files/lib/upgrade/platform.sh
target/linux/layerscape/files/arch/arm64/boot/dts/freescale/traverse-ls1043s.dts [deleted file]
target/linux/layerscape/files/arch/arm64/boot/dts/freescale/traverse-ls1043v.dts [deleted file]
target/linux/layerscape/image/Makefile
target/linux/layerscape/image/armv8_64b.mk
target/linux/layerscape/patches-5.15/300-add-DTS-for-Traverse-LS1043-Boards.patch [deleted file]

index bc7dcf24f9edbe098a87b53eea0e5976b6821644..acc5a073ad9b45333b298303875a350dde03ab1d 100644 (file)
@@ -12,10 +12,6 @@ touch /etc/config/ubootenv
 board=$(board_name)
 
 case "$board" in
-       traverse,ls1043v|\
-       traverse,ls1043s)
-               ubootenv_add_uci_config "/dev/mtd1" "0x40000" "0x2000"  "0x20000"
-       ;;
        traverse,ten64)
                ubootenv_add_uci_config "/dev/mtd3" "0x0000" "0x80000" "0x80000"
        ;;
index a21c21980abb7d85d2e0b5ca7aa7e5db9f4a330c..8a0e5c4b956516f1e5b68902ca3952e5e44c133d 100644 (file)
@@ -9,14 +9,6 @@ board_config_update
 board=$(board_name)
 
 case "$board" in
-traverse,ls1043v)
-       ucidef_set_led_netdev "wan" "WAN LED" "ls1043v:yellow:wan" "eth4"
-       ;;
-traverse,ls1043s)
-       ucidef_set_led_netdev "wan" "WAN LED" "ls1043s:yellow:wan" "eth4"
-       ucidef_set_led_netdev "xgact" "10G Activity" "ls1043s:yellow:10gact" "eth6"
-       ucidef_set_led_netdev "xglink" "10G Link" "ls1043s:green:10glink" "eth6"
-       ;;
 traverse,ten64)
        ucidef_set_led_netdev "sfp1" "SFP 1" "ten64:green:sfp1:down" "eth8" "link tx rx"
        ucidef_set_led_netdev "sfp2" "SFP 2" "ten64:green:sfp2:up" "eth9" "link tx rx"
index 7bc5f9b50296b6be7cfcb04189283eaca353577a..0a423238011190a6b327bb98aa8de377799de98d 100644 (file)
@@ -9,14 +9,6 @@ case "$(board_name)" in
        fsl,ls1028a-rdb-sdboot)
                ucidef_set_interfaces_lan_wan "swp0 swp1 swp2 swp3" "eth0"
                ;;
-       traverse,ls1043v)
-               ucidef_set_interface_lan "eth0 eth1 eth2 eth3"
-               ucidef_set_interface_wan "eth4"
-               ;;
-       traverse,ls1043s)
-               ucidef_set_interface_lan "eth0 eth1 eth2 eth3 eth6"
-               ucidef_set_interface_wan "eth4"
-               ;;
        traverse,ten64)
                ucidef_set_interface_lan "eth0 eth1 eth2 eth3"
                ucidef_set_interface_wan "eth6"
index 5e0e24ef28726ecaa6955b2f090206a0d6e0f65d..46e54b960da77d1e415dc26901f738551fa07354 100644 (file)
@@ -9,17 +9,6 @@ board_config_update
 board=$(board_name)
 
 case "$board" in
-traverse,ls1043v)
-       ucidef_add_gpio_switch "lte_reset" "LTE Reset" "377"
-       ucidef_add_gpio_switch "lte_disable" "LTE Airplane mode" "378"
-       ;;
-traverse,ls1043s)
-       ucidef_add_gpio_switch "tensfp_txdisable" "SFP+ TX Disable" "378"
-       ucidef_add_gpio_switch "gigsfp_txdisable" "SFP TX Disable" "381"
-       ucidef_add_gpio_switch "lte_reset" "LTE Reset" "502"
-       ucidef_add_gpio_switch "lte_disable" "LTE Airplane Mode" "394"
-       ucidef_add_gpio_switch "lte_power" "LTE Power" "395"
-       ;;
 traverse,ten64)
        ucidef_add_gpio_switch "lte_reset" "Cell Modem Reset" "376"
        ucidef_add_gpio_switch "lte_power" "Cell Modem Power" "377"
diff --git a/target/linux/layerscape/base-files/lib/preinit/05_layerscape_reorder_eth b/target/linux/layerscape/base-files/lib/preinit/05_layerscape_reorder_eth
deleted file mode 100644 (file)
index c6b741a..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-reorder_layerscape_interfaces() {
-       if [ ! -f /tmp/sysinfo/board_name ]; then
-               echo "No board name found, not doing reorder_layerscape_interfaces"
-               return 0
-       fi
-
-       board=$(cat /tmp/sysinfo/board_name)
-       case "$board" in
-       traverse,ls1043v|\
-       traverse,ls1043s)
-
-               # Reorder ethernet interfaces to match the physical order
-               ip link set eth2 name fm1-mac3
-               ip link set eth4 name eth2
-               ip link set eth3 name fm1-mac4
-               ip link set eth5 name eth3
-               ip link set fm1-mac3 name eth4
-               ip link set fm1-mac4 name eth5
-               ;;
-       default)
-               echo "Unknown board $board"
-               ;;
-       esac
-}
-
-boot_hook_add preinit_main reorder_layerscape_interfaces
index c63cf05e5cc1e0b7d19f05bb0508735d841db27b..0b5d14b579cfbb1d3294239da89368b3c788d7a1 100644 (file)
@@ -31,23 +31,6 @@ platform_do_upgrade_sdboot() {
        echo "Writing rootfs..."
        tar xf $tar_file ${board_dir}/root -O  | dd of=/dev/mmcblk0p2 bs=512k > /dev/null 2>&1
 
-}
-platform_do_upgrade_traverse_nandubi() {
-       bootsys=$(fw_printenv bootsys | awk -F= '{{print $2}}')
-       newbootsys=2
-       if [ "$bootsys" -eq "2" ]; then
-               newbootsys=1
-       fi
-
-       # If nand_do_upgrade succeeds, we don't have an opportunity to add any actions of
-       # our own, so do it here and set back on failure
-       echo "Setting bootsys to #${newbootsys}"
-       fw_setenv bootsys $newbootsys
-       CI_UBIPART="nandubi"
-       CI_KERNPART="kernel${newbootsys}"
-       CI_ROOTPART="rootfs${newbootsys}"
-       nand_do_upgrade "$1" || (echo "Upgrade failed, setting bootsys ${bootsys}" && fw_setenv bootsys $bootsys)
-
 }
 
 platform_do_upgrade_traverse_slotubi() {
@@ -105,11 +88,6 @@ platform_check_image() {
        local board=$(board_name)
 
        case "$board" in
-       traverse,ls1043v | \
-       traverse,ls1043s)
-               nand_do_platform_check "traverse-ls1043" $1
-               return $?
-               ;;
        traverse,ten64)
                nand_do_platform_check "ten64-mtd" $1
                return $?
@@ -150,10 +128,6 @@ platform_do_upgrade() {
        touch /var/lock/fw_printenv.lock
 
        case "$board" in
-       traverse,ls1043v | \
-       traverse,ls1043s)
-               platform_do_upgrade_traverse_nandubi "$1"
-               ;;
        traverse,ten64)
                platform_do_upgrade_traverse_slotubi "${1}"
                ;;
diff --git a/target/linux/layerscape/files/arch/arm64/boot/dts/freescale/traverse-ls1043s.dts b/target/linux/layerscape/files/arch/arm64/boot/dts/freescale/traverse-ls1043s.dts
deleted file mode 100644 (file)
index 81044aa..0000000
+++ /dev/null
@@ -1,332 +0,0 @@
-/*
- * Device Tree Include file for Traverse LS1043S board.
- *
- * Copyright 2014-2015, Freescale Semiconductor
- * Copyright 2017-2018, Traverse Technologies
- *
- * This file is dual-licensed: you can use it either under the terms
- * of the GPLv2 or the X11 license, at your option. Note that this dual
- * licensing only applies to this file, and not this project as a
- * whole.
- *
- *  a) This library is free software; you can redistribute it and/or
- *     modify it under the terms of the GNU General Public License as
- *     published by the Free Software Foundation; either version 2 of the
- *     License, or (at your option) any later version.
- *
- *     This library is distributed in the hope that it will be useful,
- *     but WITHOUT ANY WARRANTY; without even the implied warranty of
- *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- *     GNU General Public License for more details.
- *
- * Or, alternatively,
- *
- *  b) Permission is hereby granted, free of charge, to any person
- *     obtaining a copy of this software and associated documentation
- *     files (the "Software"), to deal in the Software without
- *     restriction, including without limitation the rights to use,
- *     copy, modify, merge, publish, distribute, sublicense, and/or
- *     sell copies of the Software, and to permit persons to whom the
- *     Software is furnished to do so, subject to the following
- *     conditions:
- *
- *     The above copyright notice and this permission notice shall be
- *     included in all copies or substantial portions of the Software.
- *
- *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
- *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
- *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
- *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
- *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
- *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
- *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
- *     OTHER DEALINGS IN THE SOFTWARE.
- */
-
-/dts-v1/;
-#include "fsl-ls1043a.dtsi"
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "Traverse LS1043S";
-       compatible = "traverse,ls1043s";
-
-       aliases {
-               crypto = &crypto;
-               ethernet0 = &EMAC0;
-               ethernet1 = &EMAC1;
-               ethernet2 = &EMAC2;
-               ethernet3 = &EMAC3;
-               ethernet4 = &EMAC4;
-               ethernet5 = &EMAC5;
-       };
-
-       leds {
-               compatible = "gpio-leds";
-               gpio0 {
-                       label = "ls1043s:green:user0";
-                       gpios = <&gpio1 23 GPIO_ACTIVE_HIGH>;
-               };
-               gpio1 {
-                       label = "ls1043s:green:user1";
-                       gpios = <&gpio1 24 GPIO_ACTIVE_HIGH>;
-               };
-               /* LED D17 */
-               gpio2 {
-                       label = "ls1043s:green:wan";
-                       gpios = <&gpio1 26 GPIO_ACTIVE_LOW>;
-               };
-               gpio3 {
-                       label = "ls1043s:yellow:wan";
-                       gpios = <&gpio1 27 GPIO_ACTIVE_LOW>;
-               };
-               /* LED D18 */
-               gpio4 {
-                       label = "ls1043s:green:mgmt";
-                       gpios = <&gpio1 28 GPIO_ACTIVE_LOW>;
-               };
-               gpio5 {
-                       label = "ls1043s:yellow:mgmt";
-                       gpios = <&gpio1 29 GPIO_ACTIVE_LOW>;
-               };
-               /* LED D6 */
-               gpio6 {
-                       label = "ls1043s:green:user2";
-                       gpios = <&gpio1 31 GPIO_ACTIVE_HIGH>;
-               };
-
-               /* SFP+ LEDs - these are for chassis
-                * with lightpipes only
-                */
-               teng_act {
-                       label = "ls1043s:yellow:10gact";
-                       gpios = <&gpio4 0 GPIO_ACTIVE_LOW>;
-               };
-
-               teng_link {
-                       label = "ls1043s:green:10glink";
-                       gpios = <&gpio4 1 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <1000>;
-               /* This button may not be loaded on all boards */
-               button@0 {
-                       label = "Front button";
-                       linux,code = <KEY_SETUP>;
-                       gpios = <&gpio1 25 GPIO_ACTIVE_LOW>;
-               };
-               /* This is wired to header S3 */
-               button@1 {
-                       label = "Rear button";
-                       linux,code = <KEY_WPS_BUTTON>;
-                       gpios = <&gpio1 30 GPIO_ACTIVE_LOW>;
-               };
-       };
-};
-
-&esdhc {
-       mmc-hs200-1_8v;
-       sd-uhs-sdr104;
-       sd-uhs-sdr50;
-       sd-uhs-sdr25;
-       sd-uhs-sdr12;
-};
-
-&i2c0 {
-       status = "okay";
-       rtc@6f {
-               compatible = "intersil,isl1208";
-               reg = <0x6f>;
-       };
-
-       sfp_pca9534: pca9534@24 {
-               compatible = "ti,tca9534", "nxp,pca9534";
-               gpio-controller;
-               #gpio-cells = <2>;
-               reg = <0x24>;
-               gpio-base = <100>;
-       };
-
-       controller@50 {
-               compatible = "traverse,controller";
-               reg = <0x50>;
-       };
-
-       ds125df111@18 {
-               compatible = "ti,ds125df111";
-               reg = <0x18>;
-       };
-
-       emc1704@4c {
-               compatible = "microchip,emc1704";
-               reg = <0x4c>;
-       };
-
-       pac1934@16 {
-               compatible = "microchip,pac1934";
-               reg = <0x16>;
-               /* Monitoring 3.3V, 5V, Vin/12V (voltage only), Vbat/RTC (voltage only) */
-               shunt-resistors = <4000 12000 0 0>;
-       };
-
-       pmic@8 {
-               compatible = "freescale,mc34vr500";
-               reg = <0x08>;
-       };
-};
-
-/* I2C Bus for SFP EEPROM and control
- * These are multiplexed so
- * they don't collide when loaded
- */
-&i2c3 {
-       status = "okay";
-       i2c-switch@70 {
-               compatible = "nxp,pca9540";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               reg = <0x70>;
-
-               gigsfp_i2c: i2c@0 {
-                       #address-cells = <1>;
-                       #size-cells = <0>;
-                       reg = <0>;
-               };
-               tensfp_i2c: i2c@1 {
-                       #address-cells = <1>;
-                       #size-cells = <0>;
-                       reg = <1>;
-               };
-       };
-};
-
-&ifc {
-       status = "okay";
-       #address-cells = <2>;
-       #size-cells = <1>;
-       /* Only NAND flash is used on this board */
-       ranges = <0x0 0x0 0x0 0x7e800000 0x00010000>;
-
-       nand@1,0 {
-               compatible = "fsl,ifc-nand";
-               #address-cells = <1>;
-               #size-cells = <1>;
-               reg = <0x0 0x0 0x10000>;
-       };
-};
-
-&duart0 {
-       status = "okay";
-};
-
-&duart1 {
-       status = "okay";
-};
-
-#include "fsl-ls1043-post.dtsi"
-
-&fman0 {
-       EMAC0: ethernet@e0000 {
-               phy-handle = <&qsgmii_phy1>;
-               phy-connection-type = "qsgmii";
-               local-mac-address = [0A 00 00 00 00 01];
-       };
-
-       EMAC1: ethernet@e2000 {
-               phy-handle = <&qsgmii_phy2>;
-               phy-connection-type = "qsgmii";
-               local-mac-address = [0A 00 00 00 00 02];
-       };
-
-       EMAC2: ethernet@e8000 {
-               phy-handle = <&qsgmii_phy3>;
-               phy-connection-type = "qsgmii";
-               local-mac-address = [0A 00 00 00 00 03];
-       };
-
-       EMAC3: ethernet@ea000 {
-               phy-handle = <&qsgmii_phy4>;
-               phy-connection-type = "qsgmii";
-               local-mac-address = [0A 00 00 00 00 04];
-       };
-
-       /* SFP via AR8031
-        * We treat this as a fixed-link as the
-        * AR8031 is hard-configured into
-        * 1000BASE-X mode
-        * Should MII control be desired, remove
-        * fixed-link and add
-        * phy-handle = <&rgmii_phy1>;
-        */
-       EMAC4: ethernet@e4000 {
-               phy-connection-type = "rgmii";
-               local-mac-address = [0A 00 00 00 00 05];
-               fixed-link {
-                       speed = <1000>;
-                       full-duplex;
-               };
-       };
-
-       /* Connection to Expansion (M.2) slot
-        * Future WAN (i.e xDSL) plugin
-        */
-       EMAC5: ethernet@e6000 {
-               phy-connection-type = "rgmii-id";
-               local-mac-address = [00 00 00 00 00 06];
-               fixed-link {
-                       speed = <1000>;
-                       full-duplex;
-               };
-       };
-
-       /* 10G SFP+ interface
-        * This can also run at 1.25 and 2.5G with
-        * the appropriate SerDes protocol setting in RCW
-        */
-       TENSFP: ethernet@f0000 {
-               status = "okay";
-               phy-connection-type = "xgmii";
-               fixed-link {
-                       speed = <10000>;
-                       full-duplex;
-               };
-       };
-
-       mdio@fc000 {
-               rgmii_phy1: ethernet-phy@2 {
-                       reg = <0x2>;
-               };
-               qsgmii_phy1: ethernet-phy@4 {
-                       reg = <0x4>;
-               };
-               qsgmii_phy2: ethernet-phy@5 {
-                       reg = <0x5>;
-               };
-               qsgmii_phy3: ethernet-phy@6 {
-                       reg = <0x6>;
-               };
-               qsgmii_phy4: ethernet-phy@7 {
-                       reg = <0x7>;
-               };
-       };
-};
-
-/* No QUICC engine functions on this board -
- * pins are used for other functions (GPIO, I2C etc.)
- */
-&uqe {
-       status = "disabled";
-};
-
-/* LS1043S does not use the QorIQ AHCI
- * controller.
- */
-&sata {
-       status = "disabled";
-};
diff --git a/target/linux/layerscape/files/arch/arm64/boot/dts/freescale/traverse-ls1043v.dts b/target/linux/layerscape/files/arch/arm64/boot/dts/freescale/traverse-ls1043v.dts
deleted file mode 100644 (file)
index 9368751..0000000
+++ /dev/null
@@ -1,253 +0,0 @@
-/*
- * Device Tree Include file for Traverse LS1043V board.
- *
- * Copyright 2014-2015, Freescale Semiconductor
- * Copyright 2017, Traverse Technologies
- *
- * This file is dual-licensed: you can use it either under the terms
- * of the GPLv2 or the X11 license, at your option. Note that this dual
- * licensing only applies to this file, and not this project as a
- * whole.
- *
- *  a) This library is free software; you can redistribute it and/or
- *     modify it under the terms of the GNU General Public License as
- *     published by the Free Software Foundation; either version 2 of the
- *     License, or (at your option) any later version.
- *
- *     This library is distributed in the hope that it will be useful,
- *     but WITHOUT ANY WARRANTY; without even the implied warranty of
- *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- *     GNU General Public License for more details.
- *
- * Or, alternatively,
- *
- *  b) Permission is hereby granted, free of charge, to any person
- *     obtaining a copy of this software and associated documentation
- *     files (the "Software"), to deal in the Software without
- *     restriction, including without limitation the rights to use,
- *     copy, modify, merge, publish, distribute, sublicense, and/or
- *     sell copies of the Software, and to permit persons to whom the
- *     Software is furnished to do so, subject to the following
- *     conditions:
- *
- *     The above copyright notice and this permission notice shall be
- *     included in all copies or substantial portions of the Software.
- *
- *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
- *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
- *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
- *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
- *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
- *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
- *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
- *     OTHER DEALINGS IN THE SOFTWARE.
- */
-
-/dts-v1/;
-#include "fsl-ls1043a.dtsi"
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "Traverse LS1043V";
-       compatible = "traverse,ls1043v";
-
-       aliases {
-               crypto = &crypto;
-               ethernet0 = &EMAC0;
-               ethernet1 = &EMAC1;
-               ethernet2 = &EMAC2;
-               ethernet3 = &EMAC3;
-               ethernet4 = &EMAC4;
-               ethernet5 = &EMAC5;
-               pca9555 = &pca9555;
-       };
-
-       leds {
-               compatible = "gpio-leds";
-               gpio0 {
-                       label = "ls1043v:green:user0";
-                       gpios = <&pca9555 0 GPIO_ACTIVE_LOW>;
-               };
-               gpio1 {
-                       label = "ls1043v:yellow:user0";
-                       gpios = <&pca9555 1 GPIO_ACTIVE_LOW>;
-               };
-               gpio2 {
-                       label = "ls1043v:green:user1";
-                       gpios = <&pca9555 2 GPIO_ACTIVE_LOW>;
-               };
-               gpio3 {
-                       label = "ls1043v:yellow:user1";
-                       gpios = <&pca9555 3 GPIO_ACTIVE_LOW>;
-               };
-               gpio4 {
-                       label = "ls1043v:green:user2";
-                       gpios = <&pca9555 4 GPIO_ACTIVE_HIGH>;
-               };
-               gpio5 {
-                       label = "ls1043v:yellow:wlan";
-                       gpios = <&pca9555 5 GPIO_ACTIVE_HIGH>;
-               };
-               gpio6 {
-                       label = "ls1043v:yellow:wan";
-                       gpios = <&pca9555 6 GPIO_ACTIVE_HIGH>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <1000>;
-               button@0 {
-                       label = "Front button";
-                       linux,code = <KEY_SETUP>;
-                       gpios = <&pca9555 14 GPIO_ACTIVE_LOW>;
-               };
-               button@1 {
-                       label = "Rear button";
-                       linux,code = <KEY_WPS_BUTTON>;
-                       gpios = <&pca9555 15 GPIO_ACTIVE_LOW>;
-               };
-       };
-};
-
-&i2c0 {
-       status = "okay";
-       rtc@6f {
-               compatible = "intersil,isl1208";
-               reg = <0x6f>;
-       };
-
-       pca9555: pca9555@20 {
-               compatible = "nxp,pca9555";
-               gpio-controller;
-               #gpio-cells = <2>;
-               reg = <0x20>;
-               gpio-base = <0>;
-       };
-
-       /* CPU core temp sensor and VDD (1.0V) sensor */
-       ltc2990@4c {
-               compatible = "lltc,ltc2990";
-               reg = <0x4C>;
-               lltc,meas-mode = <4 3>;
-       };
-
-       /* 3.3V and 5V monitor (may not be loaded on some SKUs) */
-       ltc2990@4f {
-               compatible = "lltc,ltc2990";
-               reg = <0x4F>;
-               lltc,meas-mode = <6 3>;
-       };
-};
-
-&ifc {
-       status = "okay";
-       #address-cells = <2>;
-       #size-cells = <1>;
-       /* Only NAND flash is used on this board */
-       ranges = <0x0 0x0 0x0 0x7e800000 0x00010000>;
-
-       nand@1,0 {
-               compatible = "fsl,ifc-nand";
-               #address-cells = <1>;
-               #size-cells = <1>;
-               reg = <0x0 0x0 0x10000>;
-       };
-};
-
-&duart0 {
-       status = "okay";
-};
-
-&duart1 {
-       status = "okay";
-};
-
-#include "fsl-ls1043-post.dtsi"
-
-&fman0 {
-       EMAC0: ethernet@e0000 {
-               phy-handle = <&qsgmii_phy1>;
-               phy-connection-type = "qsgmii";
-               local-mac-address = [0A 00 00 00 00 01];
-       };
-
-       EMAC1: ethernet@e2000 {
-               phy-handle = <&qsgmii_phy2>;
-               phy-connection-type = "qsgmii";
-               local-mac-address = [0A 00 00 00 00 02];
-       };
-
-       EMAC2: ethernet@e8000 {
-               phy-handle = <&qsgmii_phy3>;
-               phy-connection-type = "qsgmii";
-               local-mac-address = [0A 00 00 00 00 03];
-       };
-
-       EMAC3: ethernet@ea000 {
-               phy-handle = <&qsgmii_phy4>;
-               phy-connection-type = "qsgmii";
-               local-mac-address = [0A 00 00 00 00 04];
-       };
-       EMAC4: ethernet@e4000 {
-               phy-handle = <&rgmii_phy1>;
-               phy-connection-type = "rgmii";
-               local-mac-address = [0A 00 00 00 00 05];
-       };
-
-       /* Connection to VDSL SoC */
-       EMAC5: ethernet@e6000 {
-               phy-connection-type = "rgmii-id";
-               local-mac-address = [00 00 00 00 00 06];
-               fixed-link {
-                       speed = <1000>;
-                       full-duplex;
-               };
-       };
-
-       /* 10G XFI interface - not in use on this platform */
-       TENSFP: ethernet@f0000 {
-               status = "disabled";
-
-               phy-connection-type = "sgmii";
-               fixed-link {
-                       /* NB: speed = 1000 and sgmii allows forward compatibility
-                       *  with both 1G and 10G, the same is not true
-                       *  in the reverse.
-                       */
-                       speed = <1000>;
-                       full-duplex;
-               };
-       };
-
-       mdio@fc000 {
-               rgmii_phy1: ethernet-phy@3 {
-                       reg = <0x3>;
-               };
-               qsgmii_phy1: ethernet-phy@4 {
-                       reg = <0x4>;
-               };
-               qsgmii_phy2: ethernet-phy@5 {
-                       reg = <0x5>;
-               };
-               qsgmii_phy3: ethernet-phy@6 {
-                       reg = <0x6>;
-               };
-               qsgmii_phy4: ethernet-phy@7 {
-                       reg = <0x7>;
-               };
-       };
-};
-
-/* No QUICC engine functions on this board */
-&uqe {
-       status = "disabled";
-};
-
-/* No SATA/AHCI on this board */
-&sata {
-       status = "disabled";
-};
index 1463a3eaea05866ed29315839958c3445af5ac71..dfbda85b3651bfe3e3973875ad818d1e07ad5e09 100644 (file)
@@ -51,19 +51,6 @@ define Build/ls-append-sdhead
        dd if=$(STAGING_DIR_IMAGE)/$(1)-sdcard-head.img >> $@
 endef
 
-define Build/traverse-fit
-       ./mkits-multiple-config.sh -o $@.its -A $(LINUX_KARCH) \
-               -v $(LINUX_VERSION) -k $@ -a $(KERNEL_LOADADDR) \
-               -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -C gzip -c 1 -c 2 \
-               -d $(DEVICE_DTS_DIR)/freescale/traverse-ls1043s.dtb \
-               -D "Traverse_LS1043S" -n "ls1043s" -a $(FDT_LOADADDR) -c 1 \
-               -d $(DEVICE_DTS_DIR)/freescale/traverse-ls1043v.dtb \
-               -D "Traverse_LS1043V" -n "ls1043v" -a $(FDT_LOADADDR) -c 2
-       PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new
-       @mv -f $@.new $@
-endef
-
 define Build/traverse-fit-ls1088
     ./mkits-multiple-config.sh -o $@.its -A $(LINUX_KARCH) \
        -v $(LINUX_VERSION) -k $@ -a $(KERNEL_LOADADDR) \
index 0016e3bde8253fb5b21559d81317a5dbccfcf61f..259bacee314270efb82c852d6d2aaf7f32eb6ee4 100644 (file)
@@ -420,38 +420,6 @@ define Device/fsl_lx2160a-rdb-sdboot
 endef
 TARGET_DEVICES += fsl_lx2160a-rdb-sdboot
 
-define Device/traverse_ls1043
-  DEVICE_VENDOR := Traverse
-  DEVICE_MODEL := LS1043 Boards
-  KERNEL_NAME := Image
-  KERNEL_SUFFIX := -kernel.itb
-  KERNEL_INSTALL := 1
-  FDT_LOADADDR = 0x90000000
-  FILESYSTEMS := ubifs
-  MKUBIFS_OPTS := -m 1 -e 262016 -c 128
-  DEVICE_PACKAGES += \
-    layerscape-fman \
-    uboot-envtools \
-    kmod-i2c-mux-pca954x \
-    kmod-hwmon-core \
-    kmod-gpio-pca953x kmod-input-gpio-keys-polled \
-    kmod-rtc-isl1208
-  DEVICE_DESCRIPTION = \
-    Build images for Traverse LS1043 boards. This generates a single image \
-    capable of booting on any of the boards in this family.
-  DEVICE_DTS = freescale/traverse-ls1043s
-  DEVICE_DTS_DIR = $(LINUX_DIR)/arch/arm64/boot/dts
-  DEVICE_DTS_CONFIG = ls1043s
-  KERNEL := kernel-bin | gzip | traverse-fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
-  KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
-  IMAGES = root sysupgrade.bin
-  IMAGE/root = append-rootfs
-  IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
-  MKUBIFS_OPTS := -m 2048 -e 124KiB -c 4096
-  SUPPORTED_DEVICES := traverse,ls1043s traverse,ls1043v
-endef
-TARGET_DEVICES += traverse_ls1043
-
 define Device/traverse_ten64_mtd
   DEVICE_VENDOR := Traverse
   DEVICE_MODEL := Ten64 (NAND boot)
diff --git a/target/linux/layerscape/patches-5.15/300-add-DTS-for-Traverse-LS1043-Boards.patch b/target/linux/layerscape/patches-5.15/300-add-DTS-for-Traverse-LS1043-Boards.patch
deleted file mode 100644 (file)
index 110afed..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-From 5b35aae22b4ca2400e49561c9267aa01346f91d4 Mon Sep 17 00:00:00 2001
-From: Mathew McBride <matt@traverse.com.au>
-Date: Tue, 17 Apr 2018 10:01:03 +1000
-Subject: [PATCH] add DTS for Traverse LS1043 Boards
-
-Signed-off-by: Mathew McBride <matt@traverse.com.au>
-[rebase]
-Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
----
- arch/arm64/boot/dts/freescale/Makefile             |  3 +++
- arch/arm64/boot/dts/freescale/traverse-ls1043s.dts | 29 ++++++++++++++++++++++
- arch/arm64/boot/dts/freescale/traverse-ls1043v.dts | 29 ++++++++++++++++++++++
- 3 files changed, 61 insertions(+)
-
---- a/arch/arm64/boot/dts/freescale/Makefile
-+++ b/arch/arm64/boot/dts/freescale/Makefile
-@@ -31,6 +31,9 @@ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-lx2
- dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-lx2160a-rdb.dtb
- dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-lx2162a-qds.dtb
-+dtb-$(CONFIG_ARCH_LAYERSCAPE) += traverse-ls1043v.dtb
-+dtb-$(CONFIG_ARCH_LAYERSCAPE) += traverse-ls1043s.dtb
-+
- dtb-$(CONFIG_ARCH_MXC) += imx8mm-beacon-kit.dtb
- dtb-$(CONFIG_ARCH_MXC) += imx8mm-evk.dtb
- dtb-$(CONFIG_ARCH_MXC) += imx8mm-ddr4-evk.dtb