ltq-vdsl-vr11-mei: add patch fixing compilation with kernel 6.6
authorChristian Marangi <ansuelsmth@gmail.com>
Wed, 20 Mar 2024 11:28:35 +0000 (12:28 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 2 Apr 2024 21:45:22 +0000 (23:45 +0200)
Add patch fixing compilation with kernel 6.6.

class_create now require only the name instead of the module ownership
reference.

Also the kernel enabled checks for enum.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/kernel/lantiq/ltq-vdsl-vr11-mei/Makefile
package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/130-support-kernel-6.6.patch [new file with mode: 0644]

index 7b8a948179b6409d02b55fb3d7418b2a117d25b8..3e01ee63738afc5942865ac324910d9233156d8a 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-vdsl-vr11-mei
 PKG_VERSION:=1.11.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_BASE_NAME:=dsl_cpe_mei
 
 UGW_VERSION=8.5.2.10
diff --git a/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/130-support-kernel-6.6.patch b/package/kernel/lantiq/ltq-vdsl-vr11-mei/patches/130-support-kernel-6.6.patch
new file mode 100644 (file)
index 0000000..407afc9
--- /dev/null
@@ -0,0 +1,35 @@
+--- a/src/drv_mei_cpe_linux.c
++++ b/src/drv_mei_cpe_linux.c
+@@ -2779,7 +2779,11 @@ static int MEI_InitModuleRegCharDev(cons
+             ("Using major number %d" MEI_DRV_CRLF, MAJOR(mei_devt)));
+       }
++#if LINUX_VERSION_CODE < KERNEL_VERSION(6, 4, 0)
+       mei_class = class_create(THIS_MODULE, devName);
++#else
++      mei_class = class_create(devName);
++#endif
+       if (IS_ERR(mei_class))
+       {
+          PRN_DBG_USR_NL( MEI_DRV,MEI_DRV_PRN_LEVEL_HIGH,
+--- a/src/drv_mei_cpe_api_atm_ptm_intern.c
++++ b/src/drv_mei_cpe_api_atm_ptm_intern.c
+@@ -223,7 +223,7 @@ IFX_int32_t MEI_TcRequest(void *data)
+       pMeiDynCntrl->pDfeX        = NULL;
+       pMeiDynCntrl->pMeiDev      = pMeiDev;
+-      argsTcRequest.request_type = request_type;
++      argsTcRequest.request_type = (MEI_TC_RequestType_t)request_type;
+       argsTcRequest.is_bonding = MEI_BND_EnableGet(pMeiDynCntrl);
+       if (MEI_DFEX_ENTITIES == 1 && argsTcRequest.is_bonding == IFX_TRUE)
+@@ -398,7 +398,8 @@ IFX_int32_t MEI_InternalLineTCModeSwitch
+       pMeiDynCntrl->pDfeX        = NULL;
+       pMeiDynCntrl->pMeiDev      = MEIX_Cntrl[nEntity]->MeiDevice[nInstance];
+-      argsTcRequest.request_type = bPowerUp ? MEI_TC_REQUEST_PTM : MEI_TC_REQUEST_OFF;
++      argsTcRequest.request_type = bPowerUp ? (MEI_TC_RequestType_t)MEI_TC_REQUEST_PTM :
++                                              (MEI_TC_RequestType_t)MEI_TC_REQUEST_OFF;
+       argsTcRequest.is_bonding   = pMeiDynCntrl->pMeiDev->bLastBondingStatus;
+       retVal = MEI_InternalTcRequest(pMeiDynCntrl, &argsTcRequest);