au1000: create sysupgrade binary for each file system type
authorJohn Crispin <john@openwrt.org>
Thu, 7 Nov 2013 12:46:12 +0000 (12:46 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 7 Nov 2013 12:46:12 +0000 (12:46 +0000)
This patch should prevent overriding of sysupgrade binaries in the bin directory
if we build images for more then one file system type.

Discussion:

https://lists.openwrt.org/pipermail/openwrt-devel/2013-October/022108.html

Signed-off-by: Philipp Borgers <borgers@mi.fu-berlin.de>
SVN-Revision: 38674

target/linux/au1000/image/Makefile

index 1dfdd9843c56d8ecfb1b2787c6b965d5a8c0a65a..12c84a10cf0616eb6678c9e9805b3cb309c31430 100644 (file)
@@ -62,7 +62,7 @@ define Image/Build
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).fs
        $(CP) $(KDIR)/kernel.flash.srec $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-flash.srec
        $(CP) $(KDIR)/kernel.ram.srec $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-ram.srec
-       tar -C $(BIN_DIR) -cvzf $(BIN_DIR)/$(IMG_PREFIX)-sysupgrade.bin $(IMG_PREFIX)-vmlinux.bin $(IMG_PREFIX)-$(1).fs
+       tar -C $(BIN_DIR) -cvzf $(BIN_DIR)/$(IMG_PREFIX)-$(1)-sysupgrade.bin $(IMG_PREFIX)-vmlinux.bin $(IMG_PREFIX)-$(1).fs
 ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
        $(call Image/Build/Initramfs)
 endif