bcm27xx: add AMP2 to HifiBerry DAC+ / DAC+ Pro package
authorTorsten Duwe <duwe@lst.de>
Wed, 22 Sep 2021 08:52:51 +0000 (10:52 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Wed, 29 Dec 2021 19:35:57 +0000 (20:35 +0100)
According to the vendor [1] these HATs share the same DT overlay:
hifiberry-dacplus. The PCM512x-compatible control unit is attached to
I2C, so the additional snd-soc-pcm512x-i2c kernel module is required.
Also explicitly note the Amp2 support to reduce confusion for those
users.

[1] <https://www.hifiberry.com/docs/software/configuring-linux-3-18-x/>
Signed-off-by: Torsten Duwe <duwe@lst.de>
(added bcm27xx tag, changed commit message)
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/bcm27xx/modules/sound.mk

index a6b1d73987be79ab9c9993afac284d6aee7ff331..0823786d5c8a78882dbd4090ef4afc6e46795621 100644 (file)
@@ -527,24 +527,27 @@ $(eval $(call KernelPackage,sound-soc-hifiberry-dac))
 
 
 define KernelPackage/sound-soc-hifiberry-dacplus
-  TITLE:=Support for HifiBerry DAC+ / DAC+ Pro
+  TITLE:=Support for HifiBerry DAC+ / DAC+ Pro / Amp2
   KCONFIG:= \
     CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUS \
-    CONFIG_SND_SOC_PCM512x
+    CONFIG_SND_SOC_PCM512x \
+    CONFIG_SND_SOC_PCM512x_I2C
   FILES:= \
     $(LINUX_DIR)/drivers/clk/clk-hifiberry-dacpro.ko \
     $(LINUX_DIR)/sound/soc/bcm/snd-soc-hifiberry-dacplus.ko \
-    $(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x.ko
+    $(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x.ko \
+    $(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x-i2c.ko
   AUTOLOAD:=$(call AutoLoad,68,clk-hifiberry-dacpro snd-soc-pcm512x \
-    snd-soc-hifiberry-dacplus)
+    snd-soc-pcm512x-i2c snd-soc-hifiberry-dacplus)
   DEPENDS:= \
     kmod-sound-soc-bcm2835-i2s \
-    +kmod-i2c-bcm2835
+    +kmod-i2c-bcm2835 \
+    +kmod-regmap-i2c
   $(call AddDepends/sound)
 endef
 
 define KernelPackage/sound-soc-hifiberry-dacplus/description
-  This package contains support for HifiBerry DAC+ / DAC+ Pro
+  This package contains support for HifiBerry DAC+ / DAC+ Pro / Amp2
 endef
 
 $(eval $(call KernelPackage,sound-soc-hifiberry-dacplus))