brcm2708: split sdcard.img.gz into a sysupgrade and factory image
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 29 Jul 2018 09:55:14 +0000 (11:55 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 06:11:36 +0000 (08:11 +0200)
@vahid-dan reported a issue with extracting the rpi images with
Gnome's Archive Manager:
"Ubuntu Archive Manager cannot extract the file and it just
throws a general error message: "An error occurred while
extracting files".
<https://forum.lede-project.org/t/corrupted-pre-built-v18-06-0-rc2-image-for-rpi>

@blogic told me to split the single sdcard.img.gz for the RPi
into a sysupgrade and a factory image for all brcm2708 targets.
The factory images will have no metadata attached, this way
these utilities that can't deal with the attached metadata will
not fail for no reason.

Cc: John Crispin <john@phrozen.org>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/brcm2708/image/Makefile

index 80a019270de74e4af0621d5e7856a92df4df7f88..aedea9445162ac46a94ec080be62c22cb5d32897 100644 (file)
@@ -49,8 +49,9 @@ endef
 define Device/Default
   KERNEL := kernel-bin | kernel-img
   KERNEL_IMG := kernel.img
-  IMAGES := sdcard.img.gz
-  IMAGE/sdcard.img.gz := boot-img | sdcard-img | gzip | append-metadata
+  IMAGES := factory.img.gz sysupgrade.img.gz
+  IMAGE/sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
+  IMAGE/factory.img.gz := boot-img | sdcard-img | gzip
 endef
 
 define Device/rpi