bcm27xx: bcm2711: add kmod-r8169
authorJohannes Heimansberg <git@jhe.dedyn.io>
Mon, 12 Dec 2022 14:39:58 +0000 (15:39 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Thu, 15 Dec 2022 14:08:08 +0000 (15:08 +0100)
Some carrier boards [1][2] for the Raspberry Pi CM4 that are specifically
designed to be used as routers come with secondary NICs using a Realtek
RTL8111 Gigabit Ethernet chip.

When using such a board as a router with OpenWrt, it is very helpful
when both NICs are working by default. Since the Raspberry Pi 4 and the
CM4 have plenty of disk space, it should cause no harm to include the
kmod-r8169.

[1] https://wiki.dfrobot.com/Compute_Module_4_IoT_Router_Board_Mini_SKU_DFR0767
[2] https://www.waveshare.com/wiki/CM4-DUAL-ETH-MINI

Signed-off-by: Johannes Heimansberg <git@jhe.dedyn.io>
(r8169 should pull in the necessary dependencies.)
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/bcm27xx/image/Makefile

index 1334386c574dd77ed4d942bf31256e7eb44762be..999361e8cde50a53ef9508fad71311d47464a810 100644 (file)
@@ -163,7 +163,8 @@ define Device/rpi-4
        cypress-firmware-43455-sdio \
        brcmfmac-nvram-43455-sdio \
        kmod-brcmfmac wpad-basic-wolfssl \
-       kmod-usb-net-lan78xx
+       kmod-usb-net-lan78xx \
+       kmod-r8169
   IMAGE/sysupgrade.img.gz := boot-common | boot-2711 | sdcard-img | gzip | append-metadata
   IMAGE/factory.img.gz := boot-common | boot-2711 | sdcard-img | gzip
 endef