bcm63xx: mark as source-only
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Fri, 9 Jun 2023 17:53:08 +0000 (19:53 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Thu, 15 Jun 2023 18:44:26 +0000 (20:44 +0200)
Maintaining bcm63xx is a nightmare due to the amount of devices and patches
required, since every board requires an individual patch due to the lack of
full device tree compatibility.
Moreover, there are a lot of devices supported on this target which won't work
due to not having enough resources (16M-32M of RAM and/or 4M of flash).
Therefore, any development efforts should be focused on bmips and support for
those devices with enough resources should be added on bmips target.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bcm63xx/Makefile

index 4bcf9613d97e05da8c03e0a0a497d23fa7eb82ad..f206aed3d355b2306898d60f995be2ff1e2bcd52 100644 (file)
@@ -9,7 +9,7 @@ ARCH:=mips
 BOARD:=bcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
-FEATURES:=squashfs usb atm pci pcmcia usbgadget
+FEATURES:=squashfs usb atm pci pcmcia usbgadget source-only
 
 KERNEL_PATCHVER:=5.15