ramips: remove generic profiles
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 22 Jan 2021 10:45:03 +0000 (11:45 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 27 Jan 2021 20:31:20 +0000 (21:31 +0100)
On a platform with many very different devices, like found on ramips,
the generic profiles seem like remnants of the past that do not
have a real use anymore.

Remove them to have one thing less to maintain.

Actually, rt288x didn't have a default profile in the first place.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Acked-by: Paul Spooren <mail@aparcar.org>
target/linux/ramips/mt7620/profiles/00-default.mk [deleted file]
target/linux/ramips/mt7621/profiles/00-default.mk [deleted file]
target/linux/ramips/mt76x8/profiles/00-default.mk [deleted file]
target/linux/ramips/rt305x/profiles/00-default.mk [deleted file]
target/linux/ramips/rt3883/profiles/00-default.mk [deleted file]

diff --git a/target/linux/ramips/mt7620/profiles/00-default.mk b/target/linux/ramips/mt7620/profiles/00-default.mk
deleted file mode 100644 (file)
index 736a628..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile
-       PACKAGES:= kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
-       PRIORITY:=1
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ramips/mt7621/profiles/00-default.mk b/target/linux/ramips/mt7621/profiles/00-default.mk
deleted file mode 100644 (file)
index dbfd26e..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile
-       PRIORITY:=1
-       PACKAGES:=\
-               kmod-usb3 \
-               kmod-usb-ledtrig-usbport
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ramips/mt76x8/profiles/00-default.mk b/target/linux/ramips/mt76x8/profiles/00-default.mk
deleted file mode 100644 (file)
index 83886ee..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile
-       PRIORITY:=1
-       PACKAGES:= kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ramips/rt305x/profiles/00-default.mk b/target/linux/ramips/rt305x/profiles/00-default.mk
deleted file mode 100644 (file)
index cc777a8..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile
-       PRIORITY:=1
-       PACKAGES:=\
-               kmod-usb-dwc2 \
-               kmod-usb-ledtrig-usbport
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ramips/rt3883/profiles/00-default.mk b/target/linux/ramips/rt3883/profiles/00-default.mk
deleted file mode 100644 (file)
index 4683441..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile
-       PRIORITY:=1
-       PACKAGES:=kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))