bcm27xx: add SND_SOC_AD193X_{I2C,SPI} symbols
authorStijn Tintel <stijn@linux-ipv6.be>
Thu, 30 Sep 2021 15:36:23 +0000 (18:36 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Tue, 5 Oct 2021 20:30:48 +0000 (23:30 +0300)
When building an image for the bcm27xx target, some combinations of
config options will fail to build due the SND_SOC_AD193X_I2C and
SND_SOC_AD193X_SPI kernel config symbols being missing.

The problem only occurs on bcm27xx as the target contains a patch that
modifies the Kconfig file containing the symbols; in the vanilla kernel,
there is no string after the tristate keyword so the symbol is not
exposed.

The _I2C symbol depends on I2C, which is enabled in the kernel configs
of all bcm27xx subtargets.

The _SPI symbol depends on SPI_MASTER, which is exposed by either
kmod-mmc-spi, kmod-spi-bitbang, kmod-spi-dev, kmod-spi-bcm2835 or
kmod-spi-bcm2835-aux.

Both symbols are defined in the sound/soc/codecs directory, which is
only included when SND_SOC is enabled, so this problem doesn't occur
when kmod-sound-soc-core is not enabled. As the
kmod-sound-soc-bcm2835-i2s package disables the SND_SOC_AD193X_SPI
symbol, it also doesn't occur when kmod-sound-soc-bcm2835-i2s is
enabled.

As there are several possible config combinations that do exhibit this
problem, it is best to solve it by adding the missing symbols to the
subtarget kernel configs. By doing this we can remove them from the
kmod-sound-soc-bcm2835-i2s package.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
target/linux/bcm27xx/bcm2708/config-5.10
target/linux/bcm27xx/bcm2708/config-5.4
target/linux/bcm27xx/bcm2709/config-5.10
target/linux/bcm27xx/bcm2709/config-5.4
target/linux/bcm27xx/bcm2710/config-5.10
target/linux/bcm27xx/bcm2710/config-5.4
target/linux/bcm27xx/bcm2711/config-5.10
target/linux/bcm27xx/bcm2711/config-5.4
target/linux/bcm27xx/modules/sound.mk

index 094765abdc3c04680f22b86c043c288e0b5b8103..12567abb242d2dbd17da753fc61ae54621693f8c 100644 (file)
@@ -321,6 +321,8 @@ CONFIG_SERIAL_MCTRL_GPIO=y
 CONFIG_SERIAL_OF_PLATFORM=y
 CONFIG_SG_POOL=y
 CONFIG_SMSC_PHY=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
 CONFIG_SPARSE_IRQ=y
 CONFIG_SRCU=y
 # CONFIG_STRIP_ASM_SYMS is not set
index ef71076497153339c87d9f08faf93a736846a513..42203d2587a0032be10de9d81032a376271c9f16 100644 (file)
@@ -309,6 +309,8 @@ CONFIG_SERIAL_DEV_BUS=y
 CONFIG_SERIAL_MCTRL_GPIO=y
 CONFIG_SERIAL_OF_PLATFORM=y
 CONFIG_SG_POOL=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
 CONFIG_SPARSE_IRQ=y
 CONFIG_SRCU=y
 # CONFIG_STRIP_ASM_SYMS is not set
index 5b6c8b7edd3c4ccf802754679d62c9f062c2c15c..3986cffec2b58131e8539053f3d7c8c616179816 100644 (file)
@@ -402,6 +402,8 @@ CONFIG_SG_POOL=y
 CONFIG_SMP=y
 CONFIG_SMP_ON_UP=y
 CONFIG_SMSC_PHY=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
 CONFIG_SPARSE_IRQ=y
 CONFIG_SRCU=y
 # CONFIG_STRIP_ASM_SYMS is not set
index 4118d0f684197979a96238f6e3e2d94730b289dd..43926743714bf5672fcdc36fb60776ba0f3c7354 100644 (file)
@@ -399,6 +399,8 @@ CONFIG_SERIAL_OF_PLATFORM=y
 CONFIG_SG_POOL=y
 CONFIG_SMP=y
 CONFIG_SMP_ON_UP=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
 CONFIG_SPARSE_IRQ=y
 CONFIG_SRCU=y
 # CONFIG_STRIP_ASM_SYMS is not set
index 66c9ff9f0a3a1604c34eded6422b086b37bbe32a..5dfdab8987bbaa7dc7ddf31bfa3c81363832c9ee 100644 (file)
@@ -389,6 +389,8 @@ CONFIG_SERIAL_OF_PLATFORM=y
 CONFIG_SG_POOL=y
 CONFIG_SMP=y
 CONFIG_SMSC_PHY=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
 CONFIG_SPARSEMEM=y
 CONFIG_SPARSEMEM_EXTREME=y
 CONFIG_SPARSEMEM_MANUAL=y
index f2702a6d62f8902b1dc9c899466ba3344d6abc8c..6d1133980ac81c756a42e2ee6b0ce1dc40d2fa3c 100644 (file)
@@ -391,6 +391,8 @@ CONFIG_SERIAL_MCTRL_GPIO=y
 CONFIG_SERIAL_OF_PLATFORM=y
 CONFIG_SG_POOL=y
 CONFIG_SMP=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
 CONFIG_SPARSEMEM=y
 CONFIG_SPARSEMEM_EXTREME=y
 CONFIG_SPARSEMEM_MANUAL=y
index d309a3a76099dee35085af4c69eb706223614ac3..1829a5c29c8f23136c0a15d8774b5a9a293270dd 100644 (file)
@@ -400,6 +400,8 @@ CONFIG_SERIAL_MCTRL_GPIO=y
 CONFIG_SERIAL_OF_PLATFORM=y
 CONFIG_SG_POOL=y
 CONFIG_SMP=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
 CONFIG_SPARSEMEM=y
 CONFIG_SPARSEMEM_EXTREME=y
 CONFIG_SPARSEMEM_MANUAL=y
index 5548a960abdd722aa6e46f9329d75f9f68752037..f9b172e7d6db78f8122e41a9c5f929bd3b7e68dc 100644 (file)
@@ -403,6 +403,8 @@ CONFIG_SERIAL_MCTRL_GPIO=y
 CONFIG_SERIAL_OF_PLATFORM=y
 CONFIG_SG_POOL=y
 CONFIG_SMP=y
+# CONFIG_SND_SOC_AD193X_I2C is not set
+# CONFIG_SND_SOC_AD193X_SPI is not set
 CONFIG_SPARSEMEM=y
 CONFIG_SPARSEMEM_EXTREME=y
 CONFIG_SPARSEMEM_MANUAL=y
index 5073e5ff50fffed9e06dbe4aa1ccd533e21bcdf1..a6b1d73987be79ab9c9993afac284d6aee7ff331 100644 (file)
@@ -26,8 +26,6 @@ define KernelPackage/sound-soc-bcm2835-i2s
   TITLE:=SoC Audio support for the Broadcom 2835 I2S module
   KCONFIG:= \
     CONFIG_SND_BCM2835_SOC_I2S \
-    CONFIG_SND_SOC_AD193X_SPI=n \
-    CONFIG_SND_SOC_AD193X_I2C=n \
     CONFIG_SND_SOC_DMAENGINE_PCM=y \
     CONFIG_SND_SOC_GENERIC_DMAENGINE_PCM=y
   FILES:= \