mvebu: add kernel module for Turris Omnia Wi-Fi 6
authorJan Jasper de Kroon <jajadekroon@gmail.com>
Mon, 5 Feb 2024 08:02:57 +0000 (09:02 +0100)
committerRobert Marko <robimarko@gmail.com>
Mon, 26 Feb 2024 20:34:27 +0000 (21:34 +0100)
The following kernel module package was added to the build recipe for the
Turris Omnia: kmod-mt7915-firmware

This module enables support for the official Wi-Fi 6 upgrade kit sold by
CZ.NIC, which includes the AW7915-NP1 miniPCIE board based on Mediatek
MT7915AN, providing 5 GHz Wi-Fi 6 connectivity. With this commit we now
support the latest Turris Omnia Wi-Fi 6 Edition

Signed-off-by: Jan Jasper de Kroon <jajadekroon@gmail.com>
target/linux/mvebu/image/cortexa9.mk

index a49401d904c64e66038fd2a9c2036ccf5dc21814..d97509f4d63021d96160465f0c178896694cf34b 100644 (file)
@@ -104,7 +104,7 @@ define Device/cznic_turris-omnia
   DEVICE_PACKAGES :=  \
     mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
     wpad-basic-mbedtls kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
-    partx-utils kmod-i2c-mux-pca954x kmod-leds-turris-omnia
+    kmod-mt7915-firmware partx-utils kmod-i2c-mux-pca954x kmod-leds-turris-omnia
   IMAGES := sysupgrade.img.gz
   IMAGE/sysupgrade.img.gz := boot-scr | boot-img | sdcard-img | gzip | append-metadata
   SUPPORTED_DEVICES += armada-385-turris-omnia