mvebu: fix RTC of IEI-World Puzzle M90x devices
authorDaniel Golle <daniel@makrotopia.org>
Mon, 18 Dec 2023 21:22:12 +0000 (21:22 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 18 Dec 2023 22:17:09 +0000 (22:17 +0000)
The Puzzle devices come with an I2C-connected Epson RX8130 RTC.
Disable the (dysfunctional) RTC units of the SoC and add driver
kmod-rtc-ds1307 to support the Epson RX8130 instead.

Tested-by: Thomas Huehn <thomas.huehn@hs-nordhausen.de>
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9131-puzzle-m901.dts
target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9132-puzzle-m902.dts
target/linux/mvebu/image/cortexa72.mk

index 0ad25fafbb8b2d81973431dcd55976f1e5f8c679..5bc3a846e0d5f836666262c0a18406437287f6e4 100644 (file)
        };
 };
 
+&cp0_rtc {
+       status = "disabled";
+};
+
 &cp0_syscon0 {
        cp0_pinctrl: pinctrl {
                compatible = "marvell,cp115-standalone-pinctrl";
        clock-frequency = <100000>;
 };
 
+&cp1_rtc {
+       status = "disabled";
+};
+
 &cp1_syscon0 {
        cp1_pinctrl: pinctrl {
                compatible = "marvell,cp115-standalone-pinctrl";
index 398e53a5f9a4f480faa2dcbb2eae02085a47822e..671b592e67a744a721c49910c7ed680dbf2a61d6 100644 (file)
        };
 };
 
+&cp0_rtc {
+       status = "disabled";
+};
+
 &cp0_syscon0 {
        cp0_pinctrl: pinctrl {
                compatible = "marvell,cp115-standalone-pinctrl";
        clock-frequency = <100000>;
 };
 
+&cp1_rtc {
+       status = "disabled";
+};
+
 &cp1_syscon0 {
        cp1_pinctrl: pinctrl {
                compatible = "marvell,cp115-standalone-pinctrl";
        };
 };
 
+&cp2_rtc {
+       status = "disabled";
+};
+
 &cp2_syscon0 {
        cp2_pinctrl: pinctrl {
                compatible = "marvell,cp115-standalone-pinctrl";
index 47d958b2fd158037cac1120cf79c62a7b52645a9..26b02e19247dcc5ccf0f98cc19bd2eb5734d98f7 100644 (file)
@@ -65,16 +65,18 @@ TARGET_DEVICES += marvell_clearfog-gt-8k
 
 define Device/iei_puzzle-m901
   $(call Device/Default-arm64)
+  SOC := cn9131
   DEVICE_VENDOR := iEi
   DEVICE_MODEL := Puzzle-M901
-  SOC := cn9131
+  DEVICE_PACKAGES += kmod-rtc-ds1307
 endef
 TARGET_DEVICES += iei_puzzle-m901
 
 define Device/iei_puzzle-m902
   $(call Device/Default-arm64)
+  SOC := cn9132
   DEVICE_VENDOR := iEi
   DEVICE_MODEL := Puzzle-M902
-  SOC := cn9132
+  DEVICE_PACKAGES += kmod-rtc-ds1307
 endef
 TARGET_DEVICES += iei_puzzle-m902