brcm47xx: image: use standard KERNEL_IMAGE to avoid warnings
authorRafał Miłecki <zajec5@gmail.com>
Tue, 31 Mar 2015 08:56:08 +0000 (08:56 +0000)
committerRafał Miłecki <zajec5@gmail.com>
Tue, 31 Mar 2015 08:56:08 +0000 (08:56 +0000)
KERNEL_IMAGE is used as target rule so reusing the same name causes:
Makefile:326: warning: overriding recipe for target `bin/brcm47xx/vmlinux.lzma'
Makefile:326: warning: ignoring old recipe for target `bin/brcm47xx/vmlinux.lzma'
Makefile:326: warning: overriding recipe for target `build_dir/target-mipsel_74kc+dsp2_uClibc-0.9.33.2/linux-brcm47xx_mips74k/vmlinux.lzma'
Makefile:326: warning: ignoring old recipe for target `build_dir/target-mipsel_74kc+dsp2_uClibc-0.9.33.2/linux-brcm47xx_mips74k/vmlinux.lzma'

Unfortunately this will cause copying vmlinux.lzma over and over like:
cp vmlinux.lzma FOO-kernel.bin
which is redundant on brcm47xx where we never modify kernel image.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
SVN-Revision: 45178

target/linux/brcm47xx/image/Makefile

index 9c0fa2d7f1148c097509e0930e49ccb886cea202..89ea89393a36462aebcfef3cfcd4c3b9ee9b9d0f 100644 (file)
@@ -138,8 +138,9 @@ DEVICE_VARS += DEVICE_ID VERSION
 DEVICE_VARS += BOARD_ID REGION
 
 define Device/Default
+       KERNEL := kernel-bin
        IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
-       KERNEL_IMAGE = vmlinux.lzma
+       KERNEL_NAME = vmlinux.lzma
        FILESYSTEMS := $(FS_64K)
        IMAGES := trx
        IMAGE/trx := trx-with-loader