kernel/modules/usb: add support for the cp2101 USB to serial converter, thanks to...
authorGabor Juhos <juhosg@openwrt.org>
Thu, 6 Mar 2008 19:28:42 +0000 (19:28 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 6 Mar 2008 19:28:42 +0000 (19:28 +0000)
SVN-Revision: 10548

package/kernel/modules/usb.mk

index db6c403f3c0f9b8d1d2985af77019ef98a9ac1f4..f3035f47274e5621a402c0d3115e38178902ff23 100644 (file)
@@ -315,6 +315,21 @@ endef
 $(eval $(call KernelPackage,usb-serial-pl2303))
 
 
+define KernelPackage/usb-serial-cp2101
+  $(call usbdep,kmod-usb-serial)
+  TITLE:=Support for Silicon Labs cp2101 devices
+  KCONFIG:=CONFIG_USB_SERIAL_CP2101
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/cp2101.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,65,cp2101)
+endef
+
+define KernelPackage/usb-serial-cp2101/description
+ Kernel support for Silicon Labs cp2101 USB-to-Serial converters
+endef
+
+$(eval $(call KernelPackage,usb-serial-cp2101))
+
+
 define KernelPackage/usb-serial-sierrawireless
   $(call usbdep,kmod-usb-serial @LINUX_2_6)
   TITLE:=Support for Sierra Wireless devices