kernel: bump 4.14 to 4.14.62
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 9 Aug 2018 15:18:12 +0000 (17:18 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 10 Aug 2018 16:43:59 +0000 (18:43 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6, x86_64
Runtime-tested on: cns3xxx, imx6, x86_64

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/pending-4.14/0931-w1-gpio-fix-problem-with-platfom-data-in-w1-gpio.patch
target/linux/generic/pending-4.14/190-2-5-e1000e-Fix-wrong-comment-related-to-link-detection.patch

index 2dc5c2ad99c1fc00f396b0a5562f596ec4feafbd..da750cdfe14fdba225dbcfc63718edb20a00b0a6 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.14 = .61
 LINUX_VERSION-4.9 = .119
+LINUX_VERSION-4.14 = .62
 
-LINUX_KERNEL_HASH-4.14.61 = 0d0ec521a771e7d393f25b789a06d9af6e2a5a4837fadc04e7048e03b41c70e8
 LINUX_KERNEL_HASH-4.9.119 = 49e17f01a1a607b4b1ab28dc7177e103943151866c3956fd83edc8a4aae60b35
+LINUX_KERNEL_HASH-4.14.62 = 51ca4d7e8ee156dc0f19bc7768915cfae41dbb0b4f251e4fa8b178c5674c22ab
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 5ce2bf87b9bf1e0c76ec6b395001566f8ab7fc78..0c4a13f9dff18acb1e9d83f66afe816f7a21eca0 100644 (file)
@@ -13,11 +13,9 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
  drivers/w1/masters/w1-gpio.c | 7 +++----
  1 file changed, 3 insertions(+), 4 deletions(-)
 
-diff --git a/drivers/w1/masters/w1-gpio.c b/drivers/w1/masters/w1-gpio.c
-index a90728ceec5a..7b80762941af 100644
 --- a/drivers/w1/masters/w1-gpio.c
 +++ b/drivers/w1/masters/w1-gpio.c
-@@ -112,17 +112,16 @@ static int w1_gpio_probe_dt(struct platform_device *pdev)
+@@ -112,17 +112,16 @@ static int w1_gpio_probe_dt(struct platf
  static int w1_gpio_probe(struct platform_device *pdev)
  {
        struct w1_bus_master *master;
@@ -38,6 +36,3 @@ index a90728ceec5a..7b80762941af 100644
        if (!pdata) {
                dev_err(&pdev->dev, "No configuration data\n");
                return -ENXIO;
--- 
-2.14.1
-
index 9889a33cb13adb703c70a9211bd4277fe0103b26..54858657cbfe193eedae4ee012609ac528c07d00 100644 (file)
@@ -23,7 +23,7 @@ Tested-by: Aaron Brown <aaron.f.brown@intel.com>
 
 --- a/drivers/net/ethernet/intel/e1000e/netdev.c
 +++ b/drivers/net/ethernet/intel/e1000e/netdev.c
-@@ -5093,7 +5093,7 @@ static bool e1000e_has_link(struct e1000
+@@ -5082,7 +5082,7 @@ static bool e1000e_has_link(struct e1000
  
        /* get_link_status is set on LSC (link status) interrupt or
         * Rx sequence error interrupt.  get_link_status will stay
@@ -32,7 +32,7 @@ Tested-by: Aaron Brown <aaron.f.brown@intel.com>
         * for copper adapters ONLY
         */
        switch (hw->phy.media_type) {
-@@ -5111,7 +5111,7 @@ static bool e1000e_has_link(struct e1000
+@@ -5100,7 +5100,7 @@ static bool e1000e_has_link(struct e1000
                break;
        case e1000_media_type_internal_serdes:
                ret_val = hw->mac.ops.check_for_link(hw);