mtd: add build hack to reintroduce shared mtd for older releases
authorJo-Philipp Wich <jo@mein.io>
Wed, 6 Jun 2018 11:41:26 +0000 (13:41 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 6 Jun 2018 11:44:50 +0000 (13:44 +0200)
When running in SDK context, treat the mtd package as shared to reintroduce
the common repository binary package for older released IBs.

When building outside of the SDK, create a nonshared package with a higher
PKG_REVISION to let opkg prefer that over the shared one in the common repo.

Ref: https://forum.lede-project.org/t/17-01-4-opkg-install-cmd-cannot-install-package-mtd/15312
Fixes: aaac9e82aa ("mtd: mark as nonshared to fix FS#484")
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/system/mtd/Makefile

index 9ae03a77a9faf83e3d7b9055cb3efa7cdccf7649..ecb440061ec660b35d48dbc0a59f7ed4a1477f7b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mtd
-PKG_RELEASE:=21
+PKG_RELEASE:=21$(if $(SDK),,.1)
 
 PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
 STAMP_PREPARED := $(STAMP_PREPARED)_$(call confvar,CONFIG_MTD_REDBOOT_PARTS)
@@ -17,7 +17,7 @@ STAMP_PREPARED := $(STAMP_PREPARED)_$(call confvar,CONFIG_MTD_REDBOOT_PARTS)
 PKG_LICENSE:=GPL-2.0+
 PKG_LICENSE_FILES:=
 
-PKG_FLAGS:=nonshared
+PKG_FLAGS:=$(if $(SDK),,nonshared)
 
 include $(INCLUDE_DIR)/package.mk