kirkwood: use real model names for Linksys devices
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 12 Jun 2020 22:36:01 +0000 (00:36 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 31 Jul 2020 13:03:43 +0000 (15:03 +0200)
This replaces the internal device names "Audi" and "Viper" with the
real model names, which a user would look for. This makes the
Linksys devices on this target consistent with the names recently
changed for mvebu based on the same idea.

As a consequence, the "viper" device definition is split into two
separate definitions with the correct names for both real models.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
13 files changed:
package/boot/uboot-envtools/files/kirkwood
target/linux/kirkwood/base-files/etc/board.d/01_leds
target/linux/kirkwood/base-files/etc/board.d/02_network
target/linux/kirkwood/base-files/etc/board.d/05_compat-version
target/linux/kirkwood/base-files/etc/init.d/bootcount
target/linux/kirkwood/base-files/lib/upgrade/platform.sh
target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-e4200-v2.dts [new file with mode: 0644]
target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-ea3500.dts [new file with mode: 0644]
target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-ea4500.dts [new file with mode: 0644]
target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-linksys-audi.dts [deleted file]
target/linux/kirkwood/image/Makefile
target/linux/kirkwood/patches-5.4/105-ea4500.patch [deleted file]
target/linux/kirkwood/patches-5.4/105-linksys-viper-dts.patch [new file with mode: 0644]

index a099c925ea2d6c3d32c86640d1efd25163da12ba..401df74597dedb8482ba9cc3067c1198a11c42f0 100644 (file)
@@ -17,7 +17,8 @@ checkpoint,l-50|\
 cloudengines,pogoe02|\
 cloudengines,pogoplugv4|\
 iom,ix2-200|\
-linksys,viper|\
+linksys,e4200-v2|\
+linksys,ea4500|\
 raidsonic,ib-nas62x0|\
 seagate,dockstar|\
 zyxel,nsa310b|\
@@ -25,7 +26,7 @@ zyxel,nsa310s|\
 zyxel,nsa325)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x20000" "0x20000"
        ;;
-linksys,audi)
+linksys,ea3500)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x4000" "0x4000"
        ;;
 esac
index bbe689bbb5637daeb5183f2f49df4156dee8bf69..3f7fe71c0a0c6e2a84fbc3b47fb724b9f01398a1 100755 (executable)
@@ -10,10 +10,11 @@ board_config_update
 board=$(board_name)
 
 case "$board" in
-"iom,ix2-200")
+iom,ix2-200)
        ucidef_set_led_timer "health" "health" "status:white:rebuild_led" "200" "800"
        ;;
-"linksys,viper")
+linksys,e4200-v2|\
+linksys,ea4500)
        ucidef_set_led_default "pulse" "pulse" "viper:white:pulse" "1"
        ;;
 esac
index 658ce1334672210939092f2c5013d265b95b6a97..a60b87c91268fd1567c64d99103590dab72c770b 100755 (executable)
@@ -28,8 +28,9 @@ case "$board" in
 "zyxel,nsa310s")
        ucidef_set_interface_lan "eth0" "dhcp"
        ;;
-"linksys,audi"|\
-"linksys,viper")
+"linksys,e4200-v2"|\
+"linksys,ea3500"|\
+"linksys,ea4500")
        ucidef_set_interfaces_lan_wan "ethernet1 ethernet2 ethernet3 ethernet4" "internet"
        ucidef_set_interface_macaddr "wan" $( mtd_get_mac_ascii u_env eth1addr )
        ;;
index 8954d69d12c1517669c4cbaccd0fd16a88eca1c3..29d1debe58b8d28e9c1378d87b792b7344e772d9 100755 (executable)
@@ -9,8 +9,9 @@
 board_config_update
 
 case "$(board_name)" in
-       linksys,audi|\
-       linksys,viper)
+       linksys,e4200-v2|\
+       linksys,ea3500|\
+       linksys,ea4500)
                ucidef_set_compat_version "1.1"
                ;;
 esac
index 478f3d0134156533cf999ddc872a9d19fbd98f03..bbb36eb6ea91ffcad0f036c283e9464a6a737398 100755 (executable)
@@ -4,8 +4,9 @@ START=99
 
 boot() {
        case $(board_name) in
-       linksys,audi|\
-       linksys,viper)
+       linksys,e4200-v2|\
+       linksys,ea3500|\
+       linksys,ea4500)
                mtd resetbc s_env || true
                ;;
        esac
index 6d63a0a4b7602850f7aea145340136349d547f40..8ff1709f2c6c6a3014d56a694c4e2d7c2b1c8647 100644 (file)
@@ -11,8 +11,9 @@ platform_do_upgrade() {
        local board="$(board_name)"
 
        case "$board" in
-       "linksys,audi"|\
-       "linksys,viper")
+       linksys,e4200-v2|\
+       linksys,ea3500|\
+       linksys,ea4500)
                platform_do_upgrade_linksys "$1"
                ;;
        *)
diff --git a/target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-e4200-v2.dts b/target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-e4200-v2.dts
new file mode 100644 (file)
index 0000000..bfd708a
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "kirkwood-linksys-viper.dts"
+
+/ {
+       model = "Linksys E4200 v2 (Viper)";
+       compatible = "linksys,e4200-v2", "linksys,viper", "marvell,kirkwood-88f6282", "marvell,kirkwood";
+};
diff --git a/target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-ea3500.dts b/target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-ea3500.dts
new file mode 100644 (file)
index 0000000..851f316
--- /dev/null
@@ -0,0 +1,242 @@
+// SPDX-License-Identifier: GPL-2.0
+/*
+ * kirkwood-linksys-audi.dts - Device Tree file for Linksys EA3500
+ *
+ * (c) 2013 Jonas Gorski <jogo@openwrt.org>
+ * (c) 2013 Deutsche Telekom Innovation Laboratories
+ * (c) 2014 Luka Perkov <luka@openwrt.org>
+ * (c) 2014 Dan Walters <dan@walters.io>
+ *
+ */
+
+/dts-v1/;
+
+#include "kirkwood.dtsi"
+#include "kirkwood-6282.dtsi"
+
+/ {
+       model = "Linksys EA3500 (Audi)";
+       compatible = "linksys,ea3500", "linksys,audi", "marvell,kirkwood-88f6282", "marvell,kirkwood";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x00000000 0x4000000>;
+       };
+
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+               serial0 = &uart0;
+       };
+
+       chosen {
+               stdout-path = "serial0:115200n8";
+       };
+
+       gpio-keys {
+               compatible = "gpio-keys";
+
+               pinctrl-0 = <&pmx_btn_wps &pmx_btn_reset>;
+               pinctrl-names = "default";
+
+               wps {
+                       label = "WPS Button";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
+               };
+
+               reset {
+                       label = "Reset Button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               pinctrl-0 = <&pmx_led_green_power>;
+               pinctrl-names = "default";
+
+               led_power: power {
+                       label = "audi:green:power";
+                       gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
+                       default-state = "on";
+               };
+       };
+};
+
+&pinctrl {
+       pmx_led_green_power: pmx-led-green-power {
+               marvell,pins = "mpp7";
+               marvell,function = "gpo";
+       };
+
+       pmx_btn_wps: pmx-btn-wps {
+               marvell,pins = "mpp47";
+               marvell,function = "gpio";
+       };
+
+       pmx_btn_reset: pmx-btn-reset {
+               marvell,pins = "mpp48";
+               marvell,function = "gpio";
+       };
+};
+
+&mdio {
+       status = "okay";
+
+       switch@10 {
+               compatible = "marvell,mv88e6085";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               reg = <16>;
+
+               ports {
+                       #address-cells = <1>;
+                       #size-cells = <0>;
+
+                       port@0 {
+                               reg = <0>;
+                               label = "ethernet1";
+                       };
+
+                       port@1 {
+                               reg = <1>;
+                               label = "ethernet2";
+                       };
+
+                       port@2 {
+                               reg = <2>;
+                               label = "ethernet3";
+                       };
+
+                       port@3 {
+                               reg = <3>;
+                               label = "ethernet4";
+                       };
+
+                       port@4 {
+                               reg = <4>;
+                               label = "internet";
+                       };
+
+                       port@5 {
+                               reg = <5>;
+                               label = "cpu";
+                               ethernet = <&eth0port>;
+                               fixed-link {
+                                       speed = <1000>;
+                                       full-duplex;
+                               };
+                       };
+               };
+       };
+};
+
+&nand {
+       status = "okay";
+
+       pinctrl-0 = <&pmx_nand>;
+       pinctrl-names = "default";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x80000>;
+                       read-only;
+               };
+
+               partition@80000 {
+                       label = "u_env";
+                       reg = <0x80000 0x4000>;
+               };
+
+               partition@84000 {
+                       label = "s_env";
+                       reg = <0x84000 0x4000>;
+               };
+
+               partition@200000 {
+                       label = "kernel1";
+                       reg = <0x200000 0x290000>;
+               };
+
+               partition@490000 {
+                       label = "rootfs1";
+                       reg = <0x490000 0x1170000>;
+               };
+
+               partition@1600000 {
+                       label = "kernel2";
+                       reg = <0x1600000 0x290000>;
+               };
+
+               partition@1890000 {
+                       label = "rootfs2";
+                       reg = <0x1890000 0x1170000>;
+               };
+
+               partition@2a00000 {
+                       label = "syscfg";
+                       reg = <0x2a00000  0x1600000>;
+               };
+
+               partition@88000 {
+                       label = "unused";
+                       reg = <0x88000 0x178000>;
+               };
+       };
+};
+
+&pciec {
+       status = "okay";
+};
+
+&pcie0 {
+       status = "okay";
+};
+
+&pcie1 {
+       status = "okay";
+};
+
+&mdio {
+       status = "okay";
+};
+
+&uart0 {
+       status = "okay";
+};
+
+/* eth0 is connected to a Marvell 88E6171 switch, without a PHY. So set
+ * fixed speed and duplex.
+ */
+&eth0 {
+       status = "okay";
+
+       ethernet0-port@0 {
+               speed = <1000>;
+               duplex = <1>;
+       };
+};
+
+/* eth1 is connected to the switch at port 6. However DSA only supports a
+ * single CPU port. This port is disabled to avoid confusion.
+ */
+&eth1 {
+       status = "disabled";
+};
+
+/* There is no battery on the board, so the RTC does not keep
+ * time when there is no power, making it useless.
+ */
+&rtc {
+       status = "disabled";
+};
diff --git a/target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-ea4500.dts b/target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-ea4500.dts
new file mode 100644 (file)
index 0000000..495cff3
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "kirkwood-linksys-viper.dts"
+
+/ {
+       model = "Linksys EA4500 (Viper)";
+       compatible = "linksys,ea4500", "linksys,viper", "marvell,kirkwood-88f6282", "marvell,kirkwood";
+};
diff --git a/target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-linksys-audi.dts b/target/linux/kirkwood/files-5.4/arch/arm/boot/dts/kirkwood-linksys-audi.dts
deleted file mode 100644 (file)
index 90250fe..0000000
+++ /dev/null
@@ -1,242 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0
-/*
- * kirkwood-linksys-audi.dts - Device Tree file for Linksys EA3500
- *
- * (c) 2013 Jonas Gorski <jogo@openwrt.org>
- * (c) 2013 Deutsche Telekom Innovation Laboratories
- * (c) 2014 Luka Perkov <luka@openwrt.org>
- * (c) 2014 Dan Walters <dan@walters.io>
- *
- */
-
-/dts-v1/;
-
-#include "kirkwood.dtsi"
-#include "kirkwood-6282.dtsi"
-
-/ {
-       model = "Linksys Audi (EA3500)";
-       compatible = "linksys,audi", "marvell,kirkwood-88f6282", "marvell,kirkwood";
-
-       memory@0 {
-               device_type = "memory";
-               reg = <0x00000000 0x4000000>;
-       };
-
-       aliases {
-               led-boot = &led_power;
-               led-failsafe = &led_power;
-               led-running = &led_power;
-               led-upgrade = &led_power;
-               serial0 = &uart0;
-       };
-
-       chosen {
-               stdout-path = "serial0:115200n8";
-       };
-
-       gpio-keys {
-               compatible = "gpio-keys";
-
-               pinctrl-0 = <&pmx_btn_wps &pmx_btn_reset>;
-               pinctrl-names = "default";
-
-               wps {
-                       label = "WPS Button";
-                       linux,code = <KEY_WPS_BUTTON>;
-                       gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
-               };
-
-               reset {
-                       label = "Reset Button";
-                       linux,code = <KEY_RESTART>;
-                       gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               pinctrl-0 = <&pmx_led_green_power>;
-               pinctrl-names = "default";
-
-               led_power: power {
-                       label = "audi:green:power";
-                       gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
-                       default-state = "on";
-               };
-       };
-};
-
-&pinctrl {
-       pmx_led_green_power: pmx-led-green-power {
-               marvell,pins = "mpp7";
-               marvell,function = "gpo";
-       };
-
-       pmx_btn_wps: pmx-btn-wps {
-               marvell,pins = "mpp47";
-               marvell,function = "gpio";
-       };
-
-       pmx_btn_reset: pmx-btn-reset {
-               marvell,pins = "mpp48";
-               marvell,function = "gpio";
-       };
-};
-
-&mdio {
-       status = "okay";
-
-       switch@10 {
-               compatible = "marvell,mv88e6085";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               reg = <16>;
-
-               ports {
-                       #address-cells = <1>;
-                       #size-cells = <0>;
-
-                       port@0 {
-                               reg = <0>;
-                               label = "ethernet1";
-                       };
-
-                       port@1 {
-                               reg = <1>;
-                               label = "ethernet2";
-                       };
-
-                       port@2 {
-                               reg = <2>;
-                               label = "ethernet3";
-                       };
-
-                       port@3 {
-                               reg = <3>;
-                               label = "ethernet4";
-                       };
-
-                       port@4 {
-                               reg = <4>;
-                               label = "internet";
-                       };
-
-                       port@5 {
-                               reg = <5>;
-                               label = "cpu";
-                               ethernet = <&eth0port>;
-                               fixed-link {
-                                       speed = <1000>;
-                                       full-duplex;
-                               };
-                       };
-               };
-       };
-};
-
-&nand {
-       status = "okay";
-
-       pinctrl-0 = <&pmx_nand>;
-       pinctrl-names = "default";
-
-       partitions {
-               compatible = "fixed-partitions";
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partition@0 {
-                       label = "u-boot";
-                       reg = <0x0 0x80000>;
-                       read-only;
-               };
-
-               partition@80000 {
-                       label = "u_env";
-                       reg = <0x80000 0x4000>;
-               };
-
-               partition@84000 {
-                       label = "s_env";
-                       reg = <0x84000 0x4000>;
-               };
-
-               partition@200000 {
-                       label = "kernel1";
-                       reg = <0x200000 0x290000>;
-               };
-
-               partition@490000 {
-                       label = "rootfs1";
-                       reg = <0x490000 0x1170000>;
-               };
-
-               partition@1600000 {
-                       label = "kernel2";
-                       reg = <0x1600000 0x290000>;
-               };
-
-               partition@1890000 {
-                       label = "rootfs2";
-                       reg = <0x1890000 0x1170000>;
-               };
-
-               partition@2a00000 {
-                       label = "syscfg";
-                       reg = <0x2a00000  0x1600000>;
-               };
-
-               partition@88000 {
-                       label = "unused";
-                       reg = <0x88000 0x178000>;
-               };
-       };
-};
-
-&pciec {
-       status = "okay";
-};
-
-&pcie0 {
-       status = "okay";
-};
-
-&pcie1 {
-       status = "okay";
-};
-
-&mdio {
-       status = "okay";
-};
-
-&uart0 {
-       status = "okay";
-};
-
-/* eth0 is connected to a Marvell 88E6171 switch, without a PHY. So set
- * fixed speed and duplex.
- */
-&eth0 {
-       status = "okay";
-
-       ethernet0-port@0 {
-               speed = <1000>;
-               duplex = <1>;
-       };
-};
-
-/* eth1 is connected to the switch at port 6. However DSA only supports a
- * single CPU port. This port is disabled to avoid confusion.
- */
-&eth1 {
-       status = "disabled";
-};
-
-/* There is no battery on the board, so the RTC does not keep
- * time when there is no power, making it useless.
- */
-&rtc {
-       status = "disabled";
-};
index 6554fc2669499a659a7ddf5637d081f8eaf9c290..3a600da13c964a6c73dcc56afd4a1920010eb4cd 100644 (file)
@@ -96,34 +96,47 @@ define Device/iom_ix2-200
 endef
 TARGET_DEVICES += iom_ix2-200
 
-define Device/linksys_audi
-  $(Device/dsa-migration)
+define Device/linksys
   DEVICE_VENDOR := Linksys
-  DEVICE_MODEL := EA3500 (Audi)
   DEVICE_PACKAGES := kmod-mwl8k wpad-basic kmod-gpio-button-hotplug
+  KERNEL_IN_UBI :=
+  UBINIZE_OPTS := -E 5
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+endef
+
+define Device/linksys_e4200-v2
+  $(Device/linksys)
+  $(Device/dsa-migration)
+  DEVICE_MODEL := E4200
+  DEVICE_VARIANT := v2
+  DEVICE_DTS := kirkwood-e4200-v2
+  KERNEL_SIZE := 2688k
+  SUPPORTED_DEVICES += linksys,viper linksys-viper
+endef
+TARGET_DEVICES += linksys_e4200-v2
+
+define Device/linksys_ea3500
+  $(Device/linksys)
+  $(Device/dsa-migration)
+  DEVICE_MODEL := EA3500
+  DEVICE_DTS := kirkwood-ea3500
   PAGESIZE := 512
   SUBPAGESIZE := 256
   BLOCKSIZE := 16k
   KERNEL_SIZE := 2624k
-  KERNEL_IN_UBI :=
-  UBINIZE_OPTS := -E 5
-  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
-  BOARD_NAME := linksys-audi
+  SUPPORTED_DEVICES += linksys,audi linksys-audi
 endef
-TARGET_DEVICES += linksys_audi
+TARGET_DEVICES += linksys_ea3500
 
-define Device/linksys_viper
+define Device/linksys_ea4500
+  $(Device/linksys)
   $(Device/dsa-migration)
-  DEVICE_VENDOR := Linksys
-  DEVICE_MODEL := E4200v2 / EA4500 (Viper)
-  DEVICE_PACKAGES := kmod-mwl8k wpad-basic kmod-gpio-button-hotplug
+  DEVICE_MODEL := EA4500
+  DEVICE_DTS := kirkwood-ea4500
   KERNEL_SIZE := 2688k
-  KERNEL_IN_UBI :=
-  UBINIZE_OPTS := -E 5
-  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
-  BOARD_NAME := linksys-viper
+  SUPPORTED_DEVICES += linksys,viper linksys-viper
 endef
-TARGET_DEVICES += linksys_viper
+TARGET_DEVICES += linksys_ea4500
 
 define Device/raidsonic_ib-nas62x0
   DEVICE_VENDOR := RaidSonic
diff --git a/target/linux/kirkwood/patches-5.4/105-ea4500.patch b/target/linux/kirkwood/patches-5.4/105-ea4500.patch
deleted file mode 100644 (file)
index 0d97ad1..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
---- a/arch/arm/boot/dts/kirkwood-linksys-viper.dts
-+++ b/arch/arm/boot/dts/kirkwood-linksys-viper.dts
-@@ -24,6 +24,10 @@
-       };
-       aliases {
-+              led-boot = &led_white_health;
-+              led-failsafe = &led_white_health;
-+              led-running = &led_white_health;
-+              led-upgrade = &led_white_health;
-               serial0 = &uart0;
-       };
-@@ -56,9 +60,10 @@
-               pinctrl-0 = < &pmx_led_white_health &pmx_led_white_pulse >;
-               pinctrl-names = "default";
--              white-health {
-+              led_white_health: white-health {
-                       label = "viper:white:health";
-                       gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
-+                      default-state = "on";
-               };
-               white-pulse {
-@@ -114,22 +119,22 @@
-               };
-               partition@200000 {
--                      label = "kernel";
-+                      label = "kernel1";
-                       reg = <0x200000 0x2A0000>;
-               };
-               partition@4a0000 {
--                      label = "rootfs";
-+                      label = "rootfs1";
-                       reg = <0x4A0000 0x1760000>;
-               };
-               partition@1c00000 {
--                      label = "alt_kernel";
-+                      label = "kernel2";
-                       reg = <0x1C00000 0x2A0000>;
-               };
-               partition@1ea0000 {
--                      label = "alt_rootfs";
-+                      label = "rootfs2";
-                       reg = <0x1EA0000 0x1760000>;
-               };
diff --git a/target/linux/kirkwood/patches-5.4/105-linksys-viper-dts.patch b/target/linux/kirkwood/patches-5.4/105-linksys-viper-dts.patch
new file mode 100644 (file)
index 0000000..0d97ad1
--- /dev/null
@@ -0,0 +1,52 @@
+--- a/arch/arm/boot/dts/kirkwood-linksys-viper.dts
++++ b/arch/arm/boot/dts/kirkwood-linksys-viper.dts
+@@ -24,6 +24,10 @@
+       };
+       aliases {
++              led-boot = &led_white_health;
++              led-failsafe = &led_white_health;
++              led-running = &led_white_health;
++              led-upgrade = &led_white_health;
+               serial0 = &uart0;
+       };
+@@ -56,9 +60,10 @@
+               pinctrl-0 = < &pmx_led_white_health &pmx_led_white_pulse >;
+               pinctrl-names = "default";
+-              white-health {
++              led_white_health: white-health {
+                       label = "viper:white:health";
+                       gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
++                      default-state = "on";
+               };
+               white-pulse {
+@@ -114,22 +119,22 @@
+               };
+               partition@200000 {
+-                      label = "kernel";
++                      label = "kernel1";
+                       reg = <0x200000 0x2A0000>;
+               };
+               partition@4a0000 {
+-                      label = "rootfs";
++                      label = "rootfs1";
+                       reg = <0x4A0000 0x1760000>;
+               };
+               partition@1c00000 {
+-                      label = "alt_kernel";
++                      label = "kernel2";
+                       reg = <0x1C00000 0x2A0000>;
+               };
+               partition@1ea0000 {
+-                      label = "alt_rootfs";
++                      label = "rootfs2";
+                       reg = <0x1EA0000 0x1760000>;
+               };