zlib: use default Build/Configure rule
authorStijn Tintel <stijn@linux-ipv6.be>
Sat, 11 Mar 2017 08:32:19 +0000 (09:32 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 13 Dec 2017 15:23:39 +0000 (16:23 +0100)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
(cherry picked from commit 462ca4e059dbead678163da26fb4e14748f3021e)

package/libs/zlib/Makefile

index 902381bdeaa7b79c439c3e9cddc898ce4076006d..7e3bd83195e844e5825db18ddd9f93159551c996 100644 (file)
@@ -45,17 +45,15 @@ define Package/zlib-dev/description
  This package includes the development support files.
 endef
 
  This package includes the development support files.
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-               $(TARGET_CONFIGURE_OPTS) \
-               LDSHARED="$(TARGET_CC) -shared -Wl,-soname,libz.so.1" \
-               CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
-               ./configure \
-                       --prefix=/usr \
-                       --shared \
-                       --uname=Linux \
-       );
-endef
+CONFIGURE_VARS := \
+       $(TARGET_CONFIGURE_OPTS) \
+       LDSHARED="$(TARGET_CC) -shared -Wl,-soname,libz.so.1" \
+       CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
+
+CONFIGURE_ARGS := \
+       --prefix=/usr \
+       --shared \
+       --uname=Linux \
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \