ipq40xx: cut ath10k board file for mikrotik subtarget
authorJohn Thomson <git@johnthomson.fastmail.com.au>
Fri, 20 May 2022 22:13:21 +0000 (08:13 +1000)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 27 May 2022 12:15:09 +0000 (14:15 +0200)
Avoid shipping ath10k board file in Mikrotik initram images

Most will only ever need to use these initram images onceā€”to initially
load OpenWrt, but fix these images for more consistent Wi-Fi performance
between the initram and installed squashfs images.

OpenWrt BUILDBOT config ignores -cut packages in the initram images build.
This results in BUILDBOT initram images including the linux-firmware
qca4019 board-2.bin, and (initram image booted) Mikrotik devices loading
a generic BDF, rather than the intended BDF data loaded
from NOR as an api 1 board_file.

buildbot snapshot booted as initram image:
cat /etc/openwrt_version
r19679-810eac8c7f
dmesg | grep ath10k | grep -E board\|BDF
[    9.794556] ath10k_ahb a000000.wifi: Loading BDF type 0
[    9.807192] ath10k_ahb a000000.wifi: board_file api 2 bmi_id 0:16
crc32 11892f9b
[   12.457105] ath10k_ahb a800000.wifi: Loading BDF type 0
[   12.464945] ath10k_ahb a800000.wifi: board_file api 2 bmi_id 0:17
crc32 11892f9b

CC: Robert Marko <robimarko@gmail.com>
Fixes: 5eee67a72fed ("ipq40xx: mikrotik: dont include ath10k-board-qca4019 by default")
Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
Reviewed-by: Robert Marko <robimarko@gmail.com>
target/linux/ipq40xx/Makefile
target/linux/ipq40xx/chromium/target.mk
target/linux/ipq40xx/generic/target.mk
target/linux/ipq40xx/mikrotik/target.mk

index 7df920e2d808ab9b3c2dbad8a12b178e87104f5b..19b63cdd65853ec13ae6762f4098efa811f3369f 100644 (file)
@@ -19,6 +19,6 @@ DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
        kmod-ath10k-ct wpad-basic-wolfssl \
        kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct \
-       ath10k-board-qca4019 uboot-envtools
+       uboot-envtools
 
 $(eval $(call BuildTarget))
index 3983a9281a5d20eccdba636c02c9622333d38699..98bd37ed71a7a04d8f56f4b02dc5e9333b06ce49 100644 (file)
@@ -1,2 +1,3 @@
 BOARDNAME:=Google Chromium
 FEATURES += emmc boot-part rootfs-part
+DEFAULT_PACKAGES += ath10k-board-qca4019
index e158b1c98b1065a8a7a47727d17113e60cbb491c..90c1b762afcdfa5e27ce92d854fa52265fa3cd1b 100644 (file)
@@ -1,2 +1,3 @@
 BOARDNAME:=Generic
 FEATURES+=emmc
+DEFAULT_PACKAGES += ath10k-board-qca4019
index 8b17c6158573ff4c3d5330f27334009d5126f02e..4530a909850942565cbd410d53b97c22d54a48d2 100644 (file)
@@ -2,4 +2,3 @@ BOARDNAME:=MikroTik
 FEATURES += minor
 KERNEL_IMAGES:=vmlinux
 IMAGES_DIR:=compressed
-DEFAULT_PACKAGES += -ath10k-board-qca4019