ar71xx: copy atheros initramfs images to the image directory
authorGabor Juhos <juhosg@openwrt.org>
Thu, 24 Nov 2011 20:09:35 +0000 (20:09 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 24 Nov 2011 20:09:35 +0000 (20:09 +0000)
SVN-Revision: 29325

target/linux/ar71xx/image/Makefile

index a50d9072d30aa0dbe80c8b17ce79c01dc7ed8a8d..febbfb96cbf2d1fc0d37e60e517e5476e7e19cce 100644 (file)
@@ -201,6 +201,7 @@ endef
 
 define Image/Build/AthGzip/initramfs
        $(call MkuImageLzma,$(2),$(3) $($(4)))
+       $(CP) $(KDIR)/vmlinux-$(2).uImage $(call imgname,$(1),$(2))-uImage.bin
 endef
 
 define Image/Build/AthLzma
@@ -210,6 +211,7 @@ endef
 
 define Image/Build/AthLzma/initramfs
        $(call MkuImageLzma,$(2),$(3) $($(4)))
+       $(CP) $(KDIR)/vmlinux-$(2).uImage $(call imgname,$(1),$(2))-uImage.bin
 endef
 
 define Image/Build/PB4X