bcm47xx: Fix Netgear WNR3500L v2 image format
authorFlorian Fainelli <f.fainelli@gmail.com>
Tue, 14 Dec 2021 20:27:43 +0000 (12:27 -0800)
committerFlorian Fainelli <f.fainelli@gmail.com>
Mon, 20 Jun 2022 21:29:12 +0000 (14:29 -0700)
CFE on these devices expects to find the kernel compressed with LZMA but
with no dictionnary and no loader, adjust the image generation
accordingly.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
target/linux/bcm47xx/image/mips74k.mk

index 53e7b53eba8b1582867394ac058ebafc035df705..7e65821a5589cf449fa6f9ec60415ea585a8b77f 100644 (file)
@@ -460,6 +460,8 @@ define Device/netgear_wnr3500l-v2
   $(Device/netgear)
   NETGEAR_BOARD_ID := U12H172T00_NETGEAR
   NETGEAR_REGION := 1
+  KERNEL_NAME = vmlinux-nodictionary.lzma
+  IMAGE/chk := append-rootfs | trx-without-loader | netgear-chk
 endef
 TARGET_DEVICES += netgear_wnr3500l-v2