oxnas: reduce size of ATA DMA descriptor space
authorDaniel Golle <daniel@makrotopia.org>
Mon, 10 Aug 2020 22:33:00 +0000 (23:33 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 10 Aug 2020 23:16:04 +0000 (00:16 +0100)
After years of trying to find the reason for random kernel crashes
while both CPU and SATA are under load it has been found.
Some odd commented-out #defines in kref's single-port driver [1] which
were copied from the vendor driver made me develop a theory:
The IO-mapped memory area for DMA descriptors apparetly got some holes
just before the alignment boundaries.
This feels like an off-by-one bug in the hardware or maybe those fields
are used internally by the SATA controller's firmware.
Whatever the cause is: they cannot be used and trying to use them
results in reading back unexpected stuff and ends up with oopsing
Unable to handle kernel paging request at virtual address d085c004

Work around the issue by reducing the area used for bmdma descriptors.
This reduces SATA performance (iops) quite a bit, but finally makes
things work reliably. Possibly one could optimize this much more by
really just skipping the holes in that memory area -- however, that
seems to be non-trivial with the driver and libata in it's current form
(suggestions are welcome).
The 'proper' way to have good SATA performance would be to make use of
the hardware RAID features (one can use the JBOD mode to access even
just a single disc transparently through the RAID controller integrated
in the SATA host instead of accessing the SATA ports 'raw' as we do
now).

[1]: https://github.com/kref/linux-oxnas/blob/master/drivers/ata/sata_oxnas.c#L25

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/oxnas/files/drivers/ata/sata_oxnas.c
target/linux/oxnas/image/ox820.mk

index 6e0f7a72a6d5611672704cd0998d846f2d59f0f4..64231a8c70e25b20ed8767538e45db04268e0390 100644 (file)
@@ -70,7 +70,7 @@ struct sgdma_request {
 
 /* Controller information */
 enum {
-       SATA_OXNAS_MAX_PRD = 254,
+       SATA_OXNAS_MAX_PRD = 63,
        SATA_OXNAS_DMA_SIZE = SATA_OXNAS_MAX_PRD *
                                sizeof(struct ata_bmdma_prd) +
                                sizeof(struct sgdma_request),
index 2a9295bd9719a16179e9edb3a3c36840141592d3..99c438f149c13b93529950d8f68ee488e76d8ee0 100644 (file)
@@ -68,10 +68,6 @@ define Device/shuttle_kd20
   DEVICE_VENDOR := Shuttle
   DEVICE_MODEL := KD20
   SUPPORTED_DEVICES += kd20
-  KERNEL_INITRAMFS_PREFIX = $$(IMAGE_PREFIX)-factory
-  KERNEL_INITRAMFS_SUFFIX := .tar.gz
-  KERNEL_INITRAMFS = kernel-bin | append-dtb | uImage none | omninas-factory | \
-       encrypt-3des sohmuntitnlaes
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb3 kmod-usb-ledtrig-usbport \
        kmod-i2c-gpio kmod-rtc-pcf8563 kmod-gpio-beeper kmod-hwmon-drivetemp \
        kmod-hwmon-gpiofan kmod-ata-oxnas-sata kmod-md-mod kmod-md-raid0 \