tfp-layerscape: update to LSDK-20.12
authorRosen Penev <rosenp@gmail.com>
Mon, 20 Sep 2021 02:30:37 +0000 (19:30 -0700)
committerPaul Spooren <mail@aparcar.org>
Wed, 22 Sep 2021 07:39:01 +0000 (21:39 -1000)
Fixes compilation with GCC11.

Kept PKG_VERSION as there's some bug that chops off the 12 at the end.

Refreshed other patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/boot/tfa-layerscape/Makefile
package/boot/tfa-layerscape/patches/003-plat-nxp-tools-fix-create_pbl-and-byte_swap-host-bui.patch
package/boot/tfa-layerscape/patches/010-gcc11.patch [new file with mode: 0644]

index 6285da6a156542fdbdb6df113a59a4fe8976556f..6f0e1758850b58a25b37db5e98d167e9de3c4d9b 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tfa-layerscape
-PKG_VERSION:=LSDK-20.04-update-290520
+PKG_VERSION:=LSDK-20.12
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://source.codeaurora.org/external/qoriq/qoriq-components/atf
-PKG_SOURCE_VERSION:=7d748e6f0ec652ba7c43733dc67a3d0b0217390a
-PKG_MIRROR_HASH:=d209c9ad18aac9f18375450b98b8dab00f0382ccb485df14623bf9b72ea1dd9b
+PKG_SOURCE_VERSION:=LSDK-20.12
+PKG_MIRROR_HASH:=8e3a0bd33c00657beeb2df88a881b1831aeb790751cacd4c4fdf33ffa01e956e
 PKG_BUILD_DEPENDS:=tfa-layerscape/host
 
 include $(INCLUDE_DIR)/host-build.mk
index ce4d9c48bf3ebffbc78d1cc50a6e4ff2dd33d1f1..2b19d53c7146d040c8c6462f1ca4f5aaf34015a4 100644 (file)
@@ -11,8 +11,6 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  plat/nxp/tools/pbl_ch3.mk | 5 -----
  2 files changed, 8 deletions(-)
 
-diff --git a/plat/nxp/tools/pbl_ch2.mk b/plat/nxp/tools/pbl_ch2.mk
-index afa43520..ff624dd9 100644
 --- a/plat/nxp/tools/pbl_ch2.mk
 +++ b/plat/nxp/tools/pbl_ch2.mk
 @@ -20,8 +20,6 @@ ifeq ($(RCW),"")
@@ -32,8 +30,6 @@ index afa43520..ff624dd9 100644
        ${CREATE_PBL} -r ${RCW} -i ${BUILD_PLAT}/bl2.bin -b ${BOOT_MODE} -c ${SOC_NUM} -d ${BL2_BASE} -e ${BL2_BASE} \
        -o ${BUILD_PLAT}/bl2_${BOOT_MODE}.pbl ;
  # Swapping of RCW is required for QSPi Chassis 2 devices
-diff --git a/plat/nxp/tools/pbl_ch3.mk b/plat/nxp/tools/pbl_ch3.mk
-index 944ae3bb..9aa8f635 100644
 --- a/plat/nxp/tools/pbl_ch3.mk
 +++ b/plat/nxp/tools/pbl_ch3.mk
 @@ -27,9 +27,6 @@ else
@@ -55,6 +51,3 @@ index 944ae3bb..9aa8f635 100644
        # Add Block Copy command and populate boot loc ptrfor bl2.bin to RCW
        ${CREATE_PBL} -r ${RCW} -i ${BUILD_PLAT}/bl2.bin -b ${BOOT_MODE} -c ${SOC_NUM} -d ${BL2_BASE} -e ${BL2_BASE} \
        -o ${BUILD_PLAT}/bl2_${BOOT_MODE}.pbl -f ${BL2_SRC_OFFSET};
--- 
-2.17.1
-
diff --git a/package/boot/tfa-layerscape/patches/010-gcc11.patch b/package/boot/tfa-layerscape/patches/010-gcc11.patch
new file mode 100644 (file)
index 0000000..1cdc21a
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/common/runtime_svc.c
++++ b/common/runtime_svc.c
+@@ -38,7 +38,7 @@ uintptr_t handle_runtime_svc(uint32_t smc_fid,
+       u_register_t x1, x2, x3, x4;
+       int index;
+       unsigned int idx;
+-      const rt_svc_desc_t *rt_svc_descs;
++      rt_svc_desc_t *rt_svc_descs = NULL;
+       assert(handle);
+       idx = get_unique_oen_from_smc_fid(smc_fid);
+@@ -48,7 +48,7 @@ uintptr_t handle_runtime_svc(uint32_t smc_fid,
+       if (index < 0 || index >= (int)RT_SVC_DECS_NUM)
+               SMC_RET1(handle, SMC_UNK);
+-      rt_svc_descs = (rt_svc_desc_t *) RT_SVC_DESCS_START;
++      memcpy(rt_svc_descs, (rt_svc_desc_t *)RT_SVC_DESCS_START, MAX_RT_SVCS);
+       get_smc_params_from_ctx(handle, x1, x2, x3, x4);