brcm2708: split sdcard.img.gz into a sysupgrade and factory image
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 29 Jul 2018 09:55:14 +0000 (11:55 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 12:00:59 +0000 (14:00 +0200)
@vahid-dan reported a issue with extracting the rpi images with
Gnome's Archive Manager:
"Ubuntu Archive Manager cannot extract the file and it just
throws a general error message: "An error occurred while
extracting files".
<https://forum.lede-project.org/t/corrupted-pre-built-v18-06-0-rc2-image-for-rpi>

@blogic told me to split the single sdcard.img.gz for the RPi
into a sysupgrade and a factory image for all brcm2708 targets.
The factory images will have no metadata attached, this way
these utilities that can't deal with the attached metadata will
not fail for no reason.

Cc: John Crispin <john@phrozen.org>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
(cherry picked from commit 7516a960113d512cb2909f40bd07caf2a6c547b1)

target/linux/brcm2708/image/Makefile

index 326ef5a0eed15a0fae081a6404652ab8984ec420..8ace69bdfd48d1c79121178a7281234ea94716fa 100644 (file)
@@ -49,8 +49,9 @@ endef
 define Device/Default
   KERNEL := kernel-bin | kernel-img
   KERNEL_IMG := kernel.img
-  IMAGES := sdcard.img.gz
-  IMAGE/sdcard.img.gz := boot-img | sdcard-img | gzip | append-metadata
+  IMAGES := factory.img.gz sysupgrade.img.gz
+  IMAGE/sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
+  IMAGE/factory.img.gz := boot-img | sdcard-img | gzip
 endef
 
 define Device/rpi