target/x86: use common config items for options shared between generic and olpc targets
authorNicolas Thill <nico@openwrt.org>
Wed, 5 May 2010 02:07:38 +0000 (02:07 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 5 May 2010 02:07:38 +0000 (02:07 +0000)
SVN-Revision: 21364

target/linux/x86/image/Config.in
target/linux/x86/image/Makefile

index 7eb0c8a1f2924bfe562893b114973907c78af6ff..6f4e0bdb143aea4f27c3e1c3b741662c693aaf7c 100644 (file)
@@ -5,10 +5,6 @@ config X86_GRUB_IMAGES
     select PACKAGE_grub
     default y
 
-config X86_GRUB_IMAGES_PAD
-    bool "Pad GRUB images to filesystem size (for JFFS2)"
-    depends X86_GRUB_IMAGES
-
 config X86_GRUB_CONSOLE
     bool
     depends X86_GRUB_IMAGES
@@ -29,20 +25,6 @@ config X86_GRUB_BAUDRATE
     default 19200 if TARGET_x86_generic_Soekris48xx || TARGET_x86_generic_Soekris45xx || TARGET_x86_net5501
     default 38400 if ! (TARGET_x86_generic_Soekris48xx || TARGET_x86_generic_Soekris45xx || TARGET_x86_net5501)
 
-config X86_GRUB_KERNELPART
-    int "Kernel partition size (in MB)"
-    depends X86_GRUB_IMAGES
-    default 4
-
-config X86_GRUB_ROOTPART
-    string
-    prompt "Root partition on target device" if X86_GRUB_IMAGES
-    default "/dev/xvda2" if TARGET_x86_xen_domu
-    default "/dev/sda2" if ! TARGET_x86_xen_domu
-    help
-        The root partition on the final device.  If you don't know,
-        you probably want the default (/dev/sda2).
-
 config X86_GRUB_BOOTOPTS
     string
     prompt "Extra kernel boot options" if X86_GRUB_IMAGES
@@ -72,20 +54,21 @@ config OLPC_BOOTSCRIPT_IMAGES
     depends TARGET_ROOTFS_EXT2FS || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS || TARGET_ROOTFS_ISO
     default y
 
-config OLPC_BOOTSCRIPT_IMAGES_PAD
-       bool "Pad bootscript images to filesystem size (for JFFS2)"
-       depends OLPC_BOOTSCRIPT_IMAGES
 
-config OLPC_BOOTSCRIPT_KERNELPART
-    int "Kernel partition size (in MB)"
-    depends OLPC_BOOTSCRIPT_IMAGES
-    default 4
+config TARGET_IMAGES_PAD
+       bool "Pad images to filesystem size (for JFFS2)"
+       depends OLPC_BOOTSCRIPT_IMAGES || X86_GRUB_IMAGES
 
-config OLPC_BOOTSCRIPT_ROOTPART
-    string
-    prompt "Root partition on target device" if OLPC_BOOTSCRIPT_IMAGES
-    default "/dev/sda2"
-    help
-        The root partition on the final device.  If you don't know,
-        you probably want the default (/dev/sda2).
+config TARGET_KERNEL_PARTSIZE
+       int "Kernel partition size (in MB)"
+       depends OLPC_BOOTSCRIPT_IMAGES || X86_GRUB_IMAGES
+       default 4
 
+config TARGET_ROOTFS_PARTNAME
+       string "Root partition on target device"
+       depends OLPC_BOOTSCRIPT_IMAGES || X86_GRUB_IMAGES
+       default "/dev/xvda2" if TARGET_x86_xen_domu
+       default "/dev/sda2"
+       help
+         The root partition on the final device.  If you don't know,
+         you probably want the default (/dev/sda2).
index 8df00c24fe5657fea2bf97b4bdcdcd9c3aa90782..734736643972cb1ce25ada889135ff0db6054b87 100644 (file)
@@ -29,12 +29,12 @@ ifneq ($(GRUB_TERMINALS),)
   GRUB_TERMINAL_CONFIG := terminal --timeout=2 $(GRUB_TERMINALS)
 endif
 
+ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
 
 ifneq ($(CONFIG_X86_GRUB_IMAGES),)
  ifneq ($(HOST_OS),Darwin)
 
   BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
-  ROOTPART:=$(call qstrip,$(CONFIG_X86_GRUB_ROOTPART))
 
   define Image/cmdline/ext2
     root=$(ROOTPART) rootfstype=ext2 rootwait
@@ -66,9 +66,9 @@ ifneq ($(CONFIG_X86_GRUB_IMAGES),)
                -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
                -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
                ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
-       PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_x86.sh \
+       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_x86.sh \
                $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-               $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.grub \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
        $(call Image/Build/grub/$(1))
   endef
@@ -86,9 +86,9 @@ ifneq ($(CONFIG_X86_GRUB_IMAGES),)
  else
 
   define Image/Build/grub
-       PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" NOGRUB=1 ./gen_image_x86.sh 
+       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" NOGRUB=1 ./gen_image_x86.sh 
                $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-               $(CONFIG_X86_GRUB_KERNELPART) "" \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) "" \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
   endef
 
@@ -99,8 +99,6 @@ ROOTDELAY=10
 
 ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
 
-  ROOTPART:=$(call qstrip,$(CONFIG_OLPC_BOOTSCRIPT_ROOTPART))
-
   define Image/cmdline/ext2
     root=$(ROOTPART) rootfstype=ext2 rootwait
   endef
@@ -123,9 +121,9 @@ ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
        $(CP) $(KDIR)/bzImage $(KDIR)/root.bootscript/boot/vmlinuz
        sed -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
                ./olpc.fth > $(KDIR)/root.bootscript/boot/olpc.fth
-       PADDING="$(CONFIG_OLPC_BOOTSCRIPT_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_olpc.sh \
+       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_olpc.sh \
                $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-               $(CONFIG_OLPC_BOOTSCRIPT_KERNELPART) $(KDIR)/root.bootscript \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.bootscript \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
   endef