ipq40xx: chromium: Enable kmod-ramoops by default
authorBrian Norris <computersforpeace@gmail.com>
Sun, 5 Feb 2023 00:35:35 +0000 (16:35 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 18 Feb 2023 18:58:22 +0000 (19:58 +0100)
Chromium devices (like Google WiFi) have ramoops memory reserved by the
bootloader. Let's enable the ramoops kernel module by default, so we get
better crash logging.

Signed-off-by: Brian Norris <computersforpeace@gmail.com>
target/linux/ipq40xx/image/chromium.mk

index 2abd2df02ae4dd018ced778e2dc2c654a907fe0c..f6ac69ecf1433ab809ff82ab0dc33905f5c4375a 100644 (file)
@@ -30,7 +30,11 @@ define Device/google_wifi
        KERNEL_NAME := zImage
        IMAGES += factory.bin
        IMAGE/factory.bin := cros-gpt | append-kernel-part | append-rootfs
+       # Note: Chromium/Depthcharge-based bootloaders insert a reserved-memory
+       # ramoops node into the Device Tree automatically, so we can use
+       # kmod-ramoops.
        DEVICE_PACKAGES := partx-utils mkf2fs e2fsprogs \
-                          kmod-fs-ext4 kmod-fs-f2fs kmod-google-firmware
+                          kmod-fs-ext4 kmod-fs-f2fs kmod-google-firmware \
+                          kmod-ramoops
 endef
 TARGET_DEVICES += google_wifi