adm5120: add kmod-leds-gpio and kmod-ledtrig-adm5120-switch to the default packages
authorGabor Juhos <juhosg@openwrt.org>
Sat, 2 Jan 2010 15:07:39 +0000 (15:07 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 2 Jan 2010 15:07:39 +0000 (15:07 +0000)
SVN-Revision: 19001

target/linux/adm5120/Makefile
target/linux/adm5120/base-files/etc/diag.sh

index bcafec0b77b436de9b5fdfa8a0dd285383787104..8bd1eb11a563d1f8524a4bc00afdd1ebbd58864e 100644 (file)
@@ -16,6 +16,7 @@ INITRAMFS_EXTRA_FILES:=
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
-                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+                   kmod-leds-gpio kmod-ledtrig-adm5120-switch
 
 $(eval $(call BuildTarget))
index e031755239dc16bd2d4248283bae776b528c02b4..3a66dfc87b0137300da728561069f5360a1e67e5 100755 (executable)
@@ -35,6 +35,7 @@ status_led_off() {
 set_state() {
        case "$1" in
        preinit)
+               insmod leds-gpio
                status_led_set_timer 200 200
                ;;
        failsafe)