mvebu: make boot filesystem reproducible
authorDaniel Golle <daniel@makrotopia.org>
Mon, 28 Mar 2022 17:25:34 +0000 (18:25 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 28 Mar 2022 19:52:49 +0000 (20:52 +0100)
Set timestamp option for make_ext4fs to make boot filesystem
reproducible.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mvebu/image/Makefile

index 44e66a5f87304092497023f12c2eb1ce448bbb3d..b0498d34c9320cd27857d4434583409453550d73 100644 (file)
@@ -34,7 +34,9 @@ define Build/boot-img-ext4
        $(foreach dts,$(DEVICE_DTS), $(CP) $(KDIR)/image-$(dts).dtb $@.boot/$(dts).dtb;)
        $(CP) $(IMAGE_KERNEL) $@.boot/$(KERNEL_NAME)
        -$(CP) $@-boot.scr $@.boot/boot.scr
-       make_ext4fs -J -L kernel -l $(CONFIG_TARGET_KERNEL_PARTSIZE)M $@.bootimg $@.boot
+       make_ext4fs -J -L kernel -l $(CONFIG_TARGET_KERNEL_PARTSIZE)M \
+               $(if $(SOURCE_DATE_EPOCH),-T $(SOURCE_DATE_EPOCH)) \
+               $@.bootimg $@.boot
 endef
 
 define Build/buffalo-kernel-jffs2