ath10k: enable encapsulation offload by default
authorTiago Gaspar <tiagogaspar8@gmail.com>
Thu, 23 Jun 2022 13:15:06 +0000 (14:15 +0100)
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Mon, 27 Jun 2022 19:33:16 +0000 (21:33 +0200)
Enable ath10k offload by default. This improves wireless performance
without requiring user configuration.
This adds ath10k_core to the AUTOLOAD section so that the frame_mode
paramter can be added to /etc/modules.d and passed to the driver.
The frame_mode 2 enables ethernet mode on the firmware/driver.
This parameter is set by passing a different value to the frame_mode
value on kmod insmod.
Link to the original patchset:
https://patchwork.kernel.org/project/linux-wireless/cover/20220516032519.29831-1-ryazanov.s.a@gmail.com/

Signed-off-by: Tiago Gaspar <tiagogaspar8@gmail.com>
package/kernel/mac80211/ath.mk

index 50b1eed9c810e1c81868304fad00dc2d607fb12b..9af8c4665d198f3c760ab873d930f7c5fe08936f 100644 (file)
@@ -260,7 +260,8 @@ define KernelPackage/ath10k
   FILES:= \
        $(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath10k/ath10k_core.ko \
        $(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath10k/ath10k_pci.ko
-  AUTOLOAD:=$(call AutoProbe,ath10k_pci)
+  AUTOLOAD:=$(call AutoProbe,ath10k_core ath10k_pci)
+  MODPARAMS.ath10k_core:=frame_mode=2
   VARIANT:=regular
 endef