kernel: bump 5.4 to 5.4.82
authorJohn Audia <graysky@archlinux.us>
Tue, 8 Dec 2020 14:27:08 +0000 (09:27 -0500)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 9 Dec 2020 16:05:40 +0000 (17:05 +0100)
Removed since included upstream and could be reverse-applied by quilt:
  backport-5.4/315-v5.10-usbnet-ipeth-fix-connectivity-with-ios-14.patch

Remaining modifications made by update_kernel.sh

Build system: x86_64
Build-tested: ipq806x/R7800, ath79/generic, bcm27xx/bcm2711
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
Tested-by: Curtis Deptuck <curtdept@me.com> [build/run x86_64]
include/kernel-version.mk
target/linux/generic/backport-5.4/315-v5.10-usbnet-ipeth-fix-connectivity-with-ios-14.patch [deleted file]
target/linux/mediatek/patches-5.4/0600-net-phylink-propagate-resolved-link-config-via-mac_l.patch
target/linux/realtek/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch

index 11df16e9f5e98cdd1b4fb5950da44346f493100b..2633ef51072b4ca078049666389e959cd6419b9b 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .81
+LINUX_VERSION-5.4 = .82
 
-LINUX_KERNEL_HASH-5.4.81 = 9470bde475726996202d845a5fc3bc8bd3bb546bbc6816fb663fa73df25d8427
+LINUX_KERNEL_HASH-5.4.82 = fb4458e4ea38b6c5df4ee8cee0d9b0420b5aed07e273787b045c0db48709ddaf
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/generic/backport-5.4/315-v5.10-usbnet-ipeth-fix-connectivity-with-ios-14.patch b/target/linux/generic/backport-5.4/315-v5.10-usbnet-ipeth-fix-connectivity-with-ios-14.patch
deleted file mode 100644 (file)
index bb572b3..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From:   Yves-Alexis Perez <corsac@corsac.net>
-Subject: [PATCH] usbnet: ipheth: fix connectivity with iOS 14
-Date:   Thu, 19 Nov 2020 18:24:39 +0100
-Archived-At: <https://lore.kernel.org/stable/20201119172439.94988-1-corsac@corsac.net/>
-List-Post: <mailto:stable@vger.kernel.org>
-
-Starting with iOS 14 released in September 2020, connectivity using the
-personal hotspot USB tethering function of iOS devices is broken.
-
-Communication between the host and the device (for example ICMP traffic
-or DNS resolution using the DNS service running in the device itself)
-works fine, but communication to endpoints further away doesn't work.
-
-Investigation on the matter shows that UDP and ICMP traffic from the
-tethered host is reaching the Internet at all. For TCP traffic there are
-exchanges between tethered host and server but packets are modified in
-transit leading to impossible communication.
-
-After some trials Matti Vuorela discovered that reducing the URB buffer
-size by two bytes restored the previous behavior. While a better
-solution might exist to fix the issue, since the protocol is not
-publicly documented and considering the small size of the fix, let's do
-that.
-
-Tested-by: Matti Vuorela <matti.vuorela@bitfactor.fi>
-Signed-off-by: Yves-Alexis Perez <corsac@corsac.net>
-Link: https://lore.kernel.org/linux-usb/CAAn0qaXmysJ9vx3ZEMkViv_B19ju-_ExN8Yn_uSefxpjS6g4Lw@mail.gmail.com/
-Link: https://github.com/libimobiledevice/libimobiledevice/issues/1038
-Cc: stable@vger.kernel.org
----
- drivers/net/usb/ipheth.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/drivers/net/usb/ipheth.c
-+++ b/drivers/net/usb/ipheth.c
-@@ -59,7 +59,7 @@
- #define IPHETH_USBINTF_SUBCLASS 253
- #define IPHETH_USBINTF_PROTO    1
--#define IPHETH_BUF_SIZE         1516
-+#define IPHETH_BUF_SIZE         1514
- #define IPHETH_IP_ALIGN               2       /* padding at front of URB */
- #define IPHETH_TX_TIMEOUT       (5 * HZ)
index d2a9c65cdcf1c0dd2cfcf103f4f08c90bd284a19..424061ef5e664cea4016e147a285fed9abece0e5 100644 (file)
@@ -95,7 +95,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        }
  
        netif_tx_start_all_queues(port->dev);
-@@ -5124,8 +5128,11 @@ static void mvpp2_mac_config(struct phyl
+@@ -5125,8 +5129,11 @@ static void mvpp2_mac_config(struct phyl
        mvpp2_port_enable(port);
  }
  
index c61b5f6fffca676fb8a407c46b463592fbcf97e2..03accd1e076adbf95b71487b9a7424cc057446a7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -650,6 +650,10 @@ struct phy_driver {
+@@ -644,6 +644,10 @@ struct phy_driver {
                            struct ethtool_tunable *tuna,
                            const void *data);
        int (*set_loopback)(struct phy_device *dev, bool enable);